runs as a single process, handling connections with select(2). For CGIs and directory listing it does fork(2). The minimum of HTTP/1.1 and CGI/1.1 are implemented. Also supported are: chroot, setuid, basic authentication, SSL, IPv6, custom responses, aliases, and virtual hosts. The access log is written in standard CLF format. AUTHOR: Glocker Marcus <marcus@nazgul.ch> WWW: http://www.nazgul.ch/dev_nostromo.html PR: ports/155919 Submitted by: Adrian Steinmann <ast@marabu.ch>
15 lines
375 B
Text
15 lines
375 B
Text
--- src/libmy/Makefile.orig 2011-03-20 11:23:57.000000000 +0100
|
|
+++ src/libmy/Makefile 2011-03-20 11:24:15.000000000 +0100
|
|
@@ -2,9 +2,9 @@
|
|
SRCS= strcutl.c strcutw.c strcuts.c strcuti.c strcutf.c flog.c flogd.c fparse.c strlower.c strb64d.c
|
|
|
|
CFLAGS+= -Wall -Werror -Wstrict-prototypes
|
|
-NOMAN= 1
|
|
-NOPIC= 1
|
|
-NOPROFILE= 1
|
|
+NO_MAN= 1
|
|
+NO_PIC= 1
|
|
+NO_PROFILE= 1
|
|
|
|
PIPE= -pipe
|
|
|