- Changes PORTVERSION to DISTVERSION - Sets submitter as MAINTAINER. - Uses USE_GITHUB instead of MASTER_SITES - Sets LICENSE - Sets appropriate dependencies, USES, USE_X - Adds an EXAMPLES option - Adds a pkg-message to explain how the port must be used, as it is not self-evident (The software assumes all files in the same directory instead of distributed into bin/, ${DATADIR} etc so I had to find a work around: the solution is easy for the user). PR: 233772 Submitted by: Lorenzo Salvadore <phascolarctos@protonmail.ch> Reviewed by: chitty_cloud@me.com Relnotes: https://forum.z88.de/viewtopic.php?f=18&t=885
18 lines
971 B
Text
18 lines
971 B
Text
--- make/make_unix_64/z88o.mk.gcc64.orig 2017-07-17 07:14:23 UTC
|
|
+++ make/make_unix_64/z88o.mk.gcc64
|
|
@@ -11,13 +11,9 @@ DIROUT = $(DIRECA)/bin/unix64
|
|
|
|
CC = gcc
|
|
|
|
-CFLAGS = -I$(DIRCOM) -I$(DIRUNI) -O2 -fomit-frame-pointer \
|
|
- -DFR_UNIX -DFR_LINUX -DFR_XDOUB -DFR_XLONG -DFR_LINUX \
|
|
- -lm -Wl,--copy-dt-needed-entries \
|
|
- `pkg-config --cflags --libs gtk+-2.0` -lGL
|
|
+CFLAGS = -I$(DIRCOM) -I$(DIRUNI) -O2 -fomit-frame-pointer -DFR_UNIX -DFR_LINUX -DFR_XDOUB -DFR_XLONG -DFR_LINUX -lm -Wl,--copy-dt-needed-entries `pkg-config --cflags --libs gtk+-2.0` -lGL -lX11
|
|
|
|
-OBJECTSO = z88o.o cb88o.o lan88o.o dyn88o.o wlog88o.o ale88o.o rcoo88.o \
|
|
- m9.o m10.o m12.o m15.o oc88.o m16.o man88o.o gdkgl.o gtkglarea.o fr_gltext3d.o
|
|
+OBJECTSO = z88o.o cb88o.o lan88o.o dyn88o.o wlog88o.o ale88o.o rcoo88.o m9.o m10.o m12.o m15.o oc88.o m16.o man88o.o gdkgl.o gtkglarea.o fr_gltext3d.o
|
|
|
|
z88o: $(OBJECTSO)
|
|
$(CC) $(OBJECTSO) $(CFLAGS) -o $@
|