4af533cdd3
- Update to 10.0.21 - Updates mariadb100-client as well (slave-port) - Silence portlint - Re-roll patches with makepatch [1] https://mariadb.atlassian.net/browse/MDEV-7398 [2] https://mariadb.atlassian.net/browse/MDEV-8128 Changes: https://mariadb.com/kb/en/mariadb/mariadb-10021-changelog/ Differential revision: https://reviews.freebsd.org/D2771 Reviewed by: koobs (mentor), vsevolod (mentor) Approved by: vsevolod (mentor) PR: 200097 Security: 36bd352d-299b-11e5-86ff-14dae9d210b8 MFH: 2015Q3
11 lines
434 B
Text
11 lines
434 B
Text
--- scripts/CMakeLists.txt.orig 2015-06-17 14:54:12 UTC
|
|
+++ scripts/CMakeLists.txt
|
|
@@ -269,6 +269,8 @@ MACRO(EXTRACT_LINK_LIBRARIES target var)
|
|
STRING(REGEX REPLACE "^lib" "" lib "${lib}")
|
|
SET(${var} "${${var}}-l${lib} " )
|
|
ENDIF()
|
|
+ ELSEIF(lib STREQUAL "-pthread")
|
|
+ SET(${var} "${${var}}-pthread " )
|
|
ELSE()
|
|
SET(${var} "${${var}}-l${lib} " )
|
|
ENDIF()
|