db20b8b870
SeaMonkey 2.0. Lightning brings the Sunbird calendar to the popular email client, Mozilla Thunderbird and the SeaMonkey internet application suite. Since it's an extension, Lightning is tightly integrated with Thunderbird or SeaMonkey, allowing it to easily perform email-related calendaring tasks. WWW: http://www.mozilla.org/projects/calendar/lightning/ Thanks to: Andreas Tobler <andreast-list AT fgznet.ch>
729 lines
31 KiB
Text
729 lines
31 KiB
Text
diff --git a/calendar/installer/windows/Makefile.in b/calendar/installer/windows/Makefile.in
|
|
--- calendar/installer/windows/Makefile.in
|
|
+++ calendar/installer/windows/Makefile.in
|
|
@@ -147,20 +147,8 @@ uninstaller::
|
|
cat $(MOZILLA_SRCDIR)/toolkit/mozapps/installer/windows/nsis/utf16-le-bom.bin - > \
|
|
$(CONFIG_DIR)/defines.nsi
|
|
$(PERL) $(MOZILLA_SRCDIR)/toolkit/mozapps/installer/windows/nsis/preprocess-locale.pl \
|
|
$(MOZILLA_SRCDIR) $(call EXPAND_LOCALE_SRCDIR,calendar/locales)/installer $(AB_CD) \
|
|
$(CONFIG_DIR)
|
|
|
|
include $(topsrcdir)/config/rules.mk
|
|
include $(MOZILLA_SRCDIR)/toolkit/mozapps/installer/windows/nsis/makensis.mk
|
|
-
|
|
-export::
|
|
-ifndef MOZ_BRANDING_DIRECTORY
|
|
- $(NSINSTALL) -D $(DIST)/branding
|
|
- cp $(srcdir)/Header.bmp $(DIST)/branding/Header.bmp
|
|
- cp $(srcdir)/Watermrk.bmp $(DIST)/branding/Watermrk.bmp
|
|
- cp $(srcdir)/nsis/branding.nsi $(DIST)/branding/branding.nsi
|
|
- cp $(srcdir)/license.txt $(DIST)/branding/license.txt
|
|
- cp $(srcdir)/wizHeader.bmp $(DIST)/branding/wizHeader.bmp
|
|
- cp $(srcdir)/wizHeaderRTL.bmp $(DIST)/branding/wizHeaderRTL.bmp
|
|
- cp $(srcdir)/wizWatermark.bmp $(DIST)/branding/wizWatermark.bmp
|
|
-endif
|
|
diff --git a/calendar/locales/Makefile.in b/calendar/locales/Makefile.in
|
|
--- calendar/locales/Makefile.in
|
|
+++ calendar/locales/Makefile.in
|
|
@@ -49,22 +49,17 @@ ifeq ($(AB_CD),)
|
|
DIRS = ../timezones
|
|
endif
|
|
|
|
include $(topsrcdir)/config/config.mk
|
|
|
|
run_for_effects := $(shell if ! test -d $(DIST); then $(NSINSTALL) -D $(DIST); fi; if ! test -d $(DIST)/branding; then $(NSINSTALL) -D $(DIST)/branding; fi)
|
|
_ABS_DIST := $(shell cd $(DIST) && pwd)
|
|
|
|
-ifdef MOZ_BRANDING_DIRECTORY
|
|
-SUBMAKEFILES += \
|
|
- $(DEPTH)/$(MOZ_BRANDING_DIRECTORY)/Makefile \
|
|
- $(DEPTH)/$(MOZ_BRANDING_DIRECTORY)/locales/Makefile \
|
|
- $(NULL)
|
|
-endif
|
|
+SUBMAKEFILES += $(DEPTH)/$(MOZ_BRANDING_DIRECTORY)/Makefile
|
|
|
|
# This makefile uses variable overrides from the libs-% target to
|
|
# build non-default locales to non-default dist/ locations. Be aware!
|
|
|
|
AB = $(firstword $(subst -, ,$(AB_CD)))
|
|
|
|
ifdef MOZ_SUNBIRD
|
|
APP_VERSION = $(SUNBIRD_VERSION)
|
|
@@ -82,20 +77,16 @@ DEFINES += \
|
|
-DAB_CD=$(AB_CD) \
|
|
-DMOZ_LANGPACK_EID=langpack-$(AB_CD)@sunbird.mozilla.org \
|
|
-DMOZ_APP_VERSION=$(MOZ_APP_VERSION) \
|
|
-DLOCALE_SRCDIR=$(LOCALE_SRCDIR) \
|
|
-DPKG_BASENAME="$(PKG_BASENAME)" \
|
|
-DPKG_INST_BASENAME="$(PKG_INST_BASENAME)" \
|
|
$(NULL)
|
|
|
|
-ifndef MOZ_BRANDING_DIRECTORY
|
|
-DEFINES += -DMOZ_USE_GENERIC_BRANDING
|
|
-endif
|
|
-
|
|
ifeq (,$(filter-out pref,$(MOZ_EXTENSIONS)))
|
|
DEFINES += -DEXTENSION_PREF
|
|
endif
|
|
|
|
include $(topsrcdir)/config/rules.mk
|
|
|
|
tests:
|
|
ifdef MOZ_SUNBIRD
|
|
diff --git a/calendar/makefiles.sh b/calendar/makefiles.sh
|
|
--- calendar/makefiles.sh
|
|
+++ calendar/makefiles.sh
|
|
@@ -16,17 +16,18 @@
|
|
#
|
|
# The Initial Developer of the Original Code is
|
|
# Ben Turner <mozilla@songbirdnest.com>
|
|
#
|
|
# Portions created by the Initial Developer are Copyright (C) 2007
|
|
# the Initial Developer. All Rights Reserved.
|
|
#
|
|
# Contributor(s):
|
|
-# - Simon Paquet <bugzilla@babylonsounds.com>
|
|
+# Simon Paquet <bugzilla@babylonsounds.com>
|
|
+# Philipp Kewisch <mozilla@kewis.ch>
|
|
#
|
|
# Alternatively, the contents of this file may be used under the terms of
|
|
# either the GNU General Public License Version 2 or later (the "GPL"), or
|
|
# the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
|
|
# in which case the provisions of the GPL or the LGPL are applicable instead
|
|
# of those above. If you wish to allow use of your version of this file only
|
|
# under the terms of either the GPL or the LGPL, and not to allow others to
|
|
# use your version of this file under the terms of the MPL, indicate your
|
|
@@ -34,25 +35,18 @@
|
|
# and other provisions required by the GPL or the LGPL. If you do not delete
|
|
# the provisions above, a recipient may use your version of this file under
|
|
# the terms of any one of the MPL, the GPL or the LGPL.
|
|
#
|
|
# ***** END LICENSE BLOCK *****
|
|
|
|
if [ "$COMM_BUILD" ]; then
|
|
|
|
-add_makefiles "
|
|
-calendar/sunbird/Makefile
|
|
-calendar/sunbird/app/Makefile
|
|
-calendar/sunbird/base/Makefile
|
|
-calendar/sunbird/locales/Makefile
|
|
-"
|
|
+ add_makefiles "
|
|
+ calendar/sunbird/Makefile
|
|
+ calendar/sunbird/app/Makefile
|
|
+ calendar/sunbird/base/Makefile
|
|
+ calendar/sunbird/locales/Makefile
|
|
+ $MOZ_BRANDING_DIRECTORY/Makefile
|
|
+ "
|
|
|
|
-if test -n "$MOZ_BRANDING_DIRECTORY"; then
|
|
- add_makefiles "
|
|
- $MOZ_BRANDING_DIRECTORY/Makefile
|
|
- $MOZ_BRANDING_DIRECTORY/content/Makefile
|
|
- $MOZ_BRANDING_DIRECTORY/locales/Makefile
|
|
- "
|
|
+ . ${srcdir}/calendar/shared_makefiles.sh
|
|
fi
|
|
-
|
|
- . ${srcdir}/calendar/shared_makefiles.sh
|
|
-fi
|
|
diff --git a/calendar/sunbird/Makefile.in b/calendar/sunbird/Makefile.in
|
|
--- calendar/sunbird/Makefile.in
|
|
+++ calendar/sunbird/Makefile.in
|
|
@@ -45,22 +45,17 @@ VPATH = @srcdir@
|
|
include $(DEPTH)/config/autoconf.mk
|
|
|
|
DIRS = base locales app
|
|
|
|
ifeq ($(OS_ARCH),WINNT)
|
|
ifdef MOZ_INSTALLER
|
|
DIRS += ../installer/windows
|
|
|
|
-ifdef MOZ_BRANDING_DIRECTORY
|
|
-DEFINES += -DOFFICIAL_BRANDING=1
|
|
-endif
|
|
-
|
|
# For Windows build the uninstaller during the application build since the
|
|
# uninstaller is included with the application for mar file generation.
|
|
libs::
|
|
$(MAKE) -C ../installer/windows uninstaller
|
|
|
|
endif
|
|
endif
|
|
|
|
include $(topsrcdir)/config/rules.mk
|
|
-
|
|
diff --git a/calendar/sunbird/app/Makefile.in b/calendar/sunbird/app/Makefile.in
|
|
--- calendar/sunbird/app/Makefile.in
|
|
+++ calendar/sunbird/app/Makefile.in
|
|
@@ -275,64 +275,22 @@ libs:: sunbird
|
|
install:: sunbird
|
|
$(SYSINSTALL) $< $(DESTDIR)$(bindir)
|
|
|
|
GARBAGE += sunbird
|
|
GARBAGE += $(addprefix $(DIST)/bin/defaults/pref/, sunbird.js)
|
|
|
|
endif
|
|
|
|
-ifneq (,$(filter gtk gtk2,$(MOZ_WIDGET_TOOLKIT)))
|
|
-ICON_FILES = \
|
|
- $(DIST)/branding/mozicon128.png \
|
|
- $(DIST)/branding/mozicon50.xpm \
|
|
- $(DIST)/branding/mozicon16.xpm \
|
|
- $(NULL)
|
|
-
|
|
-libs:: $(ICON_FILES)
|
|
- $(INSTALL) $^ $(DIST)/bin/icons
|
|
+ifeq ($(MOZ_WIDGET_TOOLKIT),gtk2)
|
|
+libs::
|
|
+ $(INSTALL) $(IFLAGS1) $(DIST)/branding/default* $(DIST)/bin/chrome/icons/default
|
|
|
|
install::
|
|
- $(SYSINSTALL) $(IFLAGS1) $(ICON_FILES) $(DESTDIR)$(mozappdir)/icons
|
|
-endif
|
|
-
|
|
-ifeq ($(MOZ_WIDGET_TOOLKIT),gtk2)
|
|
-libs::
|
|
- $(INSTALL) $(DIST)/branding/default.xpm $(DIST)/bin/chrome/icons/default
|
|
-
|
|
-install::
|
|
- $(SYSINSTALL) $(IFLAGS1) $(DIST)/branding/default.xpm $(DESTDIR)$(mozappdir)/chrome/icons/default
|
|
-endif
|
|
-
|
|
-export::
|
|
-ifndef MOZ_BRANDING_DIRECTORY
|
|
- $(NSINSTALL) -D $(DIST)/branding
|
|
-ifeq ($(OS_ARCH),WINNT)
|
|
- cp $(srcdir)/sunbird.ico $(DIST)/branding/sunbird.ico
|
|
- cp $(srcdir)/sunbird.ico $(DIST)/branding/app.ico
|
|
- cp $(srcdir)/sunbird.ico $(DIST)/branding/document.ico
|
|
-endif
|
|
-ifneq (,$(filter mac cocoa,$(MOZ_WIDGET_TOOLKIT)))
|
|
- cp $(srcdir)/macbuild/sunbird.icns $(DIST)/branding/sunbird.icns
|
|
- cp $(srcdir)/macbuild/sb_ICS.icns $(DIST)/branding/sb_ICS.icns
|
|
- cp $(srcdir)/macbuild/dsstore $(DIST)/branding/dsstore
|
|
- cp $(srcdir)/macbuild/background.png $(DIST)/branding/background.png
|
|
- cp $(srcdir)/macbuild/disk.icns $(DIST)/branding/disk.icns
|
|
-endif
|
|
-ifneq (,$(filter gtk gtk2,$(MOZ_WIDGET_TOOLKIT)))
|
|
- cp $(srcdir)/mozicon128.png $(DIST)/branding/mozicon128.png
|
|
- cp $(srcdir)/mozicon50.xpm $(DIST)/branding/mozicon50.xpm
|
|
- cp $(srcdir)/mozicon16.xpm $(DIST)/branding/mozicon16.xpm
|
|
-endif
|
|
-ifeq ($(MOZ_WIDGET_TOOLKIT),gtk2)
|
|
- cp $(srcdir)/default.xpm $(DIST)/branding/default.xpm
|
|
-endif
|
|
-ifeq ($(OS_ARCH),OS2)
|
|
- cp $(srcdir)/sunbird-os2.ico $(DIST)/branding/sunbird.ico
|
|
-endif
|
|
+ $(SYSINSTALL) $(IFLAGS1) $(DIST)/branding/default* $(DESTDIR)$(mozappdir)/chrome/icons/default
|
|
endif
|
|
|
|
libs::
|
|
touch $(DIST)/bin/.autoreg
|
|
|
|
ifneq (,$(filter mac cocoa,$(MOZ_WIDGET_TOOLKIT)))
|
|
|
|
APP_NAME = $(MOZ_APP_DISPLAYNAME)
|
|
diff --git a/calendar/sunbird/base/Makefile.in b/calendar/sunbird/base/Makefile.in
|
|
--- calendar/sunbird/base/Makefile.in
|
|
+++ calendar/sunbird/base/Makefile.in
|
|
@@ -58,15 +58,9 @@ DEFINES += \
|
|
-DAPP_VERSION="$(APP_VERSION)" \
|
|
-DTHEME=$(THEME) \
|
|
$(NULL)
|
|
|
|
ifdef MOZ_UPDATER
|
|
DEFINES += -DMOZ_UPDATER=1
|
|
endif
|
|
|
|
-include $(topsrcdir)/config/config.mk
|
|
-
|
|
include $(topsrcdir)/config/rules.mk
|
|
-
|
|
-ifndef MOZ_BRANDING_DIRECTORY
|
|
-DEFINES += -DMOZ_USE_GENERIC_BRANDING
|
|
-endif
|
|
diff --git a/calendar/sunbird/base/jar.mn b/calendar/sunbird/base/jar.mn
|
|
--- calendar/sunbird/base/jar.mn
|
|
+++ calendar/sunbird/base/jar.mn
|
|
@@ -13,16 +13,8 @@ sunbird.jar:
|
|
content/sunbird/calendar-offline.js (content/calendar-offline.js)
|
|
content/sunbird/credits.xhtml (content/credits.xhtml)
|
|
* content/sunbird/hiddenWindow.xul (content/hiddenWindow.xul)
|
|
* content/sunbird/hiddenWindow.js (content/hiddenWindow.js)
|
|
% skin sunbird classic/1.0 %skin/sunbird/
|
|
skin/sunbird/calendar.css (themes/@THEME@/calendar.css)
|
|
skin/sunbird/toolbar.css (themes/@THEME@/toolbar.css)
|
|
skin/sunbird/offline-online.png (themes/@THEME@/offline-online.png)
|
|
-#ifdef MOZ_USE_GENERIC_BRANDING
|
|
-% content branding %content/branding/
|
|
- content/branding/about.png (branding/about.png)
|
|
- content/branding/aboutCredits.png (branding/aboutCredits.png)
|
|
- content/branding/aboutFooter.png (branding/aboutFooter.png)
|
|
- content/branding/icon64.png (branding/icon64.png)
|
|
- content/branding/icon48.png (branding/icon48.png)
|
|
-#endif
|
|
diff --git a/calendar/installer/windows/Header.bmp b/calendar/sunbird/branding/nightly/Header.bmp
|
|
rename from calendar/installer/windows/Header.bmp
|
|
rename to calendar/sunbird/branding/nightly/Header.bmp
|
|
diff --git a/calendar/sunbird/branding/nightly/Makefile.in b/calendar/sunbird/branding/nightly/Makefile.in
|
|
new file mode 100644
|
|
--- /dev/null
|
|
+++ calendar/sunbird/branding/nightly/Makefile.in
|
|
@@ -0,0 +1,81 @@
|
|
+# ***** BEGIN LICENSE BLOCK *****
|
|
+# Version: MPL 1.1/GPL 2.0/LGPL 2.1
|
|
+#
|
|
+# The contents of this file are subject to the Mozilla Public License Version
|
|
+# 1.1 (the "License"); you may not use this file except in compliance with
|
|
+# the License. You may obtain a copy of the License at
|
|
+# http://www.mozilla.org/MPL/
|
|
+#
|
|
+# Software distributed under the License is distributed on an "AS IS" basis,
|
|
+# WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
|
|
+# for the specific language governing rights and limitations under the
|
|
+# License.
|
|
+#
|
|
+# The Original Code is Mozilla Calendar code.
|
|
+#
|
|
+# The Initial Developer of the Original Code is
|
|
+# Philipp Kewisch <mozilla@kewis.ch>
|
|
+# Portions created by the Initial Developer are Copyright (C) 2009
|
|
+# the Initial Developer. All Rights Reserved.
|
|
+#
|
|
+# Contributor(s):
|
|
+# Brian Ryner <bryner@brianryner.com>
|
|
+# Matthew Willis <lilmatt@mozilla.com>
|
|
+# Robert Strong <robert.bugzilla@gmail.com>
|
|
+#
|
|
+# Alternatively, the contents of this file may be used under the terms of
|
|
+# either the GNU General Public License Version 2 or later (the "GPL"), or
|
|
+# the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
|
|
+# in which case the provisions of the GPL or the LGPL are applicable instead
|
|
+# of those above. If you wish to allow use of your version of this file only
|
|
+# under the terms of either the GPL or the LGPL, and not to allow others to
|
|
+# use your version of this file under the terms of the MPL, indicate your
|
|
+# decision by deleting the provisions above and replace them with the notice
|
|
+# and other provisions required by the GPL or the LGPL. If you do not delete
|
|
+# the provisions above, a recipient may use your version of this file under
|
|
+# the terms of any one of the MPL, the GPL or the LGPL.
|
|
+#
|
|
+# ***** END LICENSE BLOCK *****
|
|
+
|
|
+DEPTH = ../../../..
|
|
+topsrcdir = @top_srcdir@
|
|
+srcdir = @srcdir@
|
|
+VPATH = @srcdir@
|
|
+relativesrcdir = calendar/sunbird/branding/sunbird/locales
|
|
+
|
|
+include $(DEPTH)/config/autoconf.mk
|
|
+
|
|
+DEFINES += -DAB_CD=$(AB_CD)
|
|
+
|
|
+include $(topsrcdir)/config/rules.mk
|
|
+
|
|
+export::
|
|
+ $(NSINSTALL) -D $(DIST)/branding
|
|
+ifeq ($(OS_ARCH),WINNT)
|
|
+ cp $(srcdir)/sunbird.ico $(DIST)/branding/sunbird.ico
|
|
+ cp $(srcdir)/sunbird.ico $(DIST)/branding/app.ico
|
|
+ cp $(srcdir)/sunbird.ico $(DIST)/branding/document.ico
|
|
+ cp $(srcdir)/branding.nsi $(DIST)/branding/branding.nsi
|
|
+ cp $(srcdir)/wizHeader.bmp $(DIST)/branding/wizHeader.bmp
|
|
+ cp $(srcdir)/wizHeaderRTL.bmp $(DIST)/branding/wizHeaderRTL.bmp
|
|
+ cp $(srcdir)/wizWatermark.bmp $(DIST)/branding/wizWatermark.bmp
|
|
+ cp $(srcdir)/license.txt $(DIST)/branding/license.txt
|
|
+ cp $(srcdir)/Header.bmp $(DIST)/branding/Header.bmp
|
|
+ cp $(srcdir)/Watermrk.bmp $(DIST)/branding/Watermrk.bmp
|
|
+endif
|
|
+ifneq (,$(filter mac cocoa,$(MOZ_WIDGET_TOOLKIT)))
|
|
+ cp $(srcdir)/sunbird.icns $(DIST)/branding/sunbird.icns
|
|
+ cp $(srcdir)/sb_ICS.icns $(DIST)/branding/sb_ICS.icns
|
|
+ cp $(srcdir)/background.png $(DIST)/branding/background.png
|
|
+ cp $(srcdir)/dsstore $(DIST)/branding/dsstore
|
|
+ cp $(srcdir)/disk.icns $(DIST)/branding/disk.icns
|
|
+endif
|
|
+ifeq ($(MOZ_WIDGET_TOOLKIT),gtk2)
|
|
+ cp $(srcdir)/mozicon128.png $(DIST)/branding/default128.png
|
|
+ cp $(srcdir)/mozicon50.xpm $(DIST)/branding/default50.xpm
|
|
+ cp $(srcdir)/mozicon16.xpm $(DIST)/branding/default16.xpm
|
|
+ cp $(srcdir)/default.xpm $(DIST)/branding/default.xpm
|
|
+endif
|
|
+ifeq ($(OS_ARCH),OS2)
|
|
+ cp $(srcdir)/sunbird-os2.ico $(DIST)/branding/sunbird.ico
|
|
+endif
|
|
diff --git a/calendar/installer/windows/Watermrk.bmp b/calendar/sunbird/branding/nightly/Watermrk.bmp
|
|
rename from calendar/installer/windows/Watermrk.bmp
|
|
rename to calendar/sunbird/branding/nightly/Watermrk.bmp
|
|
diff --git a/calendar/sunbird/app/macbuild/background.png b/calendar/sunbird/branding/nightly/background.png
|
|
rename from calendar/sunbird/app/macbuild/background.png
|
|
rename to calendar/sunbird/branding/nightly/background.png
|
|
diff --git a/calendar/installer/windows/nsis/branding.nsi b/calendar/sunbird/branding/nightly/branding.nsi
|
|
rename from calendar/installer/windows/nsis/branding.nsi
|
|
rename to calendar/sunbird/branding/nightly/branding.nsi
|
|
diff --git a/calendar/sunbird/base/branding/about.png b/calendar/sunbird/branding/nightly/content/about.png
|
|
rename from calendar/sunbird/base/branding/about.png
|
|
rename to calendar/sunbird/branding/nightly/content/about.png
|
|
diff --git a/calendar/sunbird/base/branding/aboutCredits.png b/calendar/sunbird/branding/nightly/content/aboutCredits.png
|
|
rename from calendar/sunbird/base/branding/aboutCredits.png
|
|
rename to calendar/sunbird/branding/nightly/content/aboutCredits.png
|
|
diff --git a/calendar/sunbird/base/branding/aboutFooter.png b/calendar/sunbird/branding/nightly/content/aboutFooter.png
|
|
rename from calendar/sunbird/base/branding/aboutFooter.png
|
|
rename to calendar/sunbird/branding/nightly/content/aboutFooter.png
|
|
diff --git a/calendar/sunbird/base/branding/icon48.png b/calendar/sunbird/branding/nightly/content/icon48.png
|
|
rename from calendar/sunbird/base/branding/icon48.png
|
|
rename to calendar/sunbird/branding/nightly/content/icon48.png
|
|
diff --git a/calendar/sunbird/base/branding/icon64.png b/calendar/sunbird/branding/nightly/content/icon64.png
|
|
rename from calendar/sunbird/base/branding/icon64.png
|
|
rename to calendar/sunbird/branding/nightly/content/icon64.png
|
|
diff --git a/calendar/sunbird/app/default.xpm b/calendar/sunbird/branding/nightly/default.xpm
|
|
rename from calendar/sunbird/app/default.xpm
|
|
rename to calendar/sunbird/branding/nightly/default.xpm
|
|
diff --git a/calendar/sunbird/app/macbuild/disk.icns b/calendar/sunbird/branding/nightly/disk.icns
|
|
rename from calendar/sunbird/app/macbuild/disk.icns
|
|
rename to calendar/sunbird/branding/nightly/disk.icns
|
|
diff --git a/calendar/sunbird/app/macbuild/dsstore b/calendar/sunbird/branding/nightly/dsstore
|
|
rename from calendar/sunbird/app/macbuild/dsstore
|
|
rename to calendar/sunbird/branding/nightly/dsstore
|
|
diff --git a/calendar/sunbird/branding/nightly/jar.mn b/calendar/sunbird/branding/nightly/jar.mn
|
|
new file mode 100644
|
|
--- /dev/null
|
|
+++ calendar/sunbird/branding/nightly/jar.mn
|
|
@@ -0,0 +1,15 @@
|
|
+#filter substitution
|
|
+
|
|
+sunbird.jar:
|
|
+% content branding %content/branding/
|
|
+ content/branding/about.png (content/about.png)
|
|
+ content/branding/aboutCredits.png (content/aboutCredits.png)
|
|
+ content/branding/aboutFooter.png (content/aboutFooter.png)
|
|
+ content/branding/icon64.png (content/icon64.png)
|
|
+ content/branding/icon48.png (content/icon48.png)
|
|
+
|
|
+@AB_CD@.jar:
|
|
+% locale branding @AB_CD@ %locale/branding/
|
|
+# Calendar branding only exists in en-US
|
|
+ locale/branding/brand.dtd (locales/en-US/brand.dtd)
|
|
+* locale/branding/brand.properties (locales/en-US/brand.properties)
|
|
diff --git a/calendar/installer/windows/license.txt b/calendar/sunbird/branding/nightly/license.txt
|
|
rename from calendar/installer/windows/license.txt
|
|
rename to calendar/sunbird/branding/nightly/license.txt
|
|
diff --git a/calendar/locales/en-US/chrome/branding/brand.dtd b/calendar/sunbird/branding/nightly/locales/en-US/brand.dtd
|
|
rename from calendar/locales/en-US/chrome/branding/brand.dtd
|
|
rename to calendar/sunbird/branding/nightly/locales/en-US/brand.dtd
|
|
diff --git a/calendar/locales/en-US/chrome/branding/brand.properties b/calendar/sunbird/branding/nightly/locales/en-US/brand.properties
|
|
rename from calendar/locales/en-US/chrome/branding/brand.properties
|
|
rename to calendar/sunbird/branding/nightly/locales/en-US/brand.properties
|
|
diff --git a/calendar/sunbird/app/mozicon128.png b/calendar/sunbird/branding/nightly/mozicon128.png
|
|
rename from calendar/sunbird/app/mozicon128.png
|
|
rename to calendar/sunbird/branding/nightly/mozicon128.png
|
|
diff --git a/calendar/sunbird/app/mozicon16.xpm b/calendar/sunbird/branding/nightly/mozicon16.xpm
|
|
rename from calendar/sunbird/app/mozicon16.xpm
|
|
rename to calendar/sunbird/branding/nightly/mozicon16.xpm
|
|
diff --git a/calendar/sunbird/app/mozicon50.xpm b/calendar/sunbird/branding/nightly/mozicon50.xpm
|
|
rename from calendar/sunbird/app/mozicon50.xpm
|
|
rename to calendar/sunbird/branding/nightly/mozicon50.xpm
|
|
diff --git a/calendar/sunbird/app/macbuild/sb_ICS.icns b/calendar/sunbird/branding/nightly/sb_ICS.icns
|
|
rename from calendar/sunbird/app/macbuild/sb_ICS.icns
|
|
rename to calendar/sunbird/branding/nightly/sb_ICS.icns
|
|
diff --git a/calendar/sunbird/app/sunbird-os2.ico b/calendar/sunbird/branding/nightly/sunbird-os2.ico
|
|
rename from calendar/sunbird/app/sunbird-os2.ico
|
|
rename to calendar/sunbird/branding/nightly/sunbird-os2.ico
|
|
diff --git a/calendar/sunbird/app/macbuild/sunbird.icns b/calendar/sunbird/branding/nightly/sunbird.icns
|
|
rename from calendar/sunbird/app/macbuild/sunbird.icns
|
|
rename to calendar/sunbird/branding/nightly/sunbird.icns
|
|
diff --git a/calendar/sunbird/app/sunbird.ico b/calendar/sunbird/branding/nightly/sunbird.ico
|
|
rename from calendar/sunbird/app/sunbird.ico
|
|
rename to calendar/sunbird/branding/nightly/sunbird.ico
|
|
diff --git a/calendar/installer/windows/wizHeader.bmp b/calendar/sunbird/branding/nightly/wizHeader.bmp
|
|
rename from calendar/installer/windows/wizHeader.bmp
|
|
rename to calendar/sunbird/branding/nightly/wizHeader.bmp
|
|
diff --git a/calendar/installer/windows/wizHeaderRTL.bmp b/calendar/sunbird/branding/nightly/wizHeaderRTL.bmp
|
|
rename from calendar/installer/windows/wizHeaderRTL.bmp
|
|
rename to calendar/sunbird/branding/nightly/wizHeaderRTL.bmp
|
|
diff --git a/calendar/installer/windows/wizWatermark.bmp b/calendar/sunbird/branding/nightly/wizWatermark.bmp
|
|
rename from calendar/installer/windows/wizWatermark.bmp
|
|
rename to calendar/sunbird/branding/nightly/wizWatermark.bmp
|
|
diff --git a/calendar/sunbird/locales/Makefile.in b/calendar/sunbird/locales/Makefile.in
|
|
--- calendar/sunbird/locales/Makefile.in
|
|
+++ calendar/sunbird/locales/Makefile.in
|
|
@@ -50,20 +50,16 @@ README_FILES= \
|
|
|
|
APP_VERSION = $(SUNBIRD_VERSION)
|
|
DEFINES += \
|
|
-DAB_CD="$(AB_CD)" \
|
|
-DLOCALE_SRCDIR=$(LOCALE_SRCDIR) \
|
|
-DAPP_VERSION="$(APP_VERSION)" \
|
|
$(NULL)
|
|
|
|
-ifndef MOZ_BRANDING_DIRECTORY
|
|
-DEFINES += -DMOZ_USE_GENERIC_BRANDING
|
|
-endif
|
|
-
|
|
include $(topsrcdir)/config/rules.mk
|
|
|
|
libs:: $(addprefix $(LOCALE_SRCDIR)/,$(README_FILES))
|
|
ifeq ($(OS_ARCH),WINNT)
|
|
$(EXIT_ON_ERROR) \
|
|
for file in $^; do \
|
|
$(PERL) -pe 's/(?<!\r)\n/\r\n/g;' < $$file > $(FINAL_TARGET)/`basename $$file`; \
|
|
done
|
|
diff --git a/calendar/sunbird/locales/jar.mn b/calendar/sunbird/locales/jar.mn
|
|
--- calendar/sunbird/locales/jar.mn
|
|
+++ calendar/sunbird/locales/jar.mn
|
|
@@ -1,17 +1,10 @@
|
|
#filter substitution
|
|
|
|
-#ifdef MOZ_USE_GENERIC_BRANDING
|
|
-@AB_CD@.jar:
|
|
-% locale branding @AB_CD@ %locale/branding/
|
|
-+ locale/branding/brand.dtd (%chrome/branding/brand.dtd)
|
|
-+ locale/branding/brand.properties (%chrome/branding/brand.properties)
|
|
-#endif
|
|
-
|
|
sunbird-@AB_CD@.jar:
|
|
% locale sunbird @AB_CD@ %locale/@AB_CD@/sunbird/
|
|
locale/@AB_CD@/sunbird/aboutDialog.dtd (%chrome/sunbird/aboutDialog.dtd)
|
|
locale/@AB_CD@/sunbird/menuOverlay.dtd (%chrome/sunbird/menuOverlay.dtd)
|
|
locale/@AB_CD@/sunbird/sunbird.dtd (%chrome/sunbird/sunbird.dtd)
|
|
|
|
# Extra l10n files for documentation and such
|
|
#includesubst @LOCALE_SRCDIR@/extra-jar.mn
|
|
diff --git a/other-licenses/branding/sunbird/Makefile.in b/other-licenses/branding/sunbird/Makefile.in
|
|
--- other-licenses/branding/sunbird/Makefile.in
|
|
+++ other-licenses/branding/sunbird/Makefile.in
|
|
@@ -1,57 +1,84 @@
|
|
-# Branding Makefile
|
|
-# - jars chrome artwork
|
|
-# - copies artwork to appropriate places in objdir for bundling into app
|
|
-# resources
|
|
+# ***** BEGIN LICENSE BLOCK *****
|
|
+# Version: MPL 1.1/GPL 2.0/LGPL 2.1
|
|
+#
|
|
+# The contents of this file are subject to the Mozilla Public License Version
|
|
+# 1.1 (the "License"); you may not use this file except in compliance with
|
|
+# the License. You may obtain a copy of the License at
|
|
+# http://www.mozilla.org/MPL/
|
|
+#
|
|
+# Software distributed under the License is distributed on an "AS IS" basis,
|
|
+# WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
|
|
+# for the specific language governing rights and limitations under the
|
|
+# License.
|
|
+#
|
|
+# The Original Code is Mozilla Calendar code.
|
|
+#
|
|
+# The Initial Developer of the Original Code is
|
|
+# Matthew Willis <lilmatt@mozilla.com>
|
|
+# Portions created by the Initial Developer are Copyright (C) 2006
|
|
+# the Initial Developer. All Rights Reserved.
|
|
+#
|
|
+# Contributor(s):
|
|
+# Robert Strong <robert.bugzilla@gmail.com>
|
|
+# Philipp Kewisch <mozilla@kewis.ch>
|
|
+#
|
|
+# Alternatively, the contents of this file may be used under the terms of
|
|
+# either the GNU General Public License Version 2 or later (the "GPL"), or
|
|
+# the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
|
|
+# in which case the provisions of the GPL or the LGPL are applicable instead
|
|
+# of those above. If you wish to allow use of your version of this file only
|
|
+# under the terms of either the GPL or the LGPL, and not to allow others to
|
|
+# use your version of this file under the terms of the MPL, indicate your
|
|
+# decision by deleting the provisions above and replace them with the notice
|
|
+# and other provisions required by the GPL or the LGPL. If you do not delete
|
|
+# the provisions above, a recipient may use your version of this file under
|
|
+# the terms of any one of the MPL, the GPL or the LGPL.
|
|
+#
|
|
+# ***** END LICENSE BLOCK *****
|
|
|
|
DEPTH = ../../..
|
|
topsrcdir = @top_srcdir@
|
|
srcdir = @srcdir@
|
|
VPATH = @srcdir@
|
|
+relativesrcdir = other-licenses/branding/sunbird/locales
|
|
|
|
include $(DEPTH)/config/autoconf.mk
|
|
|
|
-DIRS = \
|
|
- content \
|
|
- locales \
|
|
- $(NULL)
|
|
+DEFINES += -DAB_CD=$(AB_CD)
|
|
|
|
include $(topsrcdir)/config/rules.mk
|
|
|
|
-CALENDAR_APP_FILES = \
|
|
- default.xpm \
|
|
- mozicon128.png \
|
|
- mozicon16.xpm \
|
|
- mozicon50.xpm \
|
|
- sunbird.ico \
|
|
- $(NULL)
|
|
-
|
|
export::
|
|
$(NSINSTALL) -D $(DIST)/branding
|
|
- cp $(addprefix $(srcdir)/, $(CALENDAR_APP_FILES)) $(DIST)/branding/
|
|
-ifneq (,$(filter gtk gtk2,$(MOZ_WIDGET_TOOLKIT)))
|
|
- $(NSINSTALL) -D $(DIST)/install
|
|
- cp $(srcdir)/header.png $(DIST)/install/header.png
|
|
- cp $(srcdir)/watermark.png $(DIST)/install/watermark.png
|
|
+ifeq ($(OS_ARCH),WINNT)
|
|
+ cp $(srcdir)/sunbird.ico $(DIST)/branding/sunbird.ico
|
|
+ cp $(srcdir)/sunbird.ico $(DIST)/branding/app.ico
|
|
+ cp $(srcdir)/branding.nsi $(DIST)/branding/branding.nsi
|
|
+ cp $(srcdir)/wizHeader.bmp $(DIST)/branding/wizHeader.bmp
|
|
+ cp $(srcdir)/wizHeaderRTL.bmp $(DIST)/branding/wizHeaderRTL.bmp
|
|
+ cp $(srcdir)/wizWatermark.bmp $(DIST)/branding/wizWatermark.bmp
|
|
+ cp $(srcdir)/license.txt $(DIST)/branding/license.txt
|
|
+ cp $(srcdir)/Header.bmp $(DIST)/branding/Header.bmp
|
|
+ cp $(srcdir)/Watermrk.bmp $(DIST)/branding/Watermrk.bmp
|
|
endif
|
|
ifneq (,$(filter mac cocoa,$(MOZ_WIDGET_TOOLKIT)))
|
|
- cp $(srcdir)/sunbird.icns $(DIST)/branding/sunbird.icns
|
|
- cp $(srcdir)/sb_ICS.icns $(DIST)/branding/sb_ICS.icns
|
|
- cp $(srcdir)/document.icns $(DIST)/branding/document.icns
|
|
- cp $(srcdir)/dsstore $(DIST)/branding/dsstore
|
|
- cp $(srcdir)/background.png $(DIST)/branding/background.png
|
|
- cp $(srcdir)/disk.icns $(DIST)/branding/disk.icns
|
|
- cp $(srcdir)/license.r $(DIST)/branding/license.r
|
|
+ cp $(srcdir)/sunbird.icns $(DIST)/branding/sunbird.icns
|
|
+ cp $(srcdir)/sb_ICS.icns $(DIST)/branding/sb_ICS.icns
|
|
+ cp $(srcdir)/document.icns $(DIST)/branding/document.icns
|
|
+ cp $(srcdir)/dsstore $(DIST)/branding/dsstore
|
|
+ cp $(srcdir)/background.png $(DIST)/branding/background.png
|
|
+ cp $(srcdir)/disk.icns $(DIST)/branding/disk.icns
|
|
+ cp $(srcdir)/license.r $(DIST)/branding/license.r
|
|
endif
|
|
-ifeq ($(OS_ARCH),WINNT)
|
|
- cp $(srcdir)/sunbird.ico $(DIST)/branding/app.ico
|
|
- cp $(srcdir)/Header.bmp $(DIST)/branding/Header.bmp
|
|
- cp $(srcdir)/Watermrk.bmp $(DIST)/branding/Watermrk.bmp
|
|
- cp $(srcdir)/branding.nsi $(DIST)/branding/branding.nsi
|
|
- cp $(srcdir)/license.txt $(DIST)/branding/license.txt
|
|
- cp $(srcdir)/wizHeader.bmp $(DIST)/branding/wizHeader.bmp
|
|
- cp $(srcdir)/wizHeaderRTL.bmp $(DIST)/branding/wizHeaderRTL.bmp
|
|
- cp $(srcdir)/wizWatermark.bmp $(DIST)/branding/wizWatermark.bmp
|
|
+ifneq (,$(filter gtk gtk2,$(MOZ_WIDGET_TOOLKIT)))
|
|
+ cp $(srcdir)/mozicon128.png $(DIST)/branding/default128.png
|
|
+ cp $(srcdir)/mozicon50.xpm $(DIST)/branding/default50.xpm
|
|
+ cp $(srcdir)/mozicon16.xpm $(DIST)/branding/default16.xpm
|
|
+ cp $(srcdir)/default.xpm $(DIST)/branding/default.xpm
|
|
+ $(NSINSTALL) -D $(DIST)/install
|
|
+ cp $(srcdir)/header.png $(DIST)/install/header.png
|
|
+ cp $(srcdir)/watermark.png $(DIST)/install/watermark.png
|
|
endif
|
|
ifeq ($(OS_ARCH),OS2)
|
|
- cp $(srcdir)/sunbird-os2.ico $(DIST)/branding/sunbird.ico
|
|
+ cp $(srcdir)/sunbird-os2.ico $(DIST)/branding/sunbird.ico
|
|
endif
|
|
diff --git a/other-licenses/branding/sunbird/content/Makefile.in b/other-licenses/branding/sunbird/content/Makefile.in
|
|
deleted file mode 100644
|
|
--- other-licenses/branding/sunbird/content/Makefile.in
|
|
+++ /dev/null
|
|
@@ -1,11 +0,0 @@
|
|
-# Branding Makefile
|
|
-# - jars chrome artwork
|
|
-
|
|
-DEPTH = ../../../..
|
|
-topsrcdir = @top_srcdir@
|
|
-srcdir = @srcdir@
|
|
-VPATH = @srcdir@
|
|
-
|
|
-include $(DEPTH)/config/autoconf.mk
|
|
-
|
|
-include $(topsrcdir)/config/rules.mk
|
|
diff --git a/other-licenses/branding/sunbird/content/jar.mn b/other-licenses/branding/sunbird/content/jar.mn
|
|
deleted file mode 100644
|
|
--- other-licenses/branding/sunbird/content/jar.mn
|
|
+++ /dev/null
|
|
@@ -1,7 +0,0 @@
|
|
-calendar.jar:
|
|
-% content branding %content/branding/ xpcnativewrappers=yes
|
|
- content/branding/about.png (about.png)
|
|
- content/branding/aboutCredits.png (aboutCredits.png)
|
|
- content/branding/aboutFooter.png (aboutFooter.png)
|
|
- content/branding/icon64.png (icon64.png)
|
|
- content/branding/icon48.png (icon48.png)
|
|
diff --git a/other-licenses/branding/sunbird/jar.mn b/other-licenses/branding/sunbird/jar.mn
|
|
new file mode 100644
|
|
--- /dev/null
|
|
+++ other-licenses/branding/sunbird/jar.mn
|
|
@@ -0,0 +1,14 @@
|
|
+#filter substitution
|
|
+
|
|
+calendar.jar:
|
|
+% content branding %content/branding/ xpcnativewrappers=yes
|
|
+ content/branding/about.png (content/about.png)
|
|
+ content/branding/aboutCredits.png (content/aboutCredits.png)
|
|
+ content/branding/aboutFooter.png (content/aboutFooter.png)
|
|
+ content/branding/icon64.png (content/icon64.png)
|
|
+ content/branding/icon48.png (content/icon48.png)
|
|
+
|
|
+@AB_CD@.jar:
|
|
+% locale branding @AB_CD@ %locale/branding/
|
|
+ locale/branding/brand.dtd (locales/en-US/brand.dtd)
|
|
+ locale/branding/brand.properties (locales/en-US/brand.properties)
|
|
diff --git a/other-licenses/branding/sunbird/locales/Makefile.in b/other-licenses/branding/sunbird/locales/Makefile.in
|
|
deleted file mode 100644
|
|
--- other-licenses/branding/sunbird/locales/Makefile.in
|
|
+++ /dev/null
|
|
@@ -1,48 +0,0 @@
|
|
-# ***** BEGIN LICENSE BLOCK *****
|
|
-# Version: MPL 1.1/GPL 2.0/LGPL 2.1
|
|
-#
|
|
-# The contents of this file are subject to the Mozilla Public License Version
|
|
-# 1.1 (the "License"); you may not use this file except in compliance with
|
|
-# the License. You may obtain a copy of the License at
|
|
-# http://www.mozilla.org/MPL/
|
|
-#
|
|
-# Software distributed under the License is distributed on an "AS IS" basis,
|
|
-# WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
|
|
-# for the specific language governing rights and limitations under the
|
|
-# License.
|
|
-#
|
|
-# The Original Code is the Mozilla Browser code.
|
|
-#
|
|
-# The Initial Developer of the Original Code is
|
|
-# Benjamin Smedberg <benjamin@smedbergs.us>
|
|
-# Portions created by the Initial Developer are Copyright (C) 2004
|
|
-# the Initial Developer. All Rights Reserved.
|
|
-#
|
|
-# Contributor(s):
|
|
-#
|
|
-# Alternatively, the contents of this file may be used under the terms of
|
|
-# either the GNU General Public License Version 2 or later (the "GPL"), or
|
|
-# the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
|
|
-# in which case the provisions of the GPL or the LGPL are applicable instead
|
|
-# of those above. If you wish to allow use of your version of this file only
|
|
-# under the terms of either the GPL or the LGPL, and not to allow others to
|
|
-# use your version of this file under the terms of the MPL, indicate your
|
|
-# decision by deleting the provisions above and replace them with the notice
|
|
-# and other provisions required by the GPL or the LGPL. If you do not delete
|
|
-# the provisions above, a recipient may use your version of this file under
|
|
-# the terms of any one of the MPL, the GPL or the LGPL.
|
|
-#
|
|
-# ***** END LICENSE BLOCK *****
|
|
-
|
|
-DEPTH = ../../../..
|
|
-topsrcdir = @top_srcdir@
|
|
-srcdir = @srcdir@
|
|
-VPATH = @srcdir@
|
|
-relativesrcdir = other-licenses/branding/sunbird/locales
|
|
-
|
|
-include $(DEPTH)/config/autoconf.mk
|
|
-
|
|
-DEFINES += -DAB_CD=$(AB_CD) -DMOZ_DISTRIBUTION_ID_UNQUOTED=$(MOZ_DISTRIBUTION_ID)
|
|
-
|
|
-include $(topsrcdir)/config/rules.mk
|
|
-
|
|
diff --git a/other-licenses/branding/sunbird/locales/jar.mn b/other-licenses/branding/sunbird/locales/jar.mn
|
|
deleted file mode 100644
|
|
--- other-licenses/branding/sunbird/locales/jar.mn
|
|
+++ /dev/null
|
|
@@ -1,6 +0,0 @@
|
|
-#filter substitution
|
|
-
|
|
-@AB_CD@.jar:
|
|
-% locale branding @AB_CD@ %locale/branding/
|
|
- locale/branding/brand.dtd (%brand.dtd)
|
|
- locale/branding/brand.properties (%brand.properties)
|