freebsd-ports/print/cups-base/files/patch-scheduler__dirsvc.c
Jason E. Hale 89fe55a74a - Update to 1.7.3
- Add DOCS option
- PHP option no longer installs a PHP module (it was eliminated in 1.6)
- Add options for other interpreters
- Add OPENSSL option to make it clearer that it is enabled instead of GNUTLS
- Fix build when ZEROCONF is disabled
- Fix detection of libusb on FreeBSD < 10 as they do not have .pc files for it
- Use @sample directive in pkg-plist
- Remove some old cruft
2014-07-01 19:15:35 +00:00

41 lines
1 KiB
C

--- ./scheduler/dirsvc.c.orig 2014-03-05 16:11:32.000000000 -0500
+++ ./scheduler/dirsvc.c 2014-06-30 11:02:48.000000000 -0400
@@ -237,11 +237,13 @@
if (BrowseLocalProtocols & BROWSE_SMB)
update_smb(1);
+#if defined(HAVE_DNSSD) || defined(HAVE_AVAHI)
/*
* Register the individual printers
*/
dnssdRegisterAllPrinters(0);
+#endif /* HAVE_DNSSD || HAVE_AVAHI */
}
@@ -255,6 +257,7 @@
if (!Browsing || !BrowseLocalProtocols)
return;
+#if defined(HAVE_DNSSD) || defined(HAVE_AVAHI)
/*
* De-register the individual printers
*/
@@ -265,7 +268,6 @@
* Shut down browsing sockets...
*/
-#if defined(HAVE_DNSSD) || defined(HAVE_AVAHI)
if ((BrowseLocalProtocols & BROWSE_DNSSD) && DNSSDMaster)
dnssdStop();
#endif /* HAVE_DNSSD || HAVE_AVAHI */
@@ -1548,7 +1550,7 @@
if (i)
*bufptr++ = ',';
- strlcpy(bufptr, p->auth_info_required[i], bufsize - (bufptr - buffer));
+ strlcpy(bufptr, p->auth_info_required[i], bufsize - (size_t)(bufptr - buffer));
bufptr += strlen(bufptr);
}