freebsd-ports/mail/thunderbird-esr/files/patch-security-coreconf-FreeBSD.mk
Joe Marcus Clarke abbdc87752 * Instead of using Xvfb, and evil black magic to create the extensions
repository, use the hidden "-register" option instead.  This has the
  advantage of not requiring an X DISPLAY and not modifying any
  preferences.
* Add i18n support to the Thunderbird startup script [1]
* Link nss with -Bsymbolic to avoid symbol conflicts with OpenSSL.  This
  should help alleviate the CUPS printing problem

PR:		73839 [1]
Submitted by:	Jose M Rodriguez <josemi@freebsd.jazztel.es> [1]
2004-11-22 04:16:25 +00:00

28 lines
702 B
Makefile

--- security/coreconf/FreeBSD.mk.orig Wed Mar 26 20:17:25 2003
+++ security/coreconf/FreeBSD.mk Sun Nov 21 22:59:49 2004
@@ -43,8 +43,12 @@
ifeq ($(OS_TEST),alpha)
CPU_ARCH = alpha
else
+ifeq ($(OS_TEST),amd64)
+CPU_ARCH = amd64
+else
CPU_ARCH = x86
endif
+endif
OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
@@ -71,7 +75,11 @@
DLL_SUFFIX = so.1.0
endif
-MKSHLIB = $(CC) $(DSO_LDOPTS)
+ifneq (,$(filter alpha ia64,$(OS_TEST)))
+MKSHLIB = $(CC) -Wl,-Bsymbolic -lc $(DSO_LDOPTS) -o $@
+else
+MKSHLIB = $(CC) -Wl,-Bsymbolic $(DSO_LDOPTS) -o $@
+endif
ifdef MAPFILE
# Add LD options to restrict exported symbols to those in the map file
endif