freebsd-ports/graphics/panorama/files/patch-ltmain.sh
Kirill Ponomarev 7f29f09f56 - Fix LIB_DEPENDS
- Support CFLAGS/CXXFLAGS properly
- Fix pkg-plist

PR:		60270
Submitted by:	Ports Fury
2003-12-15 21:09:56 +00:00

33 lines
902 B
Bash

--- ltmain.sh.orig Wed Feb 12 11:23:37 2003
+++ ltmain.sh Fri Dec 12 14:34:27 2003
@@ -944,6 +944,7 @@
;;
-avoid-version)
+ build_old_libs=no
avoid_version=yes
continue
;;
@@ -2408,6 +2409,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
if test $build_libtool_need_lc = "yes"; then
@@ -4175,10 +4179,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"