81b2b426df
duplicated headers.
27 lines
1.2 KiB
Text
27 lines
1.2 KiB
Text
--- configure.ac.orig 2011-08-12 15:36:55.000000000 +0200
|
|
+++ configure.ac 2011-08-30 01:46:23.000000000 +0200
|
|
@@ -39,22 +39,8 @@
|
|
# Check for python
|
|
AC_CHECK_PROGS(PYTHON, [python3 python3.1 python3.2 python2.7 python2.6 python2.5 python2 python], [AC_MSG_ERROR([Python is needed to build this vmod, please install python.])])
|
|
|
|
-# Varnish source tree
|
|
-AC_ARG_VAR([VARNISHSRC], [path to Varnish source tree (mandatory)])
|
|
-if test "x$VARNISHSRC" = x; then
|
|
- AC_MSG_ERROR([No Varnish source tree specified])
|
|
-fi
|
|
-VARNISHSRC=`cd $VARNISHSRC && pwd`
|
|
-AC_CHECK_FILE([$VARNISHSRC/include/varnishapi.h],
|
|
- [],
|
|
- [AC_MSG_FAILURE(["$VARNISHSRC" is not a Varnish source directory])]
|
|
-)
|
|
-
|
|
-# Check that varnishtest is built in the varnish source directory
|
|
-AC_CHECK_FILE([$VARNISHSRC/bin/varnishtest/varnishtest],
|
|
- [],
|
|
- [AC_MSG_FAILURE([Can't find "$VARNISHSRC/bin/varnishtest/varnishtest". Please build your varnish source directory])]
|
|
-)
|
|
+AC_CHECK_HEADERS([varnish/varnishapi.h], , AC_MSG_ERROR([Could not find varnish/varnishapi.h]))
|
|
+AC_CHECK_PROGS(VARNISHTEST, varnishtest, [AC_MSG_ERROR([Could not find varnishtest binary])])
|
|
|
|
# vmod installation dir
|
|
AC_ARG_VAR([VMODDIR], [vmod installation directory @<:@LIBDIR/varnish/vmods@:>@])
|