8165354577
This is mostly Greg's patch, I have added the new ports to games/Makefile (missing from PR, SUBDIR+=), and fixed a few spaces-vs-TAB glitches in the makefile, and reformatted the pkg-descr, and changed libretro-shaders-slang/pkg-descr to: | Vulkan GLSL RetroArch shader system | | WWW: https://github.com/libretro/slang-shaders v1: Here's 1.8.5. v2 of 1.8.5 update: - Fixed stage-qa (python/shebangfix) - Moved fPIC from port variable to PR/patch: https://github.com/libretro/RetroArch/pull/10384 - Fixed build with security/rhash installed: https://github.com/libretro/RetroArch/pull/10382 - Fixed ifdefs to solve powerpc64 issue: https://github.com/libretro/RetroArch/pull/10383 - Made X11 an option - Added libcaca option (the build system was auto finding this for me) v3: One little revision, fixing the dependency on libwayland-egl, which has been living in wayland instead of mesa for a long time. v4: Rebased after the webcamd/v4l related update Test built in poudriere 11.3 i386 and 12.1 amd64. PR: 227345 Submitted by: Greg V <greg@unrelenting.technology> (maintainer)
17 lines
403 B
Text
17 lines
403 B
Text
--- Makefile.orig 2018-04-07 12:50:09 UTC
|
|
+++ Makefile
|
|
@@ -1,4 +1,4 @@
|
|
-PREFIX := /usr
|
|
+PREFIX ?= /usr
|
|
INSTALLDIR := $(PREFIX)/share/libretro/assets
|
|
|
|
all:
|
|
@@ -6,7 +6,7 @@ all:
|
|
|
|
install:
|
|
mkdir -p $(DESTDIR)$(INSTALLDIR)
|
|
- cp -ar * $(DESTDIR)$(INSTALLDIR)
|
|
+ cp -a * $(DESTDIR)$(INSTALLDIR)
|
|
rm -rf $(DESTDIR)$(INSTALLDIR)/Makefile \
|
|
$(DESTDIR)$(INSTALLDIR)/configure \
|
|
$(DESTDIR)$(INSTALLDIR)/src
|