freebsd-ports/security/axTLS/files/patch-Makefile
Felippe de Meirelles Motta 22bc3c69b9 The axTLS project is an SSL client/server library using the TLSv1
protocol.  It is designed to be small and fast, and is suited to
embedded projects.  A web server is included.

WWW: http://http://axtls.sourceforge.net/

PR:		ports/177790
Submitted by:	Hirohisa Yamaguchi <umq@ueo.co.jp>
2013-06-28 20:55:58 +00:00

13 lines
520 B
Text

--- ./Makefile.orig 2011-01-07 22:16:40.000000000 +0900
+++ ./Makefile 2013-04-11 08:38:38.000000000 +0900
@@ -118,7 +118,9 @@
-@rm `perl -e 'use Config; print $$Config{installarchlib};'`/axtlsp.pm > /dev/null 2>&1
test:
- cd $(STAGE); ssltest; ../ssl/test/test_axssl.sh; cd -;
+ cd $(STAGE); [ -e ./ssltest ] && LD_LIBRARY_PATH=".:$${LD_LIBRARY_PATH}" ./ssltest ;\
+ [ -e ./perf_bigint ] && LD_LIBRARY_PATH=".:$${LD_LIBRARY_PATH}" ./perf_bigint ;\
+ ../ssl/test/test_axssl.sh; cd -;
# tidy up things
clean::