freebsd-ports/databases/percona55-server/files/patch-support-files_CMakeLists.txt
Alex Dupre d9029c5139 Update MySQL to 5.5.8 GA release. Read UPDATING.
Major changes:
- new installation layout, resembling RPM packages:
  - client = Client Utilities + Development Libraries + Shared components
  - server = MySQL Server + Embedded
- new build system: cmake instead of autotools
- fewer port knobs

Expect various breakages, but if we are lucky this could become the new default
mysql port.
2010-12-27 15:02:38 +00:00

12 lines
634 B
Text

--- support-files/CMakeLists.txt.orig 2010-12-23 17:38:19.000000000 +0100
+++ support-files/CMakeLists.txt 2010-12-23 17:41:11.000000000 +0100
@@ -74,7 +74,9 @@
INSTALL(FILES magic DESTINATION ${inst_location} COMPONENT SupportFiles)
ENDIF()
+IF(FALSE)
INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
+ENDIF()
CONFIGURE_FILE(MySQL-shared-compat.spec.sh ${CMAKE_CURRENT_BINARY_DIR}/MySQL-shared-compat.spec @ONLY)
CONFIGURE_FILE(mysql.spec.sh ${CMAKE_CURRENT_BINARY_DIR}/mysql.spec @ONLY)
CONFIGURE_FILE(mysql.spec.sh ${CMAKE_CURRENT_BINARY_DIR}/mysql.${VERSION}.spec @ONLY)