b549a1416b
- fix build with gcc-3.4; - fix sortedp.c and zbogotest to handle empty files properly; - add a 'test' target; - use INFO and PLIST_FILES and nuke pkg-plist. And yes, I know that adding HAVE_STRING_H to config.h.in is somewhat hackish; the proper fix - a string.h check in configure.in - is on its way to the bogosort developers :)
11 lines
259 B
C
11 lines
259 B
C
--- sortedp.c.orig Wed Aug 11 15:30:34 2004
|
|
+++ sortedp.c Wed Aug 11 15:30:49 2004
|
|
@@ -38,6 +38,8 @@
|
|
{
|
|
int i;
|
|
|
|
+ if (lines[0] == NULL)
|
|
+ return 1;
|
|
for (i = 1; lines[i] != NULL; i++)
|
|
if (strcmp(lines[i - 1], lines[i]) > 0)
|
|
return 0;
|