freebsd-ports/net/nagios/files/patch-ad
Jun Kuriyama 5124709f8c (1) Fix HTML generation of tac.cgi.
(2) Fix to detect gd1 library.

Submitted by:	Bradley Dean <bjdean@unimelb.edu.au> (1),
		kuriyama (2)
Approved by:	maintainer
2003-08-02 15:02:05 +00:00

69 lines
2.2 KiB
Text

--- configure.orig Tue Jun 3 12:47:57 2003
+++ configure Thu Jul 31 16:35:45 2003
@@ -11,7 +11,7 @@
ac_help=
ac_default_prefix=/usr/local
# Any additions from configure.in:
-ac_default_prefix=/usr/local/nagios
+#ac_default_prefix=/usr/local/nagios
ac_help="$ac_help
--with-nagios-user=<user> sets user name to run nagios"
ac_help="$ac_help
@@ -576,9 +576,9 @@
# Prefer explicitly selected file to automatically selected ones.
if test -z "$CONFIG_SITE"; then
if test "x$prefix" != xNONE; then
- CONFIG_SITE="$prefix/share/config.site $prefix/etc/config.site"
+ CONFIG_SITE="$prefix/share/nagios/config.site $prefix/etc/nagios/config.site"
else
- CONFIG_SITE="$ac_default_prefix/share/config.site $ac_default_prefix/etc/config.site"
+ CONFIG_SITE="$ac_default_prefix/share/nagios/config.site $ac_default_prefix/etc/nagios/config.site"
fi
fi
for ac_site_file in $CONFIG_SITE; do
@@ -2608,6 +2608,9 @@
LDFLAGS="${LDFLAGS} -L${withval}"
LD_RUN_PATH="${withval}${LD_RUN_PATH:+:}${LD_RUN_PATH}"
+else
+ LDFLAGS="${LDFLAGS} -L/usr/local/lib"
+ LD_RUN_PATH="/usr/local/ib${LD_RUN_PATH:+:}${LD_RUN_PATH}"
fi
# Check whether --with-gd-inc or --without-gd-inc was given.
@@ -2615,6 +2618,8 @@
withval="$with_gd_inc"
CFLAGS="${CFLAGS} -I${withval}"
+else
+ CFLAGS="${CFLAGS} -I/usr/local/include/gd"
fi
@@ -2748,14 +2753,14 @@
fi
if test x$GDLIBFOUND = x; then
- echo $ac_n "checking for gdImagePng in -lgd (order 3)""... $ac_c" 1>&6
-echo "configure:2753: checking for gdImagePng in -lgd (order 3)" >&5
+ echo $ac_n "checking for gdImagePng in -lgd1 (order 3)""... $ac_c" 1>&6
+echo "configure:2753: checking for gdImagePng in -lgd1 (order 3)" >&5
ac_lib_var=`echo gd'_'gdImagePng'_'3 | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
- LIBS="-lgd -lpng -lz -lm $LIBS"
+ LIBS="-lgd1 -lz -lm -lpng -ljpeg $LIBS"
cat > conftest.$ac_ext <<EOF
#line 2761 "configure"
#include "confdefs.h"
@@ -2785,7 +2790,7 @@
echo "$ac_t""yes" 1>&6
GDLIBFOUND=yep
- GDLIBS="-lgd -lpng -lz -lm"
+ GDLIBS="-lgd1 -lz -lm -lpng"
else
echo "$ac_t""no" 1>&6