023420e69b
- Remove NEWTAB option as the preference browser.link.open_external was removed in Firefox 3.5. [1] - Fix directory permissions in PREFIX/include/firefox3. [2] PR: ports/148436 [2] Reported by: crsd on EFnet [1], Peter Jeremy <peterjeremy AT acm.org> [2] Submitted by: Anonymous <swell.k AT gmail.com> [2] Security: http://www.vuxml.org/freebsd/8c2ea875-9499-11df-8e32-000f20797ede.html
11 lines
766 B
Makefile
11 lines
766 B
Makefile
--- toolkit/mozapps/installer/packager.mk.orig 2007-09-26 13:45:01.000000000 -0400
|
|
+++ toolkit/mozapps/installer/packager.mk 2007-09-26 13:47:29.000000000 -0400
|
|
@@ -409,7 +409,7 @@
|
|
(cd $(DIST)/sdk/include && tar $(TAR_CREATE_FLAGS) - .) | \
|
|
(cd $(DESTDIR)$(includedir)/stable && tar -xf -)
|
|
# The dist/include has module subdirectories that we need to flatten
|
|
- find $(DIST)/include -xtype f -exec $(SYSINSTALL) $(IFLAGS1) {} $(DESTDIR)$(includedir)/unstable \;
|
|
+ find -L $(DIST)/include -name system_wrappers\* -prune -or -type f -exec $(SYSINSTALL) $(IFLAGS1) {} $(DESTDIR)$(includedir)/unstable \;
|
|
# IDL directory is stable (dist/sdk/idl) and unstable (dist/idl)
|
|
$(NSINSTALL) -D $(DESTDIR)$(idldir)/stable
|
|
$(NSINSTALL) -D $(DESTDIR)$(idldir)/unstable
|