e6b6e3491e
This is a bundle of several ports covering many typical requirements for building an Apple WebObjects deployment environment. Each port is or has a dependancy with some other port in the bundle, and have therefore been lodged collectively. www/woadaptor WOAdaptor is a collection of WebObjects WebServer Adaptors. These include an Apache Module, CGI and FastCGI adaptors This is a subproject of Project Wonder and is an effort to pool enhancements and bug fixes for Apple's open source codebase. WWW: http://wonder.sourceforge.net/WOAdaptor.html PR: ports/117299 Submitted by: Quinton Dolan <q@onthenet.com.au>
43 lines
1.2 KiB
Text
43 lines
1.2 KiB
Text
--- Apache2/Makefile.orig Mon Jun 12 06:27:54 2006
|
|
+++ Apache2/Makefile Sat Apr 14 15:33:13 2007
|
|
@@ -84,6 +84,22 @@
|
|
|
|
|
|
|
|
+ifeq "FreeBSD" "${OS}"
|
|
+ifdef USE_SSL
|
|
+# Flags for use when enabling mod_ssl support (on by default)
|
|
+ENABLE_SSL_SUPPORT = -DAPACHE_SECURITY_ENABLED
|
|
+# These should be set to point at the ssl include and lib directories, respectively.
|
|
+OPENSSL_INCL_FLAGS = -I/usr/include/openssl
|
|
+OPENSSL_LIB_FLAGS = -L/usr/lib -lcrypto -lssl
|
|
+endif
|
|
+
|
|
+INCLUDES += ${OPENSSL_INCL_FLAGS}
|
|
+LDFLAGS += ${OPENSSL_LIB_FLAGS} -lm -module
|
|
+APXSFLAGS += "-I`${APXS} -q INCLUDEDIR`"
|
|
+
|
|
+endif
|
|
+# End FreeBSD Config
|
|
+
|
|
|
|
# Build steps
|
|
# Get the list of source files from the ../Adaptor directory and change their extension to .o
|
|
@@ -138,6 +154,17 @@
|
|
mod_WebObjects.o : mod_WebObjects.c ${COMMON_OBJFILES}
|
|
${CC} -c ${CFLAGS} mod_WebObjects.c ${COMMON_OBJFILES}
|
|
endif
|
|
+
|
|
+# FreeBSD Build
|
|
+ifeq "FreeBSD" "$(OS)"
|
|
+
|
|
+mod_WebObjects.so : mod_WebObjects.c ${COMMON_SRCFILES}
|
|
+ ${APXS} ${APXSFLAGS} mod_WebObjects.c ${COMMON_SRCFILES}
|
|
+ cp $(@:.so=.slo) $@
|
|
+
|
|
+endif
|
|
+#end FreeBSD
|
|
+
|
|
|
|
# The install target does what you'd think it would: install the module; By default, this is not called.
|
|
install: mod_WebObjects.la
|