freebsd-ports/net-mgmt/icinga/files/patch-configure.in
Lars Engels 45f4f67f8f - Update to 1.7.0 [1]
- Add support for database backends using IDOutils [2]
- Add a rc script for ido2db
- Enable embedded Perl by default
- Enable Event Broker by default
- Enable statuswrl
- Drop unnecessary use of USE_PHP
- Install sample event handlers
- Optionally depend on MySQL or PostgreSQL
- Optionally depend on Apache and install the apropriate configuration for Icinga
- Update pkg-message

PR:             ports/167988 [1], ports/164625 [2]
Submitted by:   gjb[1], Gianpaolo Del Matto <delmatto@phunsites.net> [2]
2012-05-23 20:13:22 +00:00

62 lines
2.1 KiB
Text

--- configure.in.orig 2012-05-15 13:00:56.000000000 +0000
+++ configure.in 2012-05-16 21:05:28.973178226 +0000
@@ -6,7 +6,6 @@
AC_INIT(base/icinga.c)
AC_CONFIG_HEADER(include/config.h)
-AC_PREFIX_DEFAULT(/usr/local/icinga)
PKG_NAME=icinga-core
PKG_VERSION="1.7.0"
@@ -144,6 +143,15 @@
dnl Test for pthreads support - taken from ICU FreeBSD Port configure script
THREADLIBS=""
have_pthreads="no"
+have_thr="no"
+
+dnl Prefer libthr(3) over libpthread(3) due to serious process hanging issues
+AC_CHECK_LIB(thr,pthread_create)
+if test $ac_cv_lib_thr_pthread_create = yes; then
+ THREADLIBS="-lthr"
+ have_pthreads="yes"
+ have_thr="yes"
+else
dnl FreeBSD: Try ports/linuxthreads first - Mammad Zadeh <mammad@yahoo-inc.com>
dnl FreeBSD -pthread check - Jonathan McDowell <noodles@earth.li>
@@ -205,6 +213,7 @@
if test $have_pthreads = "no"; then
AC_PTHREAD_FREEBSD
fi
+fi
AC_SUBST(THREADLIBS)
@@ -223,7 +232,7 @@
AC_DEFINE_UNQUOTED(DEFAULT_NAGIOS_USER,"$icinga_user",[user name to run nagios])
AC_DEFINE_UNQUOTED(DEFAULT_ICINGA_GROUP,"$icinga_grp",[group name to run nagios])
AC_DEFINE_UNQUOTED(DEFAULT_NAGIOS_GROUP,"$icinga_grp",[group name to run nagios])
-INSTALL_OPTS="-o $icinga_user -g $icinga_grp"
+INSTALL_OPTS="-o root -g wheel"
AC_SUBST(INSTALL_OPTS)
AC_ARG_WITH(command_user,AC_HELP_STRING([--with-command-user=<user>],[sets user name for command access]),command_user=$withval,command_user=$icinga_user)
@@ -414,7 +423,7 @@
P1FILELOC=no
AC_ARG_WITH(p1-file-dir,AC_HELP_STRING([--with-p1-file-dir=<path>],[sets path to embedded perl p1.pl directory]),P1FILELOC=$withval,P1FILELOC=no)
if test x$P1FILELOC = xno; then
- P1FILELOC="$libdir"
+ P1FILELOC="$bindir"
fi
AC_SUBST(P1FILELOC)
@@ -1033,6 +1042,9 @@
AC_DEFINE_UNQUOTED(EMBEDDEDPERL,,[Is embedded Perl being compiled in?])
PERLLIBS="`perl -MExtUtils::Embed -e ldopts`"
+ if test x$have_thr = xyes; then
+ PERLLIBS="`echo $PERLLIBS | sed 's#pthread #lthr #'`"
+ fi
PERLDIR="`perl -MConfig -e 'print $Config{installsitearch}'`"
CFLAGS="${CFLAGS} `perl -MExtUtils::Embed -e ccopts`"
USEPERL=yes