freebsd-ports/audio/timidity++/files/patch-configure
Mikhail Teterin c9f6ab02b0 Patch timidity to read the descriptions of the optional modules directly
from the module's shared object instead of a gratuitous .txt file, that
currently accompanies each module. This should fix pointhat's builds
of the interfaces without adding cruft to their PLISTs. The patch is
accepted by vendor.

Fix one other place in configure to look for tcl8X instead of tcl8.X.
The patch is accepted by vendor.

Realy on archivers/libarc instead of building the version bundled with
timidity.

Set USE_GETOPT_LONG -- timidity uses it, if it can, resulting in a
potentially omitted dependency.

Bump PORTREVISION.

Add links to the vendor's bug reports to each patch, where possible.

Approved by:	maintainer	(blanket)
2005-09-23 13:19:45 +00:00

33 lines
2.2 KiB
Text

http://timidity-docs.sourceforge.jp/cgi-bin/kagemai-en/guest.cgi?project=timidity-bugs-en&action=view_report&id=58
--- configure Sun Oct 3 08:39:51 2004
+++ configure Thu Sep 22 02:49:01 2005
@@ -16605,5 +16605,5 @@
tcl_lib=
tk_lib=
- for l in tcl tcl8.4 tcl8.3 tcl8.0jp tcl7.6jp tcl80jp tcl76jp tcl8.0 tcl7.6 tcl80 tcl76; do
+ for l in tcl84 tcl83 tcl8.0jp tcl7.6jp tcl80jp tcl76jp tcl8.0 tcl7.6 tcl80 tcl76; do
case "x$tcl_lib" in x) as_ac_Lib=`echo "ac_cv_lib_$l''_Tcl_Init" | $as_tr_sh`
echo "$as_me:$LINENO: checking for Tcl_Init in -l$l" >&5
@@ -16677,5 +16677,5 @@
done
LIBS="$LIBS $tcl_lib"
- for l in tk tk8.4 tk8.3 tk8.0jp tk4.2jp tk80jp tk42jp tk8.0 tk4.2 tk80 tk42; do
+ for l in tk tk84 tk83 tk8.0jp tk4.2jp tk80jp tk42jp tk8.0 tk4.2 tk80 tk42; do
case "x$tk_lib" in x) as_ac_Lib=`echo "ac_cv_lib_$l''_Tk_Init" | $as_tr_sh`
echo "$as_me:$LINENO: checking for Tk_Init in -l$l" >&5
@@ -19522,5 +19522,5 @@
- ac_config_files="$ac_config_files Makefile autoconf/Makefile common.makefile configs/Makefile doc/Makefile doc/C/Makefile doc/ja_JP.eucJP/Makefile interface/Makefile interface/motif_bitmaps/Makefile interface/bitmaps/Makefile interface/pixmaps/Makefile libarc/Makefile libunimod/Makefile timidity/Makefile utils/Makefile script/Makefile TiMidity.ad TiMidity-uj.ad"
+ ac_config_files="$ac_config_files Makefile autoconf/Makefile common.makefile configs/Makefile doc/Makefile doc/C/Makefile doc/ja_JP.eucJP/Makefile interface/Makefile interface/motif_bitmaps/Makefile interface/bitmaps/Makefile interface/pixmaps/Makefile libunimod/Makefile timidity/Makefile utils/Makefile script/Makefile TiMidity.ad TiMidity-uj.ad"
cat >confcache <<\_ACEOF
--- Makefile.in Wed Sep 22 13:23:32 2004
+++ Makefile.in Thu Sep 22 02:49:17 2005
@@ -268,5 +268,4 @@
autoconf \
utils \
- libarc \
libunimod \
interface \