freebsd-ports/lang/php80/files/patch-build_Makefile.global
Torsten Zuehlsdorff 1061308ba7 Welcome PHP 8.0 RC 2 to the ports tree
There are many greater changes including:
- json is now part of core
- xmlrpc is removed
- More than 150 backward incompatible changes

Have a look at: https://github.com/php/php-src/blob/php-8.0.0RC2/UPGRADING

Reviewed by:	ale, mfechner, Pascal Christen
Sponsored by:	PHP Update Service
Differential Revision:	https://reviews.freebsd.org/D26848
2020-10-21 22:58:51 +00:00

19 lines
1.2 KiB
Text

--- build/Makefile.global.orig 2019-08-06 06:54:07 UTC
+++ build/Makefile.global
@@ -89,14 +89,14 @@ test: all
@if test ! -z "$(PHP_EXECUTABLE)" && test -x "$(PHP_EXECUTABLE)"; then \
INI_FILE=`$(PHP_EXECUTABLE) -d 'display_errors=stderr' -r 'echo php_ini_loaded_file();' 2> /dev/null`; \
if test "$$INI_FILE"; then \
- $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_FILE" > $(top_builddir)/tmp-php.ini; \
+ $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_FILE" > $(top_builddir)/tmp-php.ini || :; \
else \
echo > $(top_builddir)/tmp-php.ini; \
fi; \
INI_SCANNED_PATH=`$(PHP_EXECUTABLE) -d 'display_errors=stderr' -r '$$a = explode(",\n", trim(php_ini_scanned_files())); echo $$a[0];' 2> /dev/null`; \
if test "$$INI_SCANNED_PATH"; then \
INI_SCANNED_PATH=`$(top_srcdir)/build/shtool path -d $$INI_SCANNED_PATH`; \
- $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_SCANNED_PATH"/*.ini >> $(top_builddir)/tmp-php.ini; \
+ $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_SCANNED_PATH"/*.ini >> $(top_builddir)/tmp-php.ini || :; \
fi; \
TEST_PHP_EXECUTABLE=$(PHP_EXECUTABLE) \
TEST_PHP_SRCDIR=$(top_srcdir) \