freebsd-ports/deskutils/kdeplasma-addons/files/patch-CMakeLists.txt
Max Brazhnikov 1f8475f22f Mk/bsd.kde4.mk:
- rework KDE4_BUILDENV

All ports:
- remove needless post-extract target
- make patches relative to ${PATCH_WRKSRC}
- clean up
- bump PORTREVISION when required

databases/akonadi:
- replace dependency on boost-python-libs with boost-libs
  (finally, boost-pyhton does not conflict with boost \o/)

deskutils/kdepim*:
- replace boost-python-libs with boost-libs
- reduce dependencies
- respect PREFIX
- fix build with qt3 installed

misc/kdeedu4:
- add dependency on astro/xplanet (for KStars)

misc/kdeutils4:
- add dependency on devel/qca (for okteta)
- make dependency on kdebase non-optional

multimedia/kdemultimedia4:
- add optional support for PulseAudio

x11/kdebase4:
- remove needless dependency on kdebase4-runtime

x11/kdebase4-runtime, x11/kdebase4-workspace
- remove extra CMAKE_ARGS to fix build for qt3/kde3 users

x11/kdelibs4
- remove needless dependencies
- remove extra CMAKE_ARGS to fix build for qt3/kde3 users
2009-08-10 11:47:36 +00:00

28 lines
1.1 KiB
Text

--- ./CMakeLists.txt.orig 2009-04-06 07:00:39.000000000 +1100
+++ ./CMakeLists.txt 2009-06-26 11:00:58.000000000 +1100
@@ -26,16 +26,20 @@
endif (DEPEND_PACKAGE_Marble)
macro_log_feature(MARBLE_FOUND "Marble" "Desktop Globe" "http://marble.kde.org" FALSE "" "RECOMMENDED: Marble is used to provide a desktop globe wallpaper for Plasma.")
-if (NEPOMUK_FOUND)
- include_directories( ${SOPRANO_INCLUDE_DIR} ${NEPOMUK_INCLUDE_DIR} )
-endif (NEPOMUK_FOUND)
-
add_definitions (${QT_DEFINITIONS} ${KDE4_DEFINITIONS})
-include_directories (${KDE4_INCLUDES}
+INCLUDE_DIRECTORIES (${QT_QTGUI_INCLUDE_DIR}
+ ${QT_QTCORE_INCLUDE_DIR}
+ ${QT_QTXML_INCLUDE_DIR}
+ ${PHONON_INCLUDE_DIR}
+ ${KDE4_INCLUDES}
${KDE4WORKSPACE_INCLUDE_DIR}
${KDEPIMLIBS_INCLUDE_DIR}
${CMAKE_CURRENT_SOURCE_DIR}/libs)
+if (NEPOMUK_FOUND)
+ include_directories( ${SOPRANO_INCLUDE_DIR} ${NEPOMUK_INCLUDE_DIR} )
+endif (NEPOMUK_FOUND)
+
add_subdirectory(libs)
add_subdirectory(applets)
add_subdirectory(dataengines)