freebsd-ports/graphics/libecwj2/files/patch-configure
Tijl Coosemans 74f7a90c2a - Convert to USES=libtool and add INSTALL_TARGET=install-strip
- Remove patches for Makefile.am and patch configure instead of configure.in
  to avoid USE_AUTOTOOLS
- Touch ${WRKSRC}/Source/NCSBuildGnu/NCSGnuConfig.h.in to avoid autoheader
2014-08-24 21:07:47 +00:00

42 lines
1.4 KiB
Text

--- configure.orig
+++ configure
@@ -19897,17 +19897,6 @@
# Build some standard absolute include paths for the build
MAIN_INCLUDE_DIR="$PWD/Source/include"
-LCMS_INCLUDE_DIR="$PWD/Source/C/NCSEcw/lcms/include"
-
-# Run configure in the LCMS directory (using LCMS's own configure script)
-# to initialise any platform dependent settings that it uses
-# (e.g. typedefs for int types)
-
-THISDIR=$PWD
-cd Source/C/NCSEcw/lcms
-chmod +x configure
-./configure
-cd $THISDIR
# Build LIBECWJ2_DEFS with all defines, and NCSGnuSystemDefs.h with defines
# needed by apps building against libecwj2.
@@ -19941,6 +19930,12 @@
PLATFORM_STATIC_LDFLAGS="$PLATFORM_STATIC_LDFLAGS -L/System/Library/Frameworks/Carbon.framework/Carbon"
PLATFORM_SHARED_LDFLAGS="$PLATFORM_SHARED_LDFLAGS $PLATFORM_STATIC_LDFLAGS -dynamiclib -single_module"
;;
+ *freebsd*)
+ PLATFORM_DEFS="FREEBSD"
+ PLATFORM_CFLAGS="$PLATFORM_CFLAGS -fpic"
+ PLATFORM_STATIC_LDFLAGS=""
+ PLATFORM_SHARED_LDFLAGS="$PLATFORM_SHARED_LDFLAGS $PLATFORM_STATIC_LDFLAGS"
+ ;;
*)
PLATFORM_DEFS=""
PLATFORM_STATIC_LDFLAGS=""
@@ -19954,7 +19949,7 @@
LIBECWJ2_CFLAGS="$PLATFORM_CFLAGS"
LIBECWJ2_STATIC_LDFLAGS="$PLATFORM_STATIC_LDFLAGS"
LIBECWJ2_SHARED_LDFLAGS="$PLATFORM_SHARED_LDFLAGS"
-LIBECWJ2_INCLUDES="-I$MAIN_INCLUDE_DIR -I$LCMS_INCLUDE_DIR"
+LIBECWJ2_INCLUDES="-I$MAIN_INCLUDE_DIR"
rm -f Source/NCSBuildGnu/NCSGnuSystemDefs.h
echo "#ifndef LIBECWJ2" > Source/NCSBuildGnu/NCSGnuSystemDefs.h