freebsd-ports/x11-wm/pwm/files/patch-system.mk
Kris Kennaway be8e5d8733 Unbreak on -stable by removing -pedantic-errors from CFLAGS, which
exposes new (fatal) warnings on recent compilers.
2002-09-29 01:59:20 +00:00

11 lines
391 B
Makefile

--- system.mk.orig Sat Sep 28 18:57:23 2002
+++ system.mk Sat Sep 28 18:57:31 2002
@@ -55,7 +55,7 @@
# have unused variables.
WARN= -W -Wimplicit -Wreturn-type -Wswitch -Wcomment \
-Wtrigraphs -Wformat -Wchar-subscripts -Wuninitialized \
- -Wparentheses -pedantic-errors
+ -Wparentheses
CFLAGS=-g -O2 $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
LDFLAGS=-g $(LIBS) $(EXTRA_LIBS)