PR: ports/102861 Submitted by: Remy Oudompheng <remy.oudompheng@ens.fr> Approved by: KANOU Hiroki <kanou@khdd.net> (maintainer)
25 lines
1.3 KiB
Text
25 lines
1.3 KiB
Text
--- fontforge/Makefile.dynamic.in.orig Fri Apr 14 02:59:01 2006
|
|
+++ fontforge/Makefile.dynamic.in Thu Apr 27 16:21:35 2006
|
|
@@ -43,19 +43,19 @@
|
|
cvdgloss.o groups.o parsepdf.o plugins.o bdfinfo.o \
|
|
glyphcomp.o @FF_EXTRA_FILES@
|
|
DIFFOBJS = sfddiff.o sfd.o diffstubs.o stamp.o namelist.o pua.o
|
|
ACORNOBJS = acorn2sfd.o sfd.o diffstubs.o psunicodenames.o stamp.o
|
|
|
|
-_CFLAGS = -I$(top_srcdir)/inc -I$(srcdir) -I. @WFLAGS@ $(X_CFLAGS) \
|
|
+_CFLAGS = -I$(LOCALBASE)/include -I$(top_srcdir)/inc -I$(srcdir) -I. @WFLAGS@ $(X_CFLAGS) \
|
|
@DEFS@ '-DSHAREDIR="$(sharedir)"' -DLIBDIR='"$(libdir)"' \
|
|
@CPPFLAGS@ '-DPREFIX="@prefix@"'
|
|
CFLAGS = @CFLAGS@ $(_CFLAGS)
|
|
|
|
#I used to include -L/usr/lib explicitly after static_libs. Not sure why. Should be implied & breaks 64bit compiles
|
|
LIBS = -rpath $(libdir) $(X_LIBS) ../libgdraw.la ../libgunicode.la \
|
|
- $(X_PRE_LIBS) $(X_11LIB) $(X_EXTRA_LIBS) @LIBS@ $(STATIC_LIBS) -lm
|
|
-DLIBS = -rpath $(libdir) ../libgunicode.la @LIBS@ $(STATIC_LIBS) -lm
|
|
+ $(X_PRE_LIBS) $(X_11LIB) $(X_EXTRA_LIBS) @LIBS@ $(STATIC_LIBS) -lm -lintl
|
|
+DLIBS = -rpath $(libdir) ../libgunicode.la @LIBS@ $(STATIC_LIBS) -lm -lintl
|
|
|
|
all: fontforge sfddiff
|
|
|
|
fontforge: main.o $(fontforge_LIBOBJECTS)
|
|
$(LIBTOOL) --mode=link $(CC) -export-dynamic -o fontforge main.o $(fontforge_LIBOBJECTS) $(LIBS)
|