freebsd-ports/lang/tclX/files/patch-configure
Thierry Thomas d3f0ec5007 - Fix a breakage caused by revision v 1.91 of ports/lang/tcl84/Makefile
- Switch to USE_TCL

- s/INSTALLS_SHLIB/USE_LDCONFIG/

- Support tcl84-thread

- Fix tclsh detection in configure

- Pet portlint.

Note: this port is still broken, because a test is failing, and tests
are part of the all target.

PR:		ports/110805
Submitted by:	/me
Approved by:	mi (excepted the move of tests to a regression-test target)
2007-03-26 17:11:37 +00:00

11 lines
474 B
Text

--- configure.orig Sat Oct 8 01:17:50 2005
+++ configure Sun Mar 25 15:34:58 2007
@@ -6917,7 +6917,7 @@
fi
else
# tclConfig.sh is in $INSTALL/lib directory
- REAL_TCL_BIN_DIR=`cd ${TCL_BIN_DIR}/../bin/;pwd`
+ REAL_TCL_BIN_DIR=`cd ${TCL_BIN_DIR}/../../bin/;pwd`
if test "$TEA_PLATFORM" = "windows"; then
TCLSH_PROG=${REAL_TCL_BIN_DIR}/tclsh${TCL_MAJOR_VERSION}${TCL_MINOR_VERSION}${TCL_DBGX}${EXEEXT}
else