+ fixed TCL_DEFS processing in patch-configure + re-enabled Tcl support (using new bsd.tcl.mk) + supports Tcl 80, 82, 83, 84, 85 (WITH_TCL_VER=8x or VIM_WITH_TCL_VER=8x) + no support for threaded Tcl yet (because of the way how vim's configure searches for Tcl, this needs more modifications) PR: 112347 Submitted by: mm
8 lines
583 B
Text
8 lines
583 B
Text
--- auto/configure.orig Thu May 4 03:46:19 2006
|
|
+++ auto/configure Mon Jun 19 03:01:38 2006
|
|
@@ -4644,3 +4644,4 @@ echo "${ECHO_T}$try/tclConfig.sh" >&6
|
|
TCL_LIBS=`eval echo "$TCL_LIB_SPEC $TCL_LIBS"`
|
|
- TCL_DEFS=`echo $TCL_DEFS | sed -e 's/\\\\ /\\\\X/g' | tr ' ' '\012' | sed -e '/^-[^D]/d' -e '/-D[^_]/d' -e 's/-D_/ -D_/' | tr '\012' ' ' | sed -e 's/\\\\X/\\\\ /g'`
|
|
+ TCL_DEFS=`echo $TCL_DEFS | sed -e 's/\\ /\\\\X/g' | tr ' ' '\012' | sed -e '/^-[^D]/d' -e '/-D[^_]/d' -e 's/-D_/ -D_/' | tr '\012' ' ' | sed -e 's/\\\\X/\\ /g'`
|
|
+
|
|
break
|