35 lines
1.6 KiB
Text
35 lines
1.6 KiB
Text
--- unix/configure.in.orig Fri Jan 26 23:59:53 2007
|
|
+++ unix/configure.in Sat Jan 27 00:00:06 2007
|
|
@@ -34,12 +34,12 @@
|
|
#--------------------------------------------------------------------
|
|
|
|
AC_ARG_WITH(tcl, [ --with-tcl=DIR use Tcl 7.6 binaries from DIR],
|
|
- TCL_BIN_DIR=$withval, TCL_BIN_DIR=`cd ../../tcl7.6/unix; pwd`)
|
|
+ TCL_BIN_DIR=$withval, TCL_BIN_DIR=${prefix}/lib/tcl7.6jp)
|
|
if test ! -d $TCL_BIN_DIR; then
|
|
AC_MSG_ERROR(Tcl directory $TCL_BIN_DIR doesn't exist)
|
|
fi
|
|
-if test ! -f $TCL_BIN_DIR/Makefile; then
|
|
- AC_MSG_ERROR(There's no Makefile in $TCL_BIN_DIR; perhaps you didn't specify the Tcl *build* directory (not the toplevel Tcl directory) or you forgot to configure Tcl?)
|
|
+if test ! -f $TCL_BIN_DIR/tclConfig.sh; then
|
|
+ AC_MSG_ERROR(There's no tclConfig.sh in $TCL_BIN_DIR; perhaps you didn't specify the Tcl *build* directory (not the toplevel Tcl directory) or you forgot to configure Tcl, or you did not use ports?)
|
|
fi
|
|
|
|
#--------------------------------------------------------------------
|
|
@@ -298,7 +298,7 @@
|
|
if test "$ok" = "yes" -a "${SHLIB_SUFFIX}" != ""; then
|
|
TK_SHLIB_CFLAGS="${SHLIB_CFLAGS}"
|
|
eval "TK_LIB_FILE=libtk${TCL_SHARED_LIB_SUFFIX}"
|
|
- MAKE_LIB="\${SHLIB_LD} -o ${TK_LIB_FILE} \${OBJS} ${SHLIB_LD_LIBS}"
|
|
+ MAKE_LIB="\${SHLIB_LD} -o ${TK_LIB_FILE} -Wl,-soname,${TK_LIB_FILE} \${OBJS} ${SHLIB_LD_LIBS}"
|
|
RANLIB=":"
|
|
else
|
|
TK_SHLIB_CFLAGS=""
|
|
@@ -330,6 +330,7 @@
|
|
AC_SUBST(SHLIB_VERSION)
|
|
AC_SUBST(TCL_BIN_DIR)
|
|
AC_SUBST(TCL_BUILD_LIB_SPEC)
|
|
+AC_SUBST(TCL_LIB_SPEC)
|
|
AC_SUBST(TCL_SRC_DIR)
|
|
AC_SUBST(TCL_VERSION)
|
|
AC_SUBST(TK_BUILD_LIB_SPEC)
|