The 3.0 series is an incremental improvement over the previous 2.8 series despite the major version number change. A list of important changes is available at http://www.cmake.org/cmake/help/v3.0/release/3.0.0.html On the porting side * The minimum FreeBSD release we have to support in the ports tree is now recent enough that ports/168671 can finally be committed: instead of building and using CMake's own copies of bzip2, curl, expat, libarchive, liblzma and zlib, we use the versions in ports and/or the base system. * CMake's documentation system has been changed and vastly improved at the cost of now depending on Sphinx. We still generate only man pages, but can start generating the HTML documentation in the future if desired. * devel/cmake-gui now uses Qt5 instead of Qt4 and does not needlessly build the ncurses UI that is installed by devel/cmake itself. * CMake commit 3816cd2 fixes a longstanding issue in the detection of the Python interpreter and its libraries, but requires us to revert a workaround for that in Mk/Uses/python.mk itself, effectively reverting the patch introduced by ports/168159. * Similarly, a few ports had to be fixed manually due to CMake being stricter when parsing some files or the ports detecting Python the wrong way. Fortunately, they all had been fixed upstream so I just grabbed the appropriate commits and pointed to them in the patches. science/gnudatalanguage had to have its PORTREVISION bumped because switching to USES=cmake:outsource removed a few files from the plist that were not supposed to have been installed in the first place. PR: 168671 PR: 192644
40 lines
1.5 KiB
Text
40 lines
1.5 KiB
Text
Includes the following upstream commit to fix the build with CMake 3.0+:
|
|
|
|
commit ec580cb815c16ec1ab43a469d5af7d51d8d03082
|
|
Author: Chocobozzz <florian.chocobo@gmail.com>
|
|
Date: Wed Jul 16 15:57:25 2014 +0200
|
|
|
|
No namespaces for DBus interfaces. Fixes #4401
|
|
--- src/CMakeLists.txt.orig 2013-10-20 17:40:58.416968707 +0000
|
|
+++ src/CMakeLists.txt 2013-10-20 17:41:24.671967496 +0000
|
|
@@ -892,11 +892,6 @@ optional_source(LINUX SOURCES widgets/osd_x11.cpp)
|
|
if(HAVE_DBUS)
|
|
file(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/dbus)
|
|
|
|
- # Hack to get it to generate interfaces without namespaces - required
|
|
- # because otherwise org::freedesktop::UDisks and
|
|
- # org::freedesktop::UDisks::Device conflict.
|
|
- list(APPEND QT_DBUSXML2CPP_EXECUTABLE -N)
|
|
-
|
|
# MPRIS DBUS interfaces
|
|
qt4_add_dbus_adaptor(SOURCES
|
|
dbus/org.freedesktop.MediaPlayer.player.xml
|
|
@@ -964,6 +959,10 @@ if(HAVE_DBUS)
|
|
|
|
# DeviceKit DBUS interfaces
|
|
if(HAVE_DEVICEKIT)
|
|
+ set_source_files_properties(dbus/org.freedesktop.UDisks.xml
|
|
+ PROPERTIES NO_NAMESPACE dbus/udisks)
|
|
+ set_source_files_properties(dbus/org.freedesktop.UDisks.Device.xml
|
|
+ PROPERTIES NO_NAMESPACE dbus/udisksdevice)
|
|
qt4_add_dbus_interface(SOURCES
|
|
dbus/org.freedesktop.UDisks.xml
|
|
dbus/udisks)
|
|
@@ -1322,6 +1322,7 @@
|
|
|
|
if (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
|
|
target_link_libraries(clementine execinfo)
|
|
+ set_target_properties(clementine PROPERTIES OUTPUT_NAME clementine-player)
|
|
endif (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
|
|
|
|
target_link_libraries(clementine
|