Firefox 3.1 Beta 3 is based on the Gecko 1.9.1 rendering platform, which has been under development for the past 9 months. Firefox 3.1 is an incremental release on the previous version with significant changes to improve web compatibility, performance, and ease of use: * Improved the new Private Browsing Mode. * Improvements to web worker thread support. * Improved performance and stability with the new TraceMonkey JavaScript engine. * New native JSON support. * Improvements to the Gecko layout engine, including speculative parsing for faster content rendering. * Support for new web technologies such as the <video> and <audio> elements, the W3C Geolocation API, JavaScript query selectors, CSS 2.1 and 3 properties, SVG transforms and offline applications. Thanks to: beat@, nox@, gahr@, Florian Smeets,
11 lines
449 B
Makefile
11 lines
449 B
Makefile
--- js/src/config/config.mk.orgi 2009-04-21 15:12:51.000000000 +0200
|
|
+++ js/src/config/config.mk 2009-04-21 15:15:37.000000000 +0200
|
|
@@ -490,7 +490,7 @@
|
|
INCLUDES = $(LOCAL_INCLUDES) $(REQ_INCLUDES) $(REQ_INCLUDES_SDK) -I$(PUBLIC) $(OS_INCLUDES)
|
|
|
|
ifndef MOZILLA_INTERNAL_API
|
|
-INCLUDES += -I$(LIBXUL_DIST)/sdk/include
|
|
+INCLUDES += -I$(LIBXUL_DIST)/sdk/include -I%%LOCALBASE%%/include
|
|
endif
|
|
|
|
include $(topsrcdir)/config/static-checking-config.mk
|