freebsd-ports/databases/redis-devel/files/patch-src-Makefile
Sergey A. Osokin 771437151f Upgrade from 2.8.3 to 2.8.4.
<ChangeLog>

# UPGRADE URGENCY: MODERATE for Redis and Sentinel.

* [FIX] Makefile compatibility with non common make variants improved.
* [FIX] SDIFF crash in very unlikely to trigger state fixed.
* [FIX] Config rewriting fixed: don't wipe options unknown to the rewrite
        process.
* [FIX] Set TCP port to 0 works again to disable TCP networking.
* [FIX] Fixed replication with old Redis instances as masters by not
        sending REPLCONF ACK to them.
* [FIX] Fix keyspace notifications rewrite and CONFIG GET output.
* [FIX] Fix RESTORE TTL handling in 32 bit systems (32 bit overflow).

* [NEW] Sentinel now has a run time configuration API.
* [NEW] Log when we lost connection with master or slave.
* [NEW] When instance is turned from slave to master now inherits the
        old master replication offset when possible. This improves the
        Sentinel failover procedure.

</ChangeLog>
2014-01-14 10:28:34 +00:00

31 lines
768 B
Text

--- src/Makefile.orig 2014-01-14 14:17:43.000000000 +0400
+++ src/Makefile 2014-01-14 14:19:31.000000000 +0400
@@ -22,7 +22,7 @@
WARN=-Wall
OPT=$(OPTIMIZATION)
-PREFIX?=/usr/local
+PREFIX:=$(PREFIX)
INSTALL_BIN=$(PREFIX)/bin
INSTALL=install
@@ -52,7 +52,7 @@
FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
FINAL_LIBS=-lm
-DEBUG=-g -ggdb
+#DEBUG=-g -ggdb
ifeq ($(uname_S),SunOS)
# SunOS
@@ -63,6 +63,7 @@
-ifeq ($(uname_S),Darwin)
- # Darwin (nothing to do)
-else
+ifeq ($(uname_S),FreeBSD)
+ FINAL_CFLAGS?= $(CFLAGS) $(REDIS_CFLAGS) -I${PREFIX}/include
+ FINAL_LDFLAGS= $(LDFLAGS)
+else
# All the other OSes (notably Linux)
FINAL_LDFLAGS+= -rdynamic
FINAL_LIBS+= -pthread