freebsd-ports/devel/shapelib/files/patch-contrib-Makefile
Sunpoet Po-Chuan Hsieh 50097b65fa - Update to 1.3.0b3
Changes:

2011-07-24:
- shpopen.c, dbfopen.c, shptree.c, shapefil.h: Minimize use of CPL services in
  favor of SAHooks.Error().
- Makefile: Remove all the shared library building stuff, it is just too half
  assed, and results in all sorts of bug reports and complaints. Instead just
  install a static libshp.a.

2011-07-23:
- Makefile: build shpdumptree as part of all target (#1648).
- shpopen.c: fix memory leaks in error cases (#2061)
- contrib/*.c: Include stdlib.h and strings.h (#2146)
- shpdump.c: change to use %.15g for coordinate reporting. (#2277)

2011-05-13:
- dbfopen.c, shapelib.h: Add functions to reorder and alter field definitions.
  DBFReorderFields() and DBFAlterFields().

2011-05-07:
- dbfopen.c: Ensure pending record is flushed when adding a native field
  (gdal #4073).

2011-04-16:
- shapefil.h: avoid warnings with SHP_CVSID on gcc.

2010-12-06:
- dbfopen.c: fix read past end of init data fetching code page
  http://bugzilla.maptools.org/show_bug.cgi?id=2276

2010-07-01:
- shpopen.c: do not error out on a shape with zero vertices.
- shpdump.c: do not crash if null shape returned by read object.

2010-06-29:
- shptree.c: fix sign of Z and M comparisons in SHPCheckObjectContained.
  (http://bugzilla.maptools.org/show_bug.cgi?id=2223)
2012-01-07 17:44:57 +00:00

43 lines
1.4 KiB
Text

--- contrib/Makefile.orig 2011-07-24 14:15:51.000000000 +0800
+++ contrib/Makefile 2011-12-24 03:00:00.000000000 +0800
@@ -3,19 +3,36 @@
#CFLAGS = -g
# Endian: define either _LITTLE_ENDIAN or _BIG_ENDIAN
-ENDIAN = -D_LITTLE_ENDIAN
+#ENDIAN = -D_LITTLE_ENDIAN
-CFLAGS = -g -I.. -I$(HOME)/bld/include -DPROJ4 $(ENDIAN) -DDEBUG -DDEBUG2
+CFLAGS += -D_LITTLE_ENDIAN %%PROJ%% -I.. -I$(LOCALBASE)/include -L$(LOCALBASE)/lib
SHPOBJ = ../shpopen.o ../dbfopen.o ../safileio.o
SHPGOBJ = ../shpopen.o ../dbfopen.o ../safileio.o shpgeo.o
-GEOOBJ = ./shpgeo.o -lm -L$(HOME)/bld/lib -lproj
+GEOOBJ = ./shpgeo.o -lm -lproj
default: all
-all: shpdxf shpproj dbfinfo shpcentrd shpdata shpwkb dbfinfo dbfcat shpinfo shpfix shpcat Shape_PointInPoly shpsort
+#all: shpdxf shpproj dbfinfo shpcentrd shpdata shpwkb dbfinfo dbfcat shpinfo shpfix shpcat Shape_PointInPoly shpsort
+
+ALLPROG= Shape_PointInPoly dbfcat dbfinfo shpcat shpdxf shpfix shpsort
+ALLPROJ= shpcentrd shpdata shpinfo shpproj shpwkb
+
+.if defined(NO_PROJ4)
+all: $(ALLPROG)
+install: allprog_install
+.else
+all: $(ALLPROG) $(ALLPROJ)
+install: allprog_install allproj_install
+.endif
+
+allprog_install: $(ALLPROG)
+ $(BSD_INSTALL_PROGRAM) $(ALLPROG) $(PREFIX)/bin/
+
+allproj_install: $(ALLPROJ)
+ $(BSD_INSTALL_PROGRAM) $(ALLPROJ) $(PREFIX)/bin/
clean:
rm -f shpdxf shpproj dbfinfo shpcentrd shpdata shpwkb dbfcat dbfinfo shpinfo shpfix shpcat *.o