Use LDFLAGS if they're set in the environment.
This commit is contained in:
parent
f89f1302a9
commit
025e9bb455
1 changed files with 12 additions and 3 deletions
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-ab,v 1.1 2003/04/10 13:59:46 marc Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2003/04/10 14:20:53 marc Exp $
|
||||
|
||||
--- setup/togl_setup.py.orig 2003-04-07 09:00:28.000000000 +0200
|
||||
+++ setup/togl_setup.py 2003-04-07 09:01:25.000000000 +0200
|
||||
--- setup/togl_setup.py.orig 2001-07-08 18:08:30.000000000 +0200
|
||||
+++ setup/togl_setup.py 2003-04-10 16:15:22.000000000 +0200
|
||||
@@ -50,16 +50,14 @@
|
||||
# VC++ 6.0 needs this, why togl doesn't use _WIN32?
|
||||
extra_compile_args.append('-DWIN32=1')
|
||||
|
@ -22,3 +22,12 @@ $NetBSD: patch-ab,v 1.1 2003/04/10 13:59:46 marc Exp $
|
|||
# rest of this function was inspired by build_ext.py , build_extensions()
|
||||
|
||||
if build_ext.inplace:
|
||||
@@ -71,6 +69,8 @@
|
||||
|
||||
if os.environ.has_key('CFLAGS'):
|
||||
extra_compile_args.extend(string.split(os.environ['CFLAGS']))
|
||||
+ if os.environ.has_key('LDFLAGS'):
|
||||
+ extra_link_args.extend(string.split(os.environ['LDFLAGS']))
|
||||
|
||||
# what is the name of the resulting file
|
||||
output_filename = build_ext.compiler.shared_object_filename(
|
||||
|
|
Loading…
Reference in a new issue