Import ec2-api-tools-1.3.62308 as wip/ec2-api-tools.
The API tools serve as the client interface to the Amazon EC2 web service. Use these tools to register and launch AMI instances, manipulate security groups, and more.
This commit is contained in:
parent
22336b2633
commit
040081f700
7 changed files with 552 additions and 0 deletions
3
ec2-api-tools/DESCR
Normal file
3
ec2-api-tools/DESCR
Normal file
|
@ -0,0 +1,3 @@
|
|||
The API tools serve as the client interface to the Amazon EC2 web
|
||||
service. Use these tools to register and launch AMI instances, manipulate
|
||||
security groups, and more.
|
66
ec2-api-tools/Makefile
Normal file
66
ec2-api-tools/Makefile
Normal file
|
@ -0,0 +1,66 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2011/01/20 00:31:39 jym-netbsd Exp $
|
||||
#
|
||||
|
||||
PKGNAME= ec2-api-tools-1.3.62308
|
||||
DISTNAME= ec2-api-tools-1.3-62308
|
||||
|
||||
.include "Makefile.common"
|
||||
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://s3.amazonaws.com/ec2-downloads/
|
||||
EXTRACT_SUFX= .zip
|
||||
|
||||
MAINTAINER= jym@NetBSD.org
|
||||
HOMEPAGE= http://aws.amazon.com/developertools/351
|
||||
COMMENT= Amazon EC2 API tools (register, launch, administer instances)
|
||||
LICENSE= amazon-software-license AND apache-2.0 AND gnu-gpl-v2 \
|
||||
AND cddl-1.0
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
NO_BUILD= yes
|
||||
|
||||
USE_JAVA= run
|
||||
USE_JAVA2= 1.5
|
||||
|
||||
REPLACE_INTERPRETER+= bash
|
||||
REPLACE.bash.old= /usr/bin/env.*bash
|
||||
REPLACE.bash.new= /bin/sh
|
||||
REPLACE_FILES.bash= bin/*
|
||||
|
||||
SUBST_CLASSES+= java-path
|
||||
SUBST_STAGE.java-path= pre-configure
|
||||
SUBST_FILES.java-path= bin/ec2-cmd
|
||||
SUBST_VARS.java-path+= PKG_JAVA_HOME
|
||||
SUBST_MESSAGE.java-path=Fixing path to Java interpreter.
|
||||
|
||||
SUBST_CLASSES+= ec2-home
|
||||
SUBST_STAGE.ec2-home= pre-configure
|
||||
SUBST_FILES.ec2-home= bin/*
|
||||
SUBST_SED.ec2-home+= -e 's|:.EC2_HOME is not set|:-${EC2_HOME}/|g'
|
||||
SUBST_MESSAGE.ec2-home= Setting EC2_HOME default path.
|
||||
|
||||
INSTALLATION_DIRS+= bin amazon-ec2 amazon-ec2/bin amazon-ec2/lib
|
||||
|
||||
post-extract:
|
||||
# Get rid of Windows batch files
|
||||
${FIND} ${WRKSRC} -name \*.cmd -type f -print | ${XARGS} ${RM} -f
|
||||
|
||||
do-install:
|
||||
${FIND} ${WRKSRC} -name \*.orig -type f -print | ${XARGS} ${RM} -f
|
||||
|
||||
# Install EC2 .jar files
|
||||
cd ${WRKSRC}/lib && for f in *; do \
|
||||
${INSTALL_DATA} $$f ${DESTDIR}${EC2_HOME}/lib; \
|
||||
done
|
||||
|
||||
# Install EC2 scripts
|
||||
cd ${WRKSRC}/bin && for f in *; do \
|
||||
${INSTALL_SCRIPT} $$f ${DESTDIR}${EC2_HOME}/bin;\
|
||||
${LN} -sf ${DESTDIR}${EC2_HOME}/bin/$$f \
|
||||
${DESTDIR}${PREFIX}/bin; \
|
||||
done
|
||||
|
||||
|
||||
.include "../../mk/java-vm.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
6
ec2-api-tools/Makefile.common
Normal file
6
ec2-api-tools/Makefile.common
Normal file
|
@ -0,0 +1,6 @@
|
|||
# $NetBSD: Makefile.common,v 1.1.1.1 2011/01/20 00:31:39 jym-netbsd Exp $
|
||||
|
||||
# used by wip/ec2-ami-tools/Makefile
|
||||
#
|
||||
# Default path to Amazon EC2 scripts, binaries and tools
|
||||
EC2_HOME= ${PREFIX}/amazon-ec2
|
444
ec2-api-tools/PLIST
Normal file
444
ec2-api-tools/PLIST
Normal file
|
@ -0,0 +1,444 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2011/01/20 00:31:39 jym-netbsd Exp $
|
||||
bin/ec2-activate-license
|
||||
bin/ec2-add-group
|
||||
bin/ec2-add-keypair
|
||||
bin/ec2-allocate-address
|
||||
bin/ec2-associate-address
|
||||
bin/ec2-associate-dhcp-options
|
||||
bin/ec2-attach-volume
|
||||
bin/ec2-attach-vpn-gateway
|
||||
bin/ec2-authorize
|
||||
bin/ec2-bundle-instance
|
||||
bin/ec2-cancel-bundle-task
|
||||
bin/ec2-cancel-conversion-task
|
||||
bin/ec2-cancel-spot-instance-requests
|
||||
bin/ec2-cmd
|
||||
bin/ec2-confirm-product-instance
|
||||
bin/ec2-create-customer-gateway
|
||||
bin/ec2-create-dhcp-options
|
||||
bin/ec2-create-image
|
||||
bin/ec2-create-placement-group
|
||||
bin/ec2-create-snapshot
|
||||
bin/ec2-create-spot-datafeed-subscription
|
||||
bin/ec2-create-subnet
|
||||
bin/ec2-create-tags
|
||||
bin/ec2-create-volume
|
||||
bin/ec2-create-vpc
|
||||
bin/ec2-create-vpn-connection
|
||||
bin/ec2-create-vpn-gateway
|
||||
bin/ec2-deactivate-license
|
||||
bin/ec2-delete-customer-gateway
|
||||
bin/ec2-delete-dhcp-options
|
||||
bin/ec2-delete-disk-image
|
||||
bin/ec2-delete-group
|
||||
bin/ec2-delete-keypair
|
||||
bin/ec2-delete-placement-group
|
||||
bin/ec2-delete-snapshot
|
||||
bin/ec2-delete-spot-datafeed-subscription
|
||||
bin/ec2-delete-subnet
|
||||
bin/ec2-delete-tags
|
||||
bin/ec2-delete-volume
|
||||
bin/ec2-delete-vpc
|
||||
bin/ec2-delete-vpn-connection
|
||||
bin/ec2-delete-vpn-gateway
|
||||
bin/ec2-deregister
|
||||
bin/ec2-describe-addresses
|
||||
bin/ec2-describe-availability-zones
|
||||
bin/ec2-describe-bundle-tasks
|
||||
bin/ec2-describe-conversion-tasks
|
||||
bin/ec2-describe-customer-gateways
|
||||
bin/ec2-describe-dhcp-options
|
||||
bin/ec2-describe-group
|
||||
bin/ec2-describe-image-attribute
|
||||
bin/ec2-describe-images
|
||||
bin/ec2-describe-instance-attribute
|
||||
bin/ec2-describe-instances
|
||||
bin/ec2-describe-keypairs
|
||||
bin/ec2-describe-licenses
|
||||
bin/ec2-describe-placement-groups
|
||||
bin/ec2-describe-regions
|
||||
bin/ec2-describe-reserved-instances
|
||||
bin/ec2-describe-reserved-instances-offerings
|
||||
bin/ec2-describe-snapshot-attribute
|
||||
bin/ec2-describe-snapshots
|
||||
bin/ec2-describe-spot-datafeed-subscription
|
||||
bin/ec2-describe-spot-instance-requests
|
||||
bin/ec2-describe-spot-price-history
|
||||
bin/ec2-describe-subnets
|
||||
bin/ec2-describe-tags
|
||||
bin/ec2-describe-volumes
|
||||
bin/ec2-describe-vpcs
|
||||
bin/ec2-describe-vpn-connections
|
||||
bin/ec2-describe-vpn-gateways
|
||||
bin/ec2-detach-volume
|
||||
bin/ec2-detach-vpn-gateway
|
||||
bin/ec2-disassociate-address
|
||||
bin/ec2-fingerprint-key
|
||||
bin/ec2-get-console-output
|
||||
bin/ec2-get-password
|
||||
bin/ec2-import-instance
|
||||
bin/ec2-import-keypair
|
||||
bin/ec2-import-volume
|
||||
bin/ec2-migrate-image
|
||||
bin/ec2-modify-image-attribute
|
||||
bin/ec2-modify-instance-attribute
|
||||
bin/ec2-modify-snapshot-attribute
|
||||
bin/ec2-monitor-instances
|
||||
bin/ec2-purchase-reserved-instances-offering
|
||||
bin/ec2-reboot-instances
|
||||
bin/ec2-register
|
||||
bin/ec2-release-address
|
||||
bin/ec2-request-spot-instances
|
||||
bin/ec2-reset-image-attribute
|
||||
bin/ec2-reset-instance-attribute
|
||||
bin/ec2-reset-snapshot-attribute
|
||||
bin/ec2-revoke
|
||||
bin/ec2-run-instances
|
||||
bin/ec2-start-instances
|
||||
bin/ec2-stop-instances
|
||||
bin/ec2-terminate-instances
|
||||
bin/ec2-unmonitor-instances
|
||||
bin/ec2-upload-disk-image
|
||||
bin/ec2-version
|
||||
bin/ec2actlic
|
||||
bin/ec2addcgw
|
||||
bin/ec2adddopt
|
||||
bin/ec2addgrp
|
||||
bin/ec2addkey
|
||||
bin/ec2addpgrp
|
||||
bin/ec2addsds
|
||||
bin/ec2addsnap
|
||||
bin/ec2addsubnet
|
||||
bin/ec2addtag
|
||||
bin/ec2addvgw
|
||||
bin/ec2addvol
|
||||
bin/ec2addvpc
|
||||
bin/ec2addvpn
|
||||
bin/ec2allocaddr
|
||||
bin/ec2assocaddr
|
||||
bin/ec2assocdopt
|
||||
bin/ec2attvgw
|
||||
bin/ec2attvol
|
||||
bin/ec2auth
|
||||
bin/ec2bundle
|
||||
bin/ec2cbun
|
||||
bin/ec2cct
|
||||
bin/ec2cim
|
||||
bin/ec2cpi
|
||||
bin/ec2csir
|
||||
bin/ec2daddr
|
||||
bin/ec2datt
|
||||
bin/ec2daz
|
||||
bin/ec2dbun
|
||||
bin/ec2dcgw
|
||||
bin/ec2dct
|
||||
bin/ec2ddi
|
||||
bin/ec2ddopt
|
||||
bin/ec2deactlic
|
||||
bin/ec2delcgw
|
||||
bin/ec2deldopt
|
||||
bin/ec2delgrp
|
||||
bin/ec2delkey
|
||||
bin/ec2delpgrp
|
||||
bin/ec2delsds
|
||||
bin/ec2delsnap
|
||||
bin/ec2delsubnet
|
||||
bin/ec2deltag
|
||||
bin/ec2delvgw
|
||||
bin/ec2delvol
|
||||
bin/ec2delvpc
|
||||
bin/ec2delvpn
|
||||
bin/ec2dereg
|
||||
bin/ec2detvgw
|
||||
bin/ec2detvol
|
||||
bin/ec2dgrp
|
||||
bin/ec2diatt
|
||||
bin/ec2dim
|
||||
bin/ec2dimatt
|
||||
bin/ec2din
|
||||
bin/ec2dinatt
|
||||
bin/ec2disaddr
|
||||
bin/ec2dkey
|
||||
bin/ec2dlic
|
||||
bin/ec2dpgrp
|
||||
bin/ec2dre
|
||||
bin/ec2dri
|
||||
bin/ec2drio
|
||||
bin/ec2dsds
|
||||
bin/ec2dsir
|
||||
bin/ec2dsnap
|
||||
bin/ec2dsnapatt
|
||||
bin/ec2dsph
|
||||
bin/ec2dsubnet
|
||||
bin/ec2dtag
|
||||
bin/ec2dvgw
|
||||
bin/ec2dvol
|
||||
bin/ec2dvpc
|
||||
bin/ec2dvpn
|
||||
bin/ec2fp
|
||||
bin/ec2gcons
|
||||
bin/ec2gpass
|
||||
bin/ec2ii
|
||||
bin/ec2ikey
|
||||
bin/ec2iv
|
||||
bin/ec2kill
|
||||
bin/ec2matt
|
||||
bin/ec2miatt
|
||||
bin/ec2mim
|
||||
bin/ec2mimatt
|
||||
bin/ec2min
|
||||
bin/ec2minatt
|
||||
bin/ec2msnapatt
|
||||
bin/ec2prio
|
||||
bin/ec2ratt
|
||||
bin/ec2reboot
|
||||
bin/ec2reg
|
||||
bin/ec2reladdr
|
||||
bin/ec2revoke
|
||||
bin/ec2riatt
|
||||
bin/ec2rimatt
|
||||
bin/ec2rinatt
|
||||
bin/ec2rsi
|
||||
bin/ec2rsnapatt
|
||||
bin/ec2run
|
||||
bin/ec2start
|
||||
bin/ec2stop
|
||||
bin/ec2tag
|
||||
bin/ec2udi
|
||||
bin/ec2umin
|
||||
bin/ec2ver
|
||||
amazon-ec2/bin/ec2-activate-license
|
||||
amazon-ec2/bin/ec2-add-group
|
||||
amazon-ec2/bin/ec2-add-keypair
|
||||
amazon-ec2/bin/ec2-allocate-address
|
||||
amazon-ec2/bin/ec2-associate-address
|
||||
amazon-ec2/bin/ec2-associate-dhcp-options
|
||||
amazon-ec2/bin/ec2-attach-volume
|
||||
amazon-ec2/bin/ec2-attach-vpn-gateway
|
||||
amazon-ec2/bin/ec2-authorize
|
||||
amazon-ec2/bin/ec2-bundle-instance
|
||||
amazon-ec2/bin/ec2-cancel-bundle-task
|
||||
amazon-ec2/bin/ec2-cancel-conversion-task
|
||||
amazon-ec2/bin/ec2-cancel-spot-instance-requests
|
||||
amazon-ec2/bin/ec2-cmd
|
||||
amazon-ec2/bin/ec2-confirm-product-instance
|
||||
amazon-ec2/bin/ec2-create-customer-gateway
|
||||
amazon-ec2/bin/ec2-create-dhcp-options
|
||||
amazon-ec2/bin/ec2-create-image
|
||||
amazon-ec2/bin/ec2-create-placement-group
|
||||
amazon-ec2/bin/ec2-create-snapshot
|
||||
amazon-ec2/bin/ec2-create-spot-datafeed-subscription
|
||||
amazon-ec2/bin/ec2-create-subnet
|
||||
amazon-ec2/bin/ec2-create-tags
|
||||
amazon-ec2/bin/ec2-create-volume
|
||||
amazon-ec2/bin/ec2-create-vpc
|
||||
amazon-ec2/bin/ec2-create-vpn-connection
|
||||
amazon-ec2/bin/ec2-create-vpn-gateway
|
||||
amazon-ec2/bin/ec2-deactivate-license
|
||||
amazon-ec2/bin/ec2-delete-customer-gateway
|
||||
amazon-ec2/bin/ec2-delete-dhcp-options
|
||||
amazon-ec2/bin/ec2-delete-disk-image
|
||||
amazon-ec2/bin/ec2-delete-group
|
||||
amazon-ec2/bin/ec2-delete-keypair
|
||||
amazon-ec2/bin/ec2-delete-placement-group
|
||||
amazon-ec2/bin/ec2-delete-snapshot
|
||||
amazon-ec2/bin/ec2-delete-spot-datafeed-subscription
|
||||
amazon-ec2/bin/ec2-delete-subnet
|
||||
amazon-ec2/bin/ec2-delete-tags
|
||||
amazon-ec2/bin/ec2-delete-volume
|
||||
amazon-ec2/bin/ec2-delete-vpc
|
||||
amazon-ec2/bin/ec2-delete-vpn-connection
|
||||
amazon-ec2/bin/ec2-delete-vpn-gateway
|
||||
amazon-ec2/bin/ec2-deregister
|
||||
amazon-ec2/bin/ec2-describe-addresses
|
||||
amazon-ec2/bin/ec2-describe-availability-zones
|
||||
amazon-ec2/bin/ec2-describe-bundle-tasks
|
||||
amazon-ec2/bin/ec2-describe-conversion-tasks
|
||||
amazon-ec2/bin/ec2-describe-customer-gateways
|
||||
amazon-ec2/bin/ec2-describe-dhcp-options
|
||||
amazon-ec2/bin/ec2-describe-group
|
||||
amazon-ec2/bin/ec2-describe-image-attribute
|
||||
amazon-ec2/bin/ec2-describe-images
|
||||
amazon-ec2/bin/ec2-describe-instance-attribute
|
||||
amazon-ec2/bin/ec2-describe-instances
|
||||
amazon-ec2/bin/ec2-describe-keypairs
|
||||
amazon-ec2/bin/ec2-describe-licenses
|
||||
amazon-ec2/bin/ec2-describe-placement-groups
|
||||
amazon-ec2/bin/ec2-describe-regions
|
||||
amazon-ec2/bin/ec2-describe-reserved-instances
|
||||
amazon-ec2/bin/ec2-describe-reserved-instances-offerings
|
||||
amazon-ec2/bin/ec2-describe-snapshot-attribute
|
||||
amazon-ec2/bin/ec2-describe-snapshots
|
||||
amazon-ec2/bin/ec2-describe-spot-datafeed-subscription
|
||||
amazon-ec2/bin/ec2-describe-spot-instance-requests
|
||||
amazon-ec2/bin/ec2-describe-spot-price-history
|
||||
amazon-ec2/bin/ec2-describe-subnets
|
||||
amazon-ec2/bin/ec2-describe-tags
|
||||
amazon-ec2/bin/ec2-describe-volumes
|
||||
amazon-ec2/bin/ec2-describe-vpcs
|
||||
amazon-ec2/bin/ec2-describe-vpn-connections
|
||||
amazon-ec2/bin/ec2-describe-vpn-gateways
|
||||
amazon-ec2/bin/ec2-detach-volume
|
||||
amazon-ec2/bin/ec2-detach-vpn-gateway
|
||||
amazon-ec2/bin/ec2-disassociate-address
|
||||
amazon-ec2/bin/ec2-fingerprint-key
|
||||
amazon-ec2/bin/ec2-get-console-output
|
||||
amazon-ec2/bin/ec2-get-password
|
||||
amazon-ec2/bin/ec2-import-instance
|
||||
amazon-ec2/bin/ec2-import-keypair
|
||||
amazon-ec2/bin/ec2-import-volume
|
||||
amazon-ec2/bin/ec2-migrate-image
|
||||
amazon-ec2/bin/ec2-modify-image-attribute
|
||||
amazon-ec2/bin/ec2-modify-instance-attribute
|
||||
amazon-ec2/bin/ec2-modify-snapshot-attribute
|
||||
amazon-ec2/bin/ec2-monitor-instances
|
||||
amazon-ec2/bin/ec2-purchase-reserved-instances-offering
|
||||
amazon-ec2/bin/ec2-reboot-instances
|
||||
amazon-ec2/bin/ec2-register
|
||||
amazon-ec2/bin/ec2-release-address
|
||||
amazon-ec2/bin/ec2-request-spot-instances
|
||||
amazon-ec2/bin/ec2-reset-image-attribute
|
||||
amazon-ec2/bin/ec2-reset-instance-attribute
|
||||
amazon-ec2/bin/ec2-reset-snapshot-attribute
|
||||
amazon-ec2/bin/ec2-revoke
|
||||
amazon-ec2/bin/ec2-run-instances
|
||||
amazon-ec2/bin/ec2-start-instances
|
||||
amazon-ec2/bin/ec2-stop-instances
|
||||
amazon-ec2/bin/ec2-terminate-instances
|
||||
amazon-ec2/bin/ec2-unmonitor-instances
|
||||
amazon-ec2/bin/ec2-upload-disk-image
|
||||
amazon-ec2/bin/ec2-version
|
||||
amazon-ec2/bin/ec2actlic
|
||||
amazon-ec2/bin/ec2addcgw
|
||||
amazon-ec2/bin/ec2adddopt
|
||||
amazon-ec2/bin/ec2addgrp
|
||||
amazon-ec2/bin/ec2addkey
|
||||
amazon-ec2/bin/ec2addpgrp
|
||||
amazon-ec2/bin/ec2addsds
|
||||
amazon-ec2/bin/ec2addsnap
|
||||
amazon-ec2/bin/ec2addsubnet
|
||||
amazon-ec2/bin/ec2addtag
|
||||
amazon-ec2/bin/ec2addvgw
|
||||
amazon-ec2/bin/ec2addvol
|
||||
amazon-ec2/bin/ec2addvpc
|
||||
amazon-ec2/bin/ec2addvpn
|
||||
amazon-ec2/bin/ec2allocaddr
|
||||
amazon-ec2/bin/ec2assocaddr
|
||||
amazon-ec2/bin/ec2assocdopt
|
||||
amazon-ec2/bin/ec2attvgw
|
||||
amazon-ec2/bin/ec2attvol
|
||||
amazon-ec2/bin/ec2auth
|
||||
amazon-ec2/bin/ec2bundle
|
||||
amazon-ec2/bin/ec2cbun
|
||||
amazon-ec2/bin/ec2cct
|
||||
amazon-ec2/bin/ec2cim
|
||||
amazon-ec2/bin/ec2cpi
|
||||
amazon-ec2/bin/ec2csir
|
||||
amazon-ec2/bin/ec2daddr
|
||||
amazon-ec2/bin/ec2datt
|
||||
amazon-ec2/bin/ec2daz
|
||||
amazon-ec2/bin/ec2dbun
|
||||
amazon-ec2/bin/ec2dcgw
|
||||
amazon-ec2/bin/ec2dct
|
||||
amazon-ec2/bin/ec2ddi
|
||||
amazon-ec2/bin/ec2ddopt
|
||||
amazon-ec2/bin/ec2deactlic
|
||||
amazon-ec2/bin/ec2delcgw
|
||||
amazon-ec2/bin/ec2deldopt
|
||||
amazon-ec2/bin/ec2delgrp
|
||||
amazon-ec2/bin/ec2delkey
|
||||
amazon-ec2/bin/ec2delpgrp
|
||||
amazon-ec2/bin/ec2delsds
|
||||
amazon-ec2/bin/ec2delsnap
|
||||
amazon-ec2/bin/ec2delsubnet
|
||||
amazon-ec2/bin/ec2deltag
|
||||
amazon-ec2/bin/ec2delvgw
|
||||
amazon-ec2/bin/ec2delvol
|
||||
amazon-ec2/bin/ec2delvpc
|
||||
amazon-ec2/bin/ec2delvpn
|
||||
amazon-ec2/bin/ec2dereg
|
||||
amazon-ec2/bin/ec2detvgw
|
||||
amazon-ec2/bin/ec2detvol
|
||||
amazon-ec2/bin/ec2dgrp
|
||||
amazon-ec2/bin/ec2diatt
|
||||
amazon-ec2/bin/ec2dim
|
||||
amazon-ec2/bin/ec2dimatt
|
||||
amazon-ec2/bin/ec2din
|
||||
amazon-ec2/bin/ec2dinatt
|
||||
amazon-ec2/bin/ec2disaddr
|
||||
amazon-ec2/bin/ec2dkey
|
||||
amazon-ec2/bin/ec2dlic
|
||||
amazon-ec2/bin/ec2dpgrp
|
||||
amazon-ec2/bin/ec2dre
|
||||
amazon-ec2/bin/ec2dri
|
||||
amazon-ec2/bin/ec2drio
|
||||
amazon-ec2/bin/ec2dsds
|
||||
amazon-ec2/bin/ec2dsir
|
||||
amazon-ec2/bin/ec2dsnap
|
||||
amazon-ec2/bin/ec2dsnapatt
|
||||
amazon-ec2/bin/ec2dsph
|
||||
amazon-ec2/bin/ec2dsubnet
|
||||
amazon-ec2/bin/ec2dtag
|
||||
amazon-ec2/bin/ec2dvgw
|
||||
amazon-ec2/bin/ec2dvol
|
||||
amazon-ec2/bin/ec2dvpc
|
||||
amazon-ec2/bin/ec2dvpn
|
||||
amazon-ec2/bin/ec2fp
|
||||
amazon-ec2/bin/ec2gcons
|
||||
amazon-ec2/bin/ec2gpass
|
||||
amazon-ec2/bin/ec2ii
|
||||
amazon-ec2/bin/ec2ikey
|
||||
amazon-ec2/bin/ec2iv
|
||||
amazon-ec2/bin/ec2kill
|
||||
amazon-ec2/bin/ec2matt
|
||||
amazon-ec2/bin/ec2miatt
|
||||
amazon-ec2/bin/ec2mim
|
||||
amazon-ec2/bin/ec2mimatt
|
||||
amazon-ec2/bin/ec2min
|
||||
amazon-ec2/bin/ec2minatt
|
||||
amazon-ec2/bin/ec2msnapatt
|
||||
amazon-ec2/bin/ec2prio
|
||||
amazon-ec2/bin/ec2ratt
|
||||
amazon-ec2/bin/ec2reboot
|
||||
amazon-ec2/bin/ec2reg
|
||||
amazon-ec2/bin/ec2reladdr
|
||||
amazon-ec2/bin/ec2revoke
|
||||
amazon-ec2/bin/ec2riatt
|
||||
amazon-ec2/bin/ec2rimatt
|
||||
amazon-ec2/bin/ec2rinatt
|
||||
amazon-ec2/bin/ec2rsi
|
||||
amazon-ec2/bin/ec2rsnapatt
|
||||
amazon-ec2/bin/ec2run
|
||||
amazon-ec2/bin/ec2start
|
||||
amazon-ec2/bin/ec2stop
|
||||
amazon-ec2/bin/ec2tag
|
||||
amazon-ec2/bin/ec2udi
|
||||
amazon-ec2/bin/ec2umin
|
||||
amazon-ec2/bin/ec2ver
|
||||
amazon-ec2/lib/activation-1.1.jar
|
||||
amazon-ec2/lib/bcprov.jar
|
||||
amazon-ec2/lib/commons-cli-1.1.jar
|
||||
amazon-ec2/lib/commons-codec-1.3.jar
|
||||
amazon-ec2/lib/commons-discovery-0.2.jar
|
||||
amazon-ec2/lib/commons-httpclient-3.0.jar
|
||||
amazon-ec2/lib/commons-logging-1.0.4.jar
|
||||
amazon-ec2/lib/ec2-api-tools.jar
|
||||
amazon-ec2/lib/ec2-conversion-lib.jar
|
||||
amazon-ec2/lib/ec2-java-client.jar
|
||||
amazon-ec2/lib/java-xmlbuilder-0.4-SNAPSHOT.jar
|
||||
amazon-ec2/lib/jaxb-api-2.0.jar
|
||||
amazon-ec2/lib/jaxb-impl-2.0.1.jar
|
||||
amazon-ec2/lib/jaxws-api-2.0.jar
|
||||
amazon-ec2/lib/jdom-1.0.jar
|
||||
amazon-ec2/lib/jets3t-0.8.0.jar
|
||||
amazon-ec2/lib/log4j.jar
|
||||
amazon-ec2/lib/mail-1.4.jar
|
||||
amazon-ec2/lib/stax-api-1.0.1.jar
|
||||
amazon-ec2/lib/wsdl4j-1.6.1.jar
|
||||
amazon-ec2/lib/wss4j-1.5.1.jar
|
||||
amazon-ec2/lib/wstx-asl-3.2.0.jar
|
||||
amazon-ec2/lib/xalan-j2-2.7.0.jar
|
||||
amazon-ec2/lib/xalan-j2-serializer-2.7.0.jar
|
||||
amazon-ec2/lib/xfire-all-1.2.6.jar
|
||||
amazon-ec2/lib/xfire-jsr181-api-1.0-M1.jar
|
||||
amazon-ec2/lib/xmlsec-1.3.0.jar
|
7
ec2-api-tools/distinfo
Normal file
7
ec2-api-tools/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2011/01/20 00:31:39 jym-netbsd Exp $
|
||||
|
||||
SHA1 (ec2-api-tools-1.3-62308.zip) = 28e3944391ad197e235a549ecf573007eb0a786d
|
||||
RMD160 (ec2-api-tools-1.3-62308.zip) = e00874fd258af7912b4c1b6acfb56e6746ac7c77
|
||||
Size (ec2-api-tools-1.3-62308.zip) = 8946930 bytes
|
||||
SHA1 (patch-aa) = 7fcc4576ad658054f0f42ec688269839951135e8
|
||||
SHA1 (patch-ab) = adf5fa6a389b275aa9d6d408c3982efdbcc61aa7
|
13
ec2-api-tools/patches/patch-aa
Normal file
13
ec2-api-tools/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2011/01/20 00:31:39 jym-netbsd Exp $
|
||||
Prepare for substitution of the Java home path.
|
||||
--- bin/ec2-cmd.orig 2010-12-15 17:41:53.000000000 +0000
|
||||
+++ bin/ec2-cmd
|
||||
@@ -14,7 +14,7 @@ EC2_HOME=${EC2_HOME:-EC2_HOME is not set
|
||||
LIBDIR=$EC2_HOME/lib
|
||||
|
||||
# Check our Java env
|
||||
-JAVA_HOME=${JAVA_HOME:?JAVA_HOME is not set}
|
||||
+JAVA_HOME=@PKG_JAVA_HOME@
|
||||
|
||||
# If a classpath exists preserve it
|
||||
CP=$CLASSPATH
|
13
ec2-api-tools/patches/patch-ab
Normal file
13
ec2-api-tools/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2011/01/20 00:31:39 jym-netbsd Exp $
|
||||
Remove bashism.
|
||||
--- bin/ec2-cmd.orig 2010-12-15 17:41:53.000000000 +0000
|
||||
+++ bin/ec2-cmd
|
||||
@@ -29,7 +29,7 @@ esac
|
||||
cygprop=""
|
||||
|
||||
# And add our own libraries too
|
||||
-if [ "$cygwin" == "true" ] ; then
|
||||
+if [ "$cygwin" = "true" ] ; then
|
||||
cygprop="-Dec2.cygwin=true"
|
||||
|
||||
# Make sure that when using Cygwin we use Unix
|
Loading…
Reference in a new issue