cpdup works like the standard 'cp' program but is designed to make exact mirrors of directory trees by default, whereas the 'cp' program requires a ton of options to even come close (and even then doesn't do it properly).

This commit is contained in:
Adam Hoka 2007-06-08 01:10:17 +00:00 committed by Thomas Klausner
parent b91cbac33d
commit 04823dd541
6 changed files with 60 additions and 0 deletions

3
cpdup/DESCR Normal file
View file

@ -0,0 +1,3 @@
It works like the standard 'cp' program but is designed to make exact mirrors of
directory trees by default, whereas the 'cp' program requires a ton of options
to even come close (and even then doesn't do it properly).

20
cpdup/Makefile Normal file
View file

@ -0,0 +1,20 @@
# $NetBSD: Makefile,v 1.1.1.1 2007/06/08 01:10:17 hoka_adam Exp $
#
DISTNAME= cpdup-1.07
CATEGORIES= sysutils
MASTER_SITES= http://apollo.backplane.com/FreeSrc/ \
http://utenti.gufi.org/~gmarco/files/distfiles/
EXTRACT_SUFX= .tgz
MAINTAINER= adam.hoka@gmail.com
HOMEPAGE= http://apollo.backplane.com/FreeSrc/
COMMENT= Designed to make exact mirrors of directory trees
WRKSRC= ${WRKDIR}/cpdup
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cpdup ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/cpdup.1 ${PREFIX}/${PKGMANDIR}/man1
.include "../../mk/bsd.pkg.mk"

3
cpdup/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2007/06/08 01:10:17 hoka_adam Exp $
bin/cpdup
man/man1/cpdup.1

7
cpdup/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2007/06/08 01:10:17 hoka_adam Exp $
SHA1 (cpdup-1.07.tgz) = c5bf465a5331c7c507a90ad0dfe34858dfce82f8
RMD160 (cpdup-1.07.tgz) = 14cb34a206eb8c65fa2b594ffdcbd7e6b62fadfd
Size (cpdup-1.07.tgz) = 23242 bytes
SHA1 (patch-aa) = abedd03e5b451e54453c2b358b84cc37abf645b3
SHA1 (patch-ab) = 2845c3d73cd4c35bb2441069273182048472098f

15
cpdup/patches/patch-aa Normal file
View file

@ -0,0 +1,15 @@
$NetBSD: patch-aa,v 1.1.1.1 2007/06/08 01:10:17 hoka_adam Exp $
--- Makefile.orig 2007-06-08 02:02:17.000000000 +0200
+++ Makefile
@@ -8,8 +8,8 @@ SRCS= cpdup.c hcproto.c hclink.c misc.c
SRCS+= md5.c
.endif
-LDADD+= -lmd
-DPADD+= ${LIBMD}
+#LDADD+= -lmd
+#DPADD+= ${LIBMD}
.include <bsd.prog.mk>

12
cpdup/patches/patch-ab Normal file
View file

@ -0,0 +1,12 @@
$NetBSD: patch-ab,v 1.1.1.1 2007/06/08 01:10:17 hoka_adam Exp $
--- md5.c.orig 2006-08-13 22:24:35.000000000 +0200
+++ md5.c
@@ -266,6 +266,6 @@ doMD5File(const char *filename, char *bu
CountReadBytes += size;
}
}
- return MD5File(filename, buf);
+ return doMD5File(filename, buf);
}