Add patch from next build: Rename wcwidth() to ucs_wcwidth() to avoid
conflict on NetBSD-current, Solaris, etc.
This commit is contained in:
parent
e0773228de
commit
05b0e080b8
2 changed files with 53 additions and 1 deletions
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.20 2003/10/18 14:50:14 tvierling Exp $
|
||||
$NetBSD: distinfo,v 1.21 2003/10/19 14:52:35 tvierling Exp $
|
||||
|
||||
SHA1 (entropy-0.5.9-346.tgz) = e0b0e8a38d1a6b3e8d316edd47d6cd5220dcfff1
|
||||
Size (entropy-0.5.9-346.tgz) = 683155 bytes
|
||||
SHA1 (patch-aa) = 39610404253e577e57f98d46999730420a1aa30e
|
||||
SHA1 (patch-ac) = cf51c4f645edc3f5307548033526d9da4af9c078
|
||||
|
|
51
entropy/patches/patch-aa
Normal file
51
entropy/patches/patch-aa
Normal file
|
@ -0,0 +1,51 @@
|
|||
Index: include/unicode.h
|
||||
===================================================================
|
||||
RCS file: /home/cvs/entropy/include/unicode.h,v
|
||||
retrieving revision 1.9
|
||||
retrieving revision 1.10
|
||||
diff -u -r1.9 -r1.10
|
||||
--- include/unicode.h 12 Sep 2003 22:01:46 -0000 1.9
|
||||
+++ include/unicode.h 19 Oct 2003 14:50:07 -0000 1.10
|
||||
@@ -289,7 +289,7 @@
|
||||
#endif
|
||||
|
||||
#if NEED_WCWIDTH
|
||||
-int wcwidth(u_int32_t ucs);
|
||||
+int ucs_wcwidth(u_int32_t ucs);
|
||||
#endif
|
||||
|
||||
#if NEED_WCRANGES
|
||||
Index: src/unicode.c
|
||||
===================================================================
|
||||
RCS file: /home/cvs/entropy/src/unicode.c,v
|
||||
retrieving revision 1.20
|
||||
retrieving revision 1.21
|
||||
diff -u -r1.20 -r1.21
|
||||
--- src/unicode.c 26 Sep 2003 15:14:25 -0000 1.20
|
||||
+++ src/unicode.c 19 Oct 2003 14:50:07 -0000 1.21
|
||||
@@ -3890,7 +3890,7 @@
|
||||
#endif
|
||||
|
||||
#if NEED_WCWIDTH
|
||||
-int wcwidth(u_int32_t ucs)
|
||||
+int ucs_wcwidth(u_int32_t ucs)
|
||||
{
|
||||
/* sorted list of non-overlapping intervals of non-spacing characters */
|
||||
static const struct interval {
|
||||
Index: src/vt.c
|
||||
===================================================================
|
||||
RCS file: /home/cvs/entropy/src/vt.c,v
|
||||
retrieving revision 1.15
|
||||
retrieving revision 1.16
|
||||
diff -u -r1.15 -r1.16
|
||||
--- src/vt.c 30 Jul 2003 04:20:49 -0000 1.15
|
||||
+++ src/vt.c 19 Oct 2003 14:50:07 -0000 1.16
|
||||
@@ -1393,7 +1393,7 @@
|
||||
break;
|
||||
|
||||
/* is this a combining character? */
|
||||
- if (0 == wcwidth(tc)) {
|
||||
+ if (0 == ucs_wcwidth(tc)) {
|
||||
vt_att_t chr = vt->screen[vt->cur.y][vt->cur.x];
|
||||
chr.comb = (u_int16_t)tc;
|
||||
if (vt->bdf.bbx[tc].w > vt->bdf.fw)
|
Loading…
Reference in a new issue