Upadate redis to 2.2.2

Changelog:
* Now Redis has a clean, powerful, supported C library: hiredis.
* Specially encoded data types, small lists and sets can now use up to an order of magnitude less memory.
* VM partial rewrite for code cleaness and memory usage.
* Change to the implementation of the top level dictionary for better memory efficienty.
* Sorted sets are now less memory hungry.
[...]
see https://github.com/antirez/redis/raw/2.2/00-RELEASENOTES for all changes
This commit is contained in:
Claude Charpentier 2011-03-08 10:52:25 +00:00 committed by Thomas Klausner
parent b5391b133d
commit 06ec41c0f6
6 changed files with 129 additions and 61 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.2 2010/12/14 13:31:05 fhajny Exp $
# $NetBSD: Makefile,v 1.3 2011/03/08 10:52:25 zatmania Exp $
#
DISTNAME= redis-2.0.4
DISTNAME= redis-2.2.2
CATEGORIES= databases
MASTER_SITES= http://redis.googlecode.com/files/
@ -21,7 +21,7 @@ RCD_SCRIPTS+= redis
RCD_SCRIPT_SRC.redis= ${FILESDIR}/redis.sh
DOCDIR= share/doc/redis
DOCFILES+= 00-RELEASENOTES BETATESTING.txt BUGS COPYING \
DOCFILES+= 00-RELEASENOTES BUGS COPYING \
Changelog README
EGDIR= ${PREFIX}/share/examples/${PKGBASE}
INSTALLATION_DIRS+= bin ${DOCDIR} ${EGDIR} ${EGDIR}/utils ${EGDIR}/tests
@ -45,7 +45,7 @@ PKG_USERS+= ${REDIS_USER}:${REDIS_GROUP}
PKG_GECOS.${REDIS_USER}= Redis daemon user
PKG_HOME.${REDIS_USER}= ${REDIS_DBDIR}
FILES_SUBST+= REDIS_USER=${REDIS_USER:Q}
FILES_SUBST+= REDIS_USER=${REDIS_USER}
SUBST_CLASSES+= fix-paths
SUBST_STAGE.fix-paths= post-patch

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2010/12/05 17:24:18 zatmania Exp $
@comment $NetBSD: PLIST,v 1.2 2011/03/08 10:52:25 zatmania Exp $
bin/redis-benchmark
bin/redis-check-aof
bin/redis-check-dump
@ -8,12 +8,12 @@ share/doc/redis/00-RELEASENOTES
share/doc/redis/AppendCommand.html
share/doc/redis/AppendOnlyFileHowto.html
share/doc/redis/AuthCommand.html
share/doc/redis/BETATESTING.txt
share/doc/redis/BUGS
share/doc/redis/Benchmarks.html
share/doc/redis/BgrewriteaofCommand.html
share/doc/redis/BgsaveCommand.html
share/doc/redis/BlpopCommand.html
share/doc/redis/BrpoplpushCommand.html
share/doc/redis/COPYING
share/doc/redis/Changelog
share/doc/redis/CommandReference.html
@ -36,6 +36,7 @@ share/doc/redis/FlushdbCommand.html
share/doc/redis/FromSqlToDataStructures.html
share/doc/redis/GenericCommandsSidebar.html
share/doc/redis/GetCommand.html
share/doc/redis/GetbitCommand.html
share/doc/redis/GetsetCommand.html
share/doc/redis/HackingStrings.html
share/doc/redis/HashCommandsSidebar.html
@ -87,8 +88,11 @@ share/doc/redis/RedisCLI.html
share/doc/redis/RedisEventLibrary.html
share/doc/redis/RedisGuides.html
share/doc/redis/RedisInternals.html
share/doc/redis/RedisPipelining.html
share/doc/redis/RedisStatus.html
share/doc/redis/Redis_1_2_0_Changelog.html
share/doc/redis/Redis_2_0_0_Changelog.html
share/doc/redis/Redis_2_0_Whats_new.html
share/doc/redis/RenameCommand.html
share/doc/redis/RenamenxCommand.html
share/doc/redis/ReplicationHowto.html
@ -104,8 +108,10 @@ share/doc/redis/SdiffstoreCommand.html
share/doc/redis/SelectCommand.html
share/doc/redis/SetCommand.html
share/doc/redis/SetCommandsSidebar.html
share/doc/redis/SetbitCommand.html
share/doc/redis/SetexCommand.html
share/doc/redis/SetnxCommand.html
share/doc/redis/SetrangeCommand.html
share/doc/redis/Sets.html
share/doc/redis/ShutdownCommand.html
share/doc/redis/SideBar.html
@ -125,6 +131,7 @@ share/doc/redis/SrandmemberCommand.html
share/doc/redis/SremCommand.html
share/doc/redis/StringCommandsSidebar.html
share/doc/redis/Strings.html
share/doc/redis/StrlenCommand.html
share/doc/redis/SubstrCommand.html
share/doc/redis/SunionCommand.html
share/doc/redis/SunionstoreCommand.html
@ -134,7 +141,6 @@ share/doc/redis/TemplateCommand.html
share/doc/redis/TtlCommand.html
share/doc/redis/TwitterAlikeExample.html
share/doc/redis/TypeCommand.html
share/doc/redis/UDP.html
share/doc/redis/UnstableSource.html
share/doc/redis/VirtualMemorySpecification.html
share/doc/redis/VirtualMemoryUserGuide.html
@ -157,6 +163,7 @@ share/examples/rc.d/redis
share/examples/redis/redis.conf.example
share/examples/redis/tests/assets/default.conf
share/examples/redis/tests/integration/aof.tcl
share/examples/redis/tests/integration/redis-cli.tcl
share/examples/redis/tests/integration/replication.tcl
share/examples/redis/tests/support/redis.tcl
share/examples/redis/tests/support/server.tcl
@ -167,15 +174,20 @@ share/examples/redis/tests/test_helper.tcl
share/examples/redis/tests/tmp/.gitignore
share/examples/redis/tests/unit/auth.tcl
share/examples/redis/tests/unit/basic.tcl
share/examples/redis/tests/unit/cas.tcl
share/examples/redis/tests/unit/expire.tcl
share/examples/redis/tests/unit/other.tcl
share/examples/redis/tests/unit/protocol.tcl
share/examples/redis/tests/unit/pubsub.tcl
share/examples/redis/tests/unit/quit.tcl
share/examples/redis/tests/unit/sort.tcl
share/examples/redis/tests/unit/type/hash.tcl
share/examples/redis/tests/unit/type/list.tcl
share/examples/redis/tests/unit/type/set.tcl
share/examples/redis/tests/unit/type/zset.tcl
share/examples/redis/utils/build-static-symbols.tcl
share/examples/redis/utils/generate-command-help.rb
share/examples/redis/utils/mktarball.sh
share/examples/redis/utils/redis-copy.rb
share/examples/redis/utils/redis-sha1.rb
share/examples/redis/utils/redis_init_script

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.2 2010/12/14 13:31:05 fhajny Exp $
$NetBSD: distinfo,v 1.3 2011/03/08 10:52:25 zatmania Exp $
SHA1 (redis-2.0.4.tar.gz) = fee2f1960eda22385503517a9a6dcae610df84d5
RMD160 (redis-2.0.4.tar.gz) = e8ae60e9c5cf79b2f81233bfa6516659fea3983f
Size (redis-2.0.4.tar.gz) = 346383 bytes
SHA1 (patch-aa) = 9a70e2feb37483bc92586011330b353405814387
SHA1 (patch-ab) = e1ddb3edd2c37b5b65a65d8d1019b2179f39e01d
SHA1 (redis-2.2.2.tar.gz) = 75b953e4a3067570555c5f3f5e8f481c40489904
RMD160 (redis-2.2.2.tar.gz) = a7a21ab6aa07f79e5cdeb991a26dd1d55446e38e
Size (redis-2.2.2.tar.gz) = 446269 bytes
SHA1 (patch-aa) = 6d6173e7b3184776c12fd4c4a9f5d7ed80041963
SHA1 (patch-ab) = 331beaba6e0d0b5251f3ed58ec83db1acc3ba642
SHA1 (patch-ac) = 46367c8e94489945f4f72f911fd171de5e4d45b3

View file

@ -1,43 +1,50 @@
$NetBSD: patch-aa,v 1.2 2010/12/14 13:31:05 fhajny Exp $
$NetBSD: patch-aa,v 1.3 2011/03/08 10:52:25 zatmania Exp $
Change the default config file to something more production like.
--- redis.conf.orig 2010-07-01 18:36:31.000000000 +0000
+++ redis.conf
@@ -14,11 +14,11 @@
Fix CFLAGS and INSTALL support to pkgsrc standards.
--- deps/hiredis/Makefile.orig 2011-03-04 15:31:20.000000000 +0000
+++ deps/hiredis/Makefile
@@ -8,7 +8,7 @@ BINS = hiredis-example hiredis-test
uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
OPTIMIZATION?=-O3
ifeq ($(uname_S),SunOS)
- CFLAGS?=-std=c99 -pedantic $(OPTIMIZATION) -fPIC -Wall -W -D__EXTENSIONS__ -D_XPG6 $(ARCH) $(PROF)
+ CCFLAGS?= $(CFLAGS) -std=c99 -pedantic $(OPTIMIZATION) -fPIC -Wall -W -D__EXTENSIONS__ -D_XPG6 $(ARCH) $(PROF)
CCLINK?=-ldl -lnsl -lsocket -lm -lpthread
LDFLAGS?=-L. -Wl,-R,.
DYLIBNAME?=libhiredis.so
@@ -16,7 +16,7 @@ ifeq ($(uname_S),SunOS)
STLIBNAME?=libhiredis.a
STLIB_MAKE_CMD?=ar rcs ${STLIBNAME} ${OBJ}
else ifeq ($(uname_S),Darwin)
- CFLAGS?=-std=c99 -pedantic $(OPTIMIZATION) -fPIC -Wall -W -Wwrite-strings $(ARCH) $(PROF)
+ CiCFLAGS?= $(CFLAGS) -std=c99 -pedantic $(OPTIMIZATION) -fPIC -Wall -W -Wwrite-strings $(ARCH) $(PROF)
CCLINK?=-lm -pthread
LDFLAGS?=-L. -Wl,-rpath,.
OBJARCH?=-arch i386 -arch x86_64
@@ -25,7 +25,7 @@ else ifeq ($(uname_S),Darwin)
STLIBNAME?=libhiredis.a
STLIB_MAKE_CMD?=libtool -static -o ${STLIBNAME} - ${OBJ}
else
- CFLAGS?=-std=c99 -pedantic $(OPTIMIZATION) -fPIC -Wall -W -Wwrite-strings $(ARCH) $(PROF)
+ CCFLAGS?= $(CFLAGS) -std=c99 -pedantic $(OPTIMIZATION) -fPIC -Wall -W -Wwrite-strings $(ARCH) $(PROF)
CCLINK?=-lm -pthread
LDFLAGS?=-L. -Wl,-rpath,.
DYLIBNAME?=libhiredis.so
@@ -36,7 +36,7 @@ endif
CCOPT= $(CFLAGS) $(CCLINK)
DEBUG?= -g -ggdb
# By default Redis does not run as a daemon. Use 'yes' if you need it.
# Note that Redis will write a pid file in /var/run/redis.pid when daemonized.
-daemonize no
+daemonize yes
-PREFIX?= /usr/local
+PREFIX?= ./
INSTALL_INC= $(PREFIX)/include/hiredis
INSTALL_LIB= $(PREFIX)/lib
INSTALL= cp -a
@@ -83,7 +83,7 @@ test: hiredis-test
./hiredis-test
# When running daemonized, Redis writes a pid file in /var/run/redis.pid by
# default. You can specify a custom pid file location here.
-pidfile /var/run/redis.pid
+pidfile @@PIDDIR@@/redis.pid
# Accept connections on the specified port, default is 6379
port 6379
@@ -37,12 +37,12 @@ timeout 300
# verbose (many rarely useful info, but not a mess like the debug level)
# notice (moderately verbose, what you want in production probably)
# warning (only very important / critical messages are logged)
-loglevel verbose
+loglevel warning
# Specify the log file name. Also 'stdout' can be used to force
# Redis to log on the standard output. Note that if you use standard
# output for logging but daemonize, logs will be sent to /dev/null
-logfile stdout
+logfile @@LOGDIR@@/redis.log
# Set the number of databases. The default database is DB 0, you can select
# a different one on a per-connection basis using SELECT <dbid> where
@@ -86,7 +86,7 @@ dbfilename dump.rdb
# Also the Append Only File will be created inside this directory.
#
# Note that you must specify a directory here, not a file name.
-dir ./
+dir @@DBDIR@@
################################# REPLICATION #################################
.c.o:
- $(CC) -c $(CFLAGS) $(OBJARCH) $(DEBUG) $(COMPILE_TIME) $<
+ $(CC) -c $(CCFLAGS) $(OBJARCH) $(DEBUG) $(COMPILE_TIME) $<
clean:
rm -rf ${DYLIBNAME} ${STLIBNAME} $(BINS) hiredis-example* *.o *.gcda *.gcno *.gcov

View file

@ -1,34 +1,39 @@
$NetBSD: patch-ab,v 1.1 2010/12/14 13:31:05 fhajny Exp $
$NetBSD: patch-ab,v 1.2 2011/03/08 10:52:25 zatmania Exp $
Fix CFLAGS and INSTALL support to pkgsrc standards.
--- Makefile.orig 2010-11-06 09:07:03.000000000 +0000
+++ Makefile
@@ -6,18 +6,18 @@ release_hdr := $(shell sh -c './mkreleas
--- src/Makefile.orig 2011-03-04 15:31:20.000000000 +0000
+++ src/Makefile
@@ -6,11 +6,11 @@ release_hdr := $(shell sh -c './mkreleas
uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
OPTIMIZATION?=-O2
ifeq ($(uname_S),SunOS)
- CFLAGS?= -std=c99 -pedantic $(OPTIMIZATION) -Wall -W -D__EXTENSIONS__ -D_XPG6
+ CCFLAGS= $(CFLAGS) -std=c99 -pedantic $(OPTIMIZATION) -Wall -W -D__EXTENSIONS__ -D_XPG6
CCLINK?= -ldl -lnsl -lsocket -lm -lpthread
DEBUG?= -g -ggdb
else
- CFLAGS?= -std=c99 -pedantic $(OPTIMIZATION) -Wall -W $(ARCH) $(PROF)
+ CCFLAGS= $(CFLAGS) -std=c99 -pedantic $(OPTIMIZATION) -Wall -W $(ARCH) $(PROF)
CCLINK?= -lm -pthread
DEBUG?= -g -rdynamic -ggdb
endif
@@ -19,11 +19,11 @@ ifeq ($(USE_TCMALLOC),yes)
CCLINK+= -ltcmalloc
CFLAGS+= -DUSE_TCMALLOC
endif
-CCOPT= $(CFLAGS) $(CCLINK) $(ARCH) $(PROF)
+CCOPT= $(CCFLAGS) $(CCLINK) $(ARCH) $(PROF)
DEBUG?= -g -rdynamic -ggdb
-INSTALL_TOP= /usr/local
-INSTALL_BIN= $(INSTALL_TOP)/bin
-PREFIX= /usr/local
-INSTALL_BIN= $(PREFIX)/bin
-INSTALL= cp -p
+INSTALL_TOP= $(PREFIX)
+INSTALL_BIN= $(DESTDIR)$(INSTALL_TOP)/bin
+INSTALL= $(BSD_INSTALL_PROGRAM)
OBJ = adlist.o ae.o anet.o dict.o redis.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o
OBJ = adlist.o ae.o anet.o dict.o redis.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o vm.o pubsub.o multi.o debug.o sort.o intset.o syncio.o
BENCHOBJ = ae.o anet.o redis-benchmark.o sds.o adlist.o zmalloc.o
@@ -80,7 +80,7 @@ redis-check-aof: $(CHECKAOFOBJ)
@@ -133,7 +133,7 @@ redis-check-aof: $(CHECKAOFOBJ)
$(CC) -o $(CHECKAOFPRGNAME) $(CCOPT) $(DEBUG) $(CHECKAOFOBJ)
.c.o:

43
redis/patches/patch-ac Normal file
View file

@ -0,0 +1,43 @@
$NetBSD: patch-ac,v 1.1 2011/03/08 10:52:25 zatmania Exp $
Change the default config file to something more production like.
--- redis.conf.orig 2011-03-04 15:31:20.000000000 +0000
+++ redis.conf
@@ -14,11 +14,11 @@
# By default Redis does not run as a daemon. Use 'yes' if you need it.
# Note that Redis will write a pid file in /var/run/redis.pid when daemonized.
-daemonize no
+daemonize yes
# When running daemonized, Redis writes a pid file in /var/run/redis.pid by
# default. You can specify a custom pid file location here.
-pidfile /var/run/redis.pid
+pidfile @@PIDDIR@@/redis.pid
# Accept connections on the specified port, default is 6379.
# If port 0 is specified Redis will not listen on a TCP socket.
@@ -44,12 +44,12 @@ timeout 300
# verbose (many rarely useful info, but not a mess like the debug level)
# notice (moderately verbose, what you want in production probably)
# warning (only very important / critical messages are logged)
-loglevel verbose
+loglevel warning
# Specify the log file name. Also 'stdout' can be used to force
# Redis to log on the standard output. Note that if you use standard
# output for logging but daemonize, logs will be sent to /dev/null
-logfile stdout
+logfile @@LOGDIR@@/redis.log
# To enable logging to the system logger, just set 'syslog-enabled' to yes,
# and optionally update the other syslog parameters to suit your needs.
@@ -103,7 +103,7 @@ dbfilename dump.rdb
# Also the Append Only File will be created inside this directory.
#
# Note that you must specify a directory here, not a file name.
-dir ./
+dir @@DBDIR@@
################################# REPLICATION #################################