MyDNS is a free DNS server for UNIX. It was implemented from scratch and
is designed to serve records directly from an SQL database (currently either MySQL or PostgreSQL). This package provides the PostgreSQL-based version.
This commit is contained in:
parent
ed9018de5d
commit
06f9a6aab1
8 changed files with 155 additions and 0 deletions
23
mydns-pgsql/DESCR
Normal file
23
mydns-pgsql/DESCR
Normal file
|
@ -0,0 +1,23 @@
|
|||
MyDNS is a free DNS server for UNIX. It was implemented from scratch and
|
||||
is designed to serve records directly from an SQL database (currently
|
||||
either MySQL or PostgreSQL).
|
||||
|
||||
Its primary objectives are stability, security, interoperability, and
|
||||
speed, though not necessarily in that order.
|
||||
|
||||
MyDNS does not include recursive name service, nor a resolver library.
|
||||
It is primarily designed for organizations with many zones and/or
|
||||
resource records who desire the ability to perform real-time dynamic
|
||||
updates on their DNS data via MySQL.
|
||||
|
||||
MyDNS starts and is ready to answer questions immediately, no matter how
|
||||
much DNS data you have in the database. It is very fast and memory-
|
||||
efficient. It includes complete documentation, including a manual and a
|
||||
FAQ.
|
||||
|
||||
MyDNS supports a few frills, including round robin DNS, dynamic load
|
||||
balancing, and outgoing AXFR for non-MyDNS nameservers.
|
||||
|
||||
MyDNS is licensed under the GNU General Public License.
|
||||
|
||||
This package provides the PostgreSQL-based version.
|
11
mydns-pgsql/MESSAGE
Normal file
11
mydns-pgsql/MESSAGE
Normal file
|
@ -0,0 +1,11 @@
|
|||
===========================================================================
|
||||
$NetBSD: MESSAGE,v 1.1.1.1 2005/09/09 12:38:12 ghen Exp $
|
||||
|
||||
MyDNS uses two tables in a PostgreSQL database: "soa" and "rr" (you can
|
||||
change this in ${PKG_SYSCONFDIR}/mydns.conf if you want). MyDNS can give the
|
||||
commands to generate these tables:
|
||||
|
||||
${LOCALBASE}/sbin/mydns --create-tables
|
||||
|
||||
You can pipe the output right into the psql(1) client.
|
||||
===========================================================================
|
13
mydns-pgsql/Makefile
Normal file
13
mydns-pgsql/Makefile
Normal file
|
@ -0,0 +1,13 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2005/09/09 12:38:12 ghen Exp $
|
||||
|
||||
PKGNAME= ${DISTNAME:S/-/-pgsql-/}
|
||||
COMMENT= PostgreSQL-based DNS server
|
||||
|
||||
CONFLICTS= mydns-mysql-[0-9]*
|
||||
|
||||
CONFIGURE_ARGS+= --without-mysql
|
||||
CONFIGURE_ARGS+= --with-pgsql-lib=${PREFIX}/lib
|
||||
CONFIGURE_ARGS+= --with-pgsql-include=${PREFIX}/include
|
||||
|
||||
.include "../../mk/pgsql.buildlink3.mk"
|
||||
.include "Makefile.common"
|
39
mydns-pgsql/Makefile.common
Normal file
39
mydns-pgsql/Makefile.common
Normal file
|
@ -0,0 +1,39 @@
|
|||
# $NetBSD: Makefile.common,v 1.1.1.1 2005/09/09 12:38:12 ghen Exp $
|
||||
|
||||
DISTNAME= mydns-1.0.0
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://mydns.bboy.net/download/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= geert.hendrickx@ua.ac.be
|
||||
HOMEPAGE= http://mydns.bboy.net/
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_PKGLOCALEDIR= YES
|
||||
USE_PKGINSTALL= YES
|
||||
|
||||
CONFIGURE_ARGS+= --with-confdir=${PKG_SYSCONFDIR}
|
||||
|
||||
MYDNS_USER?= mydns
|
||||
MYDNS_GROUP?= mydns
|
||||
MYDNS_PERMS= ${ROOT_USER} ${ROOT_GROUP} 600
|
||||
|
||||
SUBST_CLASSES+= user
|
||||
SUBST_STAGE.user= pre-build
|
||||
SUBST_FILES.user= src/mydns/conf.c
|
||||
SUBST_SED.user= -e 's/%%MYDNS_USER%%/${MYDNS_USER}/'
|
||||
SUBST_SED.user+= -e 's/%%MYDNS_GROUP%%/${MYDNS_GROUP}/'
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/${PKGBASE}
|
||||
CONF_FILES_PERMS= ${EGDIR}/mydns.conf ${PKG_SYSCONFDIR}/mydns.conf ${MYDNS_PERMS}
|
||||
RCD_SCRIPTS= mydns
|
||||
|
||||
PKG_GROUPS= ${MYDNS_GROUP}
|
||||
PKG_USERS= ${MYDNS_USER}:${MYDNS_GROUP}::MyDNS\ user
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${EGDIR}
|
||||
${WRKSRC}/src/mydns/mydns --dump-config > ${EGDIR}/mydns.conf
|
||||
${CHMOD} 0600 ${EGDIR}/mydns.conf
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
21
mydns-pgsql/PLIST
Normal file
21
mydns-pgsql/PLIST
Normal file
|
@ -0,0 +1,21 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2005/09/09 12:38:12 ghen Exp $
|
||||
bin/mydns-conf
|
||||
bin/mydnscheck
|
||||
bin/mydnsexport
|
||||
bin/mydnsimport
|
||||
bin/mydnsptrconvert
|
||||
info/mydns.info
|
||||
man/man5/mydns.conf.5
|
||||
man/man8/mydns-conf.8
|
||||
man/man8/mydns.8
|
||||
man/man8/mydnscheck.8
|
||||
man/man8/mydnsexport.8
|
||||
man/man8/mydnsimport.8
|
||||
man/man8/mydnsptrconvert.8
|
||||
sbin/mydns
|
||||
share/examples/mydns-pgsql/mydns.conf
|
||||
share/examples/rc.d/mydns
|
||||
${PKGLOCALEDIR}/locale/es/LC_MESSAGES/mydns.mo
|
||||
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/mydns.mo
|
||||
${PKGLOCALEDIR}/locale/pt_BR/LC_MESSAGES/mydns.mo
|
||||
@dirrm share/examples/mydns-pgsql
|
6
mydns-pgsql/distinfo
Normal file
6
mydns-pgsql/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2005/09/09 12:38:12 ghen Exp $
|
||||
|
||||
SHA1 (mydns-1.0.0.tar.bz2) = 6a19977f8c6411ed142a5cc635c1cd53e0afc69c
|
||||
RMD160 (mydns-1.0.0.tar.bz2) = a83d790faf3e1a90fcae70e8f1900432ed5e15cf
|
||||
Size (mydns-1.0.0.tar.bz2) = 545441 bytes
|
||||
SHA1 (patch-aa) = 76fc8010ef86169460735ec7012a7885b8d76924
|
27
mydns-pgsql/files/mydns.sh
Normal file
27
mydns-pgsql/files/mydns.sh
Normal file
|
@ -0,0 +1,27 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# $NetBSD: mydns.sh,v 1.1.1.1 2005/09/09 12:38:12 ghen Exp $
|
||||
#
|
||||
# PROVIDE: mydns
|
||||
# REQUIRE: SERVERS
|
||||
# BEFORE: DAEMON
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
. /etc/rc.subr
|
||||
fi
|
||||
|
||||
name="mydns"
|
||||
rcvar=$name
|
||||
command="@PREFIX@/sbin/mydns"
|
||||
command_args="-b"
|
||||
required_files="@PKG_SYSCONFDIR@/mydns.conf"
|
||||
extra_commands="reload"
|
||||
reload_sig="HUP"
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
||||
else
|
||||
@ECHO@ -n " ${name}$"
|
||||
${command} ${command_args} ${mydns_flags}
|
||||
fi
|
15
mydns-pgsql/patches/patch-aa
Normal file
15
mydns-pgsql/patches/patch-aa
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2005/09/09 12:38:12 ghen Exp $
|
||||
|
||||
--- src/mydns/conf.c.orig 2005-01-14 15:23:41.000000000 +0100
|
||||
+++ src/mydns/conf.c
|
||||
@@ -62,8 +62,8 @@ static CONF defConfig[] = {
|
||||
|
||||
{ "-", NULL, N_("GENERAL OPTIONS")},
|
||||
|
||||
-{ "user", "nobody", N_("Run with the permissions of this user")},
|
||||
-{ "group", "nobody", N_("Run with the permissions of this group")},
|
||||
+{ "user", "%%MYDNS_USER%%", N_("Run with the permissions of this user")},
|
||||
+{ "group", "%%MYDNS_GROUP%%", N_("Run with the permissions of this group")},
|
||||
{ "listen", "*", N_("Listen on these addresses ('*' for all)"), "bind"},
|
||||
{ "no-listen", "", N_("Do not listen on these addresses")},
|
||||
|
Loading…
Reference in a new issue