Have a working system.mk that doesn't contain references to

${BUILDLINK_X11_DIR}. Avoid -g option in ion-dock.
This commit is contained in:
Quentin Garnier 2003-04-09 17:52:52 +00:00
parent 4bed3fd1bf
commit 074e589235
6 changed files with 24 additions and 17 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/04/03 09:27:17 cubidou Exp $
# $NetBSD: Makefile,v 1.2 2003/04/09 17:52:52 cubidou Exp $
#
DISTNAME= ion-devel-20030327
@ -15,6 +15,8 @@ USE_PKGINSTALL= YES
USE_X11= YES
USE_GMAKE= YES
MAKE_ENV+= X11_PREFIX=${BUILDLINK_X11_DIR}
PKG_SYSCONFSUBDIR= ion
EGDIR= ${PREFIX}/share/examples/ion
EGFILES= common-frame-bindings.conf draw.conf \
@ -29,4 +31,9 @@ CONF_FILES+= ${EGDIR}/$f ${PKG_SYSCONFDIR}/$f
.endfor
.undef f
post-patch:
${SED} -e s,@@PREFIX@@,${PREFIX}, -e s,@@X11BASE@@,${X11BASE}, \
${WRKSRC}/system.mk > ${WRKSRC}/system.mk.tmp
${MV} ${WRKSRC}/system.mk.tmp ${WRKSRC}/system.mk
.include "../../mk/bsd.pkg.mk"

View file

@ -1,6 +1,3 @@
I'm not entirely satisfied with the fact that the package
installs a system.mk file that references buildlink dir.
That's fine when plugins are installed from pkgsrc, but
not for plugins that are not built from pkgsrc. The
reference should be set to $(X11BASE) (and hard wired in
the installed system.mk file).
New version out. This one will need more work, since now
it depends on lua-devel, which I have to package as
well.

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.1.1.1 2003/04/03 09:27:17 cubidou Exp $
$NetBSD: distinfo,v 1.2 2003/04/09 17:52:52 cubidou Exp $
SHA1 (ion-devel-20030327.tar.gz) = 554e33afc119da2158200aa4080903d831f25e16
Size (ion-devel-20030327.tar.gz) = 203669 bytes
SHA1 (patch-aa) = d5335fc6f80a3545049ffdf3dab7e469c487b72b
SHA1 (patch-aa) = bd98bb655bd1d256e63b37c772a10ad090b2b86d
SHA1 (patch-ab) = b63395c877957621d76f57fa42e710241d5903c0
SHA1 (patch-ac) = c65657e7e407e037b42952d33463044036e21f5a
SHA1 (patch-ad) = a33954ec0e560884fe71f5aae7ac0753c9ac149e

View file

@ -1,4 +1,4 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/04/03 09:27:17 cubidou Exp $
$NetBSD: patch-aa,v 1.2 2003/04/09 17:52:53 cubidou Exp $
--- system.mk.orig 2003-03-17 19:49:26.000000000 +0100
+++ system.mk
@ -7,7 +7,7 @@ $NetBSD: patch-aa,v 1.1.1.1 2003/04/03 09:27:17 cubidou Exp $
##
-PREFIX=/usr/local/ion-devel
+#PREFIX=/usr/local/ion-devel
+PREFIX?=@@PREFIX@@
# No need to modify these usually
BINDIR=$(PREFIX)/bin
@ -33,7 +33,7 @@ $NetBSD: patch-aa,v 1.1.1.1 2003/04/03 09:27:17 cubidou Exp $
##
-X11_PREFIX=/usr/X11R6
+X11_PREFIX=$(BUILDLINK_X11_DIR)
+X11_PREFIX?=@@X11BASE@@
# SunOS/Solaris
#X11_PREFIX=/usr/openwin

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2003/04/03 09:29:50 cubidou Exp $
$NetBSD: distinfo,v 1.2 2003/04/09 17:52:54 cubidou Exp $
SHA1 (ion-dock-20030330.tar.gz) = cbb08571988271e10f4838e19e1f52a4dce6a713
Size (ion-dock-20030330.tar.gz) = 7790 bytes
SHA1 (patch-aa) = 6619d2fd6d6594f12917e4a080a445cb4cf38b8a
SHA1 (patch-aa) = 11f5b7cc15ce20602abc7437dc9d776469c96f49

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/04/03 09:29:50 cubidou Exp $
$NetBSD: patch-aa,v 1.2 2003/04/09 17:52:54 cubidou Exp $
--- Makefile.orig 2003-03-27 00:09:51.000000000 +0100
+++ Makefile
@@ -5,13 +5,13 @@
@@ -5,15 +5,15 @@
# Set this to your Ion source directory.
# If you're using the Debian package, just apt-get install ion-devel-dev
# instead.
@ -17,8 +17,11 @@ $NetBSD: patch-aa,v 1.1.1.1 2003/04/03 09:29:50 cubidou Exp $
+MODULEDIR := $(LIBDIR)/ion
+IONETCDIR := $(EXDIR)/ion
CFLAGS := -g -O2 -fPIC $(WARN) $(DEFINES) $(INCLUDES) $(X11_INCLUDES) \
-CFLAGS := -g -O2 -fPIC $(WARN) $(DEFINES) $(INCLUDES) $(X11_INCLUDES) \
+CFLAGS += -fPIC $(WARN) $(DEFINES) $(INCLUDES) $(X11_INCLUDES) \
$(EXTRA_INCLUDES) -I$(ION_DIR) -I$(ION_DIR)/libtu/include
ifeq ($(ION_DEBIAN_PACKAGE),1)
@@ -27,15 +27,8 @@ CONFFILE = dock.conf
all: $(MODULE).so