This is NSD Name Server Daemon (NSD).

NSD is a complete implementation of an authoritative DNS nameserver.
For further information about what NSD is and what NSD is not please
consult the REQUIREMENTS document which is a part of this distribution
(thanks to Olaf).

This is the SVN trunk version of NSD version 4
This commit is contained in:
Fredrik Pettai 2012-10-14 11:13:06 +00:00 committed by Thomas Klausner
parent 4a8493b8fd
commit 07ecf10cbb
7 changed files with 155 additions and 0 deletions

8
nsd4-svn/DESCR Normal file
View file

@ -0,0 +1,8 @@
This is NSD Name Server Daemon (NSD).
NSD is a complete implementation of an authoritative DNS nameserver.
For further information about what NSD is and what NSD is not please
consult the REQUIREMENTS document which is a part of this distribution
(thanks to Olaf).
This is the SVN trunk version of NSD version 4

82
nsd4-svn/Makefile Normal file
View file

@ -0,0 +1,82 @@
# $NetBSD: Makefile,v 1.1 2012/10/14 11:13:06 pettai Exp $
#
DISTNAME= nsd4-${VERSION}
CATEGORIES= net security
MASTER_SITES= # not defined
MAINTAINER= pettai@NetBSD.org
HOMEPAGE= http://www.nlnetlabs.nl/projects/nsd/
COMMENT= Name Server Daemon 4 (trunk)
LICENSE= modified-bsd
PKG_DESTDIR_SUPPORT= user-destdir
BUILDLINK_API_DEPENDS.openssl+= openssl>=0.9.7
PKG_OPTIONS_VAR= PKG_OPTIONS.nsd
PKG_SUPPORTED_OPTIONS= inet6
PKG_SUGGESTED_OPTIONS= inet6
.include "../../mk/bsd.options.mk"
USE_TOOLS+= aclocal autoconf automake autoheader gmake gm4 autoreconf
#USE_LIBTOOL= yes
SVN_REPOSITORIES= nsd
SVN_ROOT.nsd= http://www.nlnetlabs.nl/svn/nsd/trunk/
SVN_MODULE.nsd= NSD4
VERSION= 4.0a
NO_CHECKSUM= yes
PKG_DESTDIR_SUPPORT= user-destdir
BUILD_DEFS+= VARBASE
USE_LANGUAGES= c c++
USE_LIBTOOL= yes
WRKSRC= ${WRKDIR}/NSD4
PKG_SYSCONFSUBDIR= nsd
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--prefix=${PREFIX:Q}
CONFIGURE_ARGS+=--enable-bind8-stats
.if !empty(PKG_OPTIONS:Minet6)
CONFIGURE_ARGS+=--enable-ipv6
.else
CONFIGURE_ARGS+=--disable-ipv6
.endif
CONFIGURE_ARGS+=--localstatedir=${VARBASE}
CONFIGURE_ARGS+=--with-pidfile=${VARBASE}/run/nsd.pid
CONFIGURE_ARGS+=--with-user=${NSD_USER}
CONFIGURE_ARGS+=--with-dbfile=${VARBASE}/nsd/nsd.db
CONFIGURE_ARGS+=--with-difffile=${VARBASE}/nsd/nsd-ixfr.db
CONFIGURE_ARGS+=--with-xfrdfile=${VARBASE}/nsd/nsd-xfrd.state
CONFIGURE_ARGS+=--with-ssl=${BUILDLINK_PREFIX.openssl}
RCD_SCRIPTS= nsd
NSD_USER?= nsd
NSD_GROUP?= nsd
PKG_GROUPS= ${NSD_GROUP}
PKG_USERS= ${NSD_USER}:${NSD_GROUP}
CONF_FILES+= share/examples/nsd/nsd.conf ${PKG_SYSCONFDIR}/nsd.conf
INSTALLATION_DIRS= share/examples/nsd
INSTALLATION_DIRS+= ${VARBASE}/nsd
pre-configure:
cd ${WRKSRC} && autoreconf -i
post-install:
${INSTALL_DATA} ${WRKSRC}/contrib/nsd.zones2nsd.conf \
${DESTDIR}${PREFIX}/share/examples/nsd
.include "../../security/openssl/buildlink3.mk"
.include "../../wip/mk/svn-package.mk"
.include "../../mk/bsd.pkg.mk"

13
nsd4-svn/PLIST Normal file
View file

@ -0,0 +1,13 @@
@comment $NetBSD: PLIST,v 1.1 2012/10/14 11:13:06 pettai Exp $
man/man5/nsd.conf.5
man/man8/nsd-checkconf.8
man/man8/nsd-control.8
man/man8/nsd.8
sbin/nsd
sbin/nsd-checkconf
sbin/nsd-control
sbin/nsd-control-setup
share/examples/nsd/nsd.conf
share/examples/nsd/nsd.zones2nsd.conf
share/examples/rc.d/nsd
@pkgdir etc/nsd

4
nsd4-svn/distinfo Normal file
View file

@ -0,0 +1,4 @@
$NetBSD: distinfo,v 1.1 2012/10/14 11:13:06 pettai Exp $
SHA1 (patch-aa) = d49649f79ff8e8dc8b0bed7287c9f473ae189814
SHA1 (patch-util.c) = acaf676e675fc07ef51b4c1cc056214731bc193f

20
nsd4-svn/files/nsd.sh Normal file
View file

@ -0,0 +1,20 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: nsd.sh,v 1.1 2012/10/14 11:13:06 pettai Exp $
#
# PROVIDE: nsd
# REQUIRE: DAEMON
#
. /etc/rc.subr
name="nsd"
rcvar=${name}
command=@PREFIX@/sbin/${name}
pidfile=/var/run/${name}.pid
nsd_flags=${nsd_flags:-""}
load_rc_config ${name}
run_rc_command "$1"

13
nsd4-svn/patches/patch-aa Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1 2012/10/14 11:13:06 pettai Exp $
--- Makefile.in.orig 2012-10-14 10:22:12.000000000 +0000
+++ Makefile.in
@@ -125,7 +125,7 @@ install: all
$(INSTALL_DATA) $(srcdir)/nsd-checkconf.8 $(DESTDIR)$(mandir)/man8/nsd-checkconf.8
$(INSTALL_DATA) $(srcdir)/nsd-control.8 $(DESTDIR)$(mandir)/man8/nsd-control.8
$(INSTALL_DATA) $(srcdir)/nsd.conf.5 $(DESTDIR)$(mandir)/man5/nsd.conf.5
- $(INSTALL_DATA) nsd.conf.sample $(DESTDIR)$(nsdconfigfile).sample
+ $(INSTALL_DATA) nsd.conf.sample $(DESTDIR)${PREFIX}/share/examples/nsd/nsd.conf
uninstall:
@echo

View file

@ -0,0 +1,15 @@
$NetBSD: patch-util.c,v 1.1 2012/10/14 11:13:06 pettai Exp $
* Use u_int32_t instead of obsolete u_long.
--- util.c.orig 2011-03-22 13:13:32.000000000 +0000
+++ util.c
@@ -742,7 +742,7 @@ mktime_from_utc(const struct tm *tm)
http://www.tsfr.org/~orc/Code/bsd/bsd-current/cksum/crc.c.
or http://gobsd.com/code/freebsd/usr.bin/cksum/crc.c
The polynomial is 0x04c11db7L. */
-static u_long crctab[] = {
+static const u_int32_t crctab[] = {
0x0,
0x04c11db7, 0x09823b6e, 0x0d4326d9, 0x130476dc, 0x17c56b6b,
0x1a864db2, 0x1e475005, 0x2608edb8, 0x22c9f00f, 0x2f8ad6d6,