Add some more includes to make the cpu and memory modules build

on netbsd-7.  Bump PKGREVISION.
This commit is contained in:
Havard Eidnes 2015-09-16 12:56:59 +00:00 committed by Thomas Klausner
parent 3448094a29
commit 08a3acc4b3
4 changed files with 39 additions and 3 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.6 2015/08/26 13:45:38 heidnes Exp $
# $NetBSD: Makefile.common,v 1.7 2015/09/16 12:56:59 heidnes Exp $
# used by wip/zabbix-server/Makefile
# used by wip/zabbix-agent/Makefile
# used by wip/zabbix-server-pgsql/Makefile
@ -6,7 +6,7 @@
VER= 2.4.4
DISTNAME= zabbix-${VER}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=zabbix/}

View file

@ -1,9 +1,11 @@
$NetBSD: distinfo,v 1.11 2015/08/20 11:45:27 heidnes Exp $
$NetBSD: distinfo,v 1.12 2015/09/16 12:56:59 heidnes Exp $
SHA1 (zabbix-2.4.4.tar.gz) = 505b274fe17d83bd5099cf71cd3d38a4d3d8d88b
RMD160 (zabbix-2.4.4.tar.gz) = 27b92992a008f3cd37dd264d46c2f1ed3392f2fe
Size (zabbix-2.4.4.tar.gz) = 14844586 bytes
SHA1 (patch-src_libs_zbxsysinfo_netbsd_cpu.c) = 38353bc15b528259a3b2c0ce2ae52fcacb00bf9d
SHA1 (patch-src_libs_zbxsysinfo_netbsd_diskspace.c) = 186cdcb367e68b1c9f5250ac2b94c75b8731da40
SHA1 (patch-src_libs_zbxsysinfo_netbsd_memory.c) = 466c2d17a49fd0cc37dd5bc905485d2856beb160
SHA1 (patch-src_zabbix__agent_Makefile.in) = 8b366776f72e189234cebbb4e9c4cba62750790b
SHA1 (patch-src_zabbix__agent_zabbix__agentd.c) = 959bc02cd67167001c11ba532be1e4f0971144b8
SHA1 (patch-src_zabbix__proxy_Makefile.in) = 7b3fe51b7f21656c1453de5f948568e6d0d0d3d8

View file

@ -0,0 +1,17 @@
$NetBSD: patch-src_libs_zbxsysinfo_netbsd_cpu.c,v 1.1 2015/09/16 12:56:59 heidnes Exp $
Add some more includes to make this build on netbsd-7.
--- src/libs/zbxsysinfo/netbsd/cpu.c.orig 2015-02-23 12:28:14.000000000 +0000
+++ src/libs/zbxsysinfo/netbsd/cpu.c
@@ -24,6 +24,10 @@
#include "zbxalgo.h"
#include "zbxjson.h"
+#include <sys/types.h>
+#include <sys/sysctl.h>
+#include <uvm/uvm_extern.h>
+
static int get_cpu_num()
{
#ifdef HAVE_FUNCTION_SYSCTL_HW_NCPU /* NetBSD 3.1 i386; NetBSD 4.0 i386 */

View file

@ -0,0 +1,17 @@
$NetBSD: patch-src_libs_zbxsysinfo_netbsd_memory.c,v 1.1 2015/09/16 12:56:59 heidnes Exp $
Add some more includes to make this build on netbsd-7.
--- src/libs/zbxsysinfo/netbsd/memory.c.orig 2015-02-23 12:28:14.000000000 +0000
+++ src/libs/zbxsysinfo/netbsd/memory.c
@@ -21,6 +21,10 @@
#include "sysinfo.h"
#include "log.h"
+#include <sys/types.h>
+#include <sys/sysctl.h>
+#include <uvm/uvm_extern.h>
+
static int mib[] = {CTL_VM, VM_UVMEXP2};
static size_t len;
static struct uvmexp_sysctl uvm;