An open source implementation of the Sender ID specification as defined by the
Internet Engineering Task Force's (IETF). The Sender ID proposal includes three different specifications: draft-ietf-marid-core-03 draft-ietf-marid-protocol-02 draft-ietf-marid-submitter-03 sid-milter implements the -core and -protocol specifications. -submitter requires an optional SMTP extension that would be implemented in the sendmail MTA. This implementation is part of the Sendmail Messaging Integrity program, a comprehensive testing initiative designed to gather real-world usage data by evaluating several aspects of various leading sender authentication schemes against a wide range of SMTP software operating today. This software is being provided to the open source community for the purposes of testing the DomainKeys approach against various implementations of mail transport agents, mail list managers, forwarding services, and various other SMTP software. THIS IS PRE-RELEASE SOFTWARE, and should not be used in any critical production environments.
This commit is contained in:
parent
8a584dd051
commit
08eea2465a
7 changed files with 139 additions and 0 deletions
24
sid-milter/DESCR
Normal file
24
sid-milter/DESCR
Normal file
|
@ -0,0 +1,24 @@
|
|||
An open source implementation of the Sender ID specification as defined by the
|
||||
Internet Engineering Task Force's (IETF).
|
||||
|
||||
The Sender ID proposal includes three different specifications:
|
||||
draft-ietf-marid-core-03
|
||||
draft-ietf-marid-protocol-02
|
||||
draft-ietf-marid-submitter-03
|
||||
|
||||
sid-milter implements the -core and -protocol specifications. -submitter
|
||||
requires an optional SMTP extension that would be implemented in the sendmail
|
||||
MTA.
|
||||
|
||||
This implementation is part of the Sendmail Messaging Integrity program, a
|
||||
comprehensive testing initiative designed to gather real-world usage data by
|
||||
evaluating several aspects of various leading sender authentication schemes
|
||||
against a wide range of SMTP software operating today.
|
||||
|
||||
This software is being provided to the open source community for the purposes
|
||||
of testing the DomainKeys approach against various implementations of mail
|
||||
transport agents, mail list managers, forwarding services, and various other
|
||||
SMTP software.
|
||||
|
||||
THIS IS PRE-RELEASE SOFTWARE, and should not be used in any critical
|
||||
production environments.
|
20
sid-milter/MESSAGE
Normal file
20
sid-milter/MESSAGE
Normal file
|
@ -0,0 +1,20 @@
|
|||
===========================================================================
|
||||
$NetBSD: MESSAGE,v 1.1.1.1 2004/09/01 10:35:53 adrian_p Exp $
|
||||
|
||||
sid-milter is now installed.
|
||||
The documentation can be found at ${PREFIX}/share/doc/sid-milter/
|
||||
|
||||
Please read the instructions in ${PREFIX}/share/doc/sid-milter/INSTALL
|
||||
for setting up sid-milter.
|
||||
|
||||
At a minmium you will need to specify:
|
||||
|
||||
sidmilter_flags="-p socketfile -d domain"
|
||||
|
||||
in your /etc/rc.conf.
|
||||
|
||||
For security you may also wish to investigate the use of "-u userid".
|
||||
|
||||
THIS IS PRE-RELEASE SOFTWARE, and should not be used in any critical
|
||||
production environments.
|
||||
===========================================================================
|
42
sid-milter/Makefile
Normal file
42
sid-milter/Makefile
Normal file
|
@ -0,0 +1,42 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2004/09/01 10:35:53 adrian_p Exp $
|
||||
|
||||
DISTNAME= sid-milter-0.2.0
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=sid-milter/}
|
||||
|
||||
MAINTAINER= adrianp@NetBSD.org
|
||||
HOMEPAGE= http://www.sendmail.net/sid-milter/
|
||||
COMMENT= Open source implementation of the Sender ID specification
|
||||
|
||||
DEPENDS+= sendmail>=8.13.0:../../mail/sendmail
|
||||
|
||||
LICENSE= no-profit
|
||||
USE_BUILDLINK3= YES
|
||||
PTHREAD_OPTS+= require
|
||||
USE_PKGINSTALL= YES
|
||||
RCD_SCRIPTS= sidmilter
|
||||
|
||||
SIDDOC= ${PREFIX}/share/doc/sid-milter
|
||||
BUILDLINK_DEPENDS.libmilter?= libmilter>=8.13.0
|
||||
|
||||
do-build:
|
||||
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./Build)
|
||||
|
||||
do-install:
|
||||
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./Build \
|
||||
INCLUDEDIR=${PREFIX}/include \
|
||||
LIBDIR=${PREFIX}/lib \
|
||||
MANROOT=${PREFIX}/man/man \
|
||||
UBINDIR=${PREFIX}/bin \
|
||||
install
|
||||
|
||||
${INSTALL_DATA_DIR} ${SIDDOC}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${SIDDOC}
|
||||
${INSTALL_DATA} ${WRKSRC}/README-SenderID ${SIDDOC}
|
||||
${INSTALL_DATA} ${WRKSRC}/INSTALL ${SIDDOC}
|
||||
${INSTALL_DATA} ${WRKSRC}/LICENSE ${SIDDOC}
|
||||
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../mail/libmilter/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
9
sid-milter/PLIST
Normal file
9
sid-milter/PLIST
Normal file
|
@ -0,0 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2004/09/01 10:35:53 adrian_p Exp $
|
||||
bin/sid-filter
|
||||
man/man8/sid-filter.0
|
||||
man/man3/ar.0
|
||||
share/doc/sid-milter/INSTALL
|
||||
share/doc/sid-milter/LICENSE
|
||||
share/doc/sid-milter/README
|
||||
share/doc/sid-milter/README-SenderID
|
||||
@dirrm share/doc/sid-milter
|
5
sid-milter/distinfo
Normal file
5
sid-milter/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2004/09/01 10:35:53 adrian_p Exp $
|
||||
|
||||
SHA1 (sid-milter-0.2.0.tar.gz) = 6921bee382f3ff5f225773aa9034ce90dbbfdfd8
|
||||
Size (sid-milter-0.2.0.tar.gz) = 280488 bytes
|
||||
SHA1 (patch-aa) = 261abb57a4c69feef3791060c3a610dd4271fac1
|
24
sid-milter/files/sidmilter.sh
Executable file
24
sid-milter/files/sidmilter.sh
Executable file
|
@ -0,0 +1,24 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: sidmilter.sh,v 1.1.1.1 2004/09/01 10:35:53 adrian_p Exp $
|
||||
#
|
||||
# PROVIDE: sidfilter
|
||||
# REQUIRE: DAEMON
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
. /etc/rc.subr
|
||||
fi
|
||||
|
||||
name="sidfilter"
|
||||
rcvar=$name
|
||||
command="@PREFIX@/bin/sid-filter"
|
||||
pidfile="/var/run/sid-filter.pid"
|
||||
command_args="-l -P ${pidfile}"
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
||||
else
|
||||
echo -n " ${name}"
|
||||
${command} ${sidfilter_flags} ${command_args}
|
||||
fi
|
15
sid-milter/patches/patch-aa
Normal file
15
sid-milter/patches/patch-aa
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2004/09/01 10:35:53 adrian_p Exp $
|
||||
|
||||
--- sid-filter/Makefile.m4.orig Wed Sep 1 10:00:41 2004
|
||||
+++ sid-filter/Makefile.m4 Wed Sep 1 10:01:01 2004
|
||||
@@ -21,8 +21,8 @@
|
||||
|
||||
|
||||
bldPRODUCT_START(`executable', `sid-filter')
|
||||
-define(`bldSOURCES', `sid-filter.c rfc2822.h util.c ')
|
||||
-PREPENDDEF(`confLIBS', `-lmilter ')
|
||||
+define(`bldSOURCES', `sid-filter.c rfc2822.c util.c ')
|
||||
+PREPENDDEF(`confLIBS', `-lmilter -lpthread $(COMPILER_RPATH_FLAG)${PREFIX}/lib ')
|
||||
bldPRODUCT_END
|
||||
|
||||
bldPRODUCT_START(`manpage', `sid-filter')
|
Loading…
Reference in a new issue