Removed doxygen dependecy for the docs.

Changed installation dir for docs and license.
Removed doc option, docs are now always installed.
Patched so that the installer doesn't install .a files.
Taking maintainership since I imported the package.
Removed usage of wip/qore/Makefiel.common and wip/qore/options.mk.
Added missing PTHREAD_OPTS.
Bumping pkgrevision.
This commit is contained in:
Niclas Rosenvik 2014-02-16 19:38:23 +00:00 committed by Thomas Klausner
parent 47a0a15090
commit 0a6d235d32
6 changed files with 683 additions and 612 deletions

View file

@ -1,30 +1,35 @@
# $NetBSD: Makefile,v 1.2 2014/01/22 22:16:15 nros Exp $
# $NetBSD: Makefile,v 1.3 2014/02/16 19:38:23 nros Exp $
DISTNAME= qore-xml-module-1.2
PKGREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=qore/}
EXTRACT_SUFX= .tar.bz2
.include "../../wip/qore/Makefile.common"
MAINTAINER= pkgsrc-users@NetBSD.org
MAINTAINER= nros@users.sourceforge.net
COMMENT= XML module for Qore
HOMEPAGE= http://www.qore.org/
LICENSE= gnu-lgpl-v2.1 OR mit
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_LANGUAGES= c c++
USE_TOOLS+= gmake
PTHREAD_OPTS+= require
INSTALL_TARGET= install install-html-local
#This is needed in order to comply the with MIT license and binary distribution
INSTALLATION_DIRS+= share/qore-xml-module/license
INSTALLATION_DIRS+= share/qore/license/modules/xml
post-install:
${INSTALL_DATA} ${WRKSRC}/COPYING.LGPL \
${DESTDIR}${PREFIX}/share/qore-xml-module/license
${DESTDIR}${PREFIX}/share/qore/license/modules/xml
${INSTALL_DATA} ${WRKSRC}/COPYING.MIT \
${DESTDIR}${PREFIX}/share/qore-xml-module/license
${DESTDIR}${PREFIX}/share/qore/license/modules/xml
.include "../../wip/qore/plist-version.mk"
.include "../../wip/qore/options.mk"
.include "options.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"

File diff suppressed because it is too large Load diff

View file

@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.1 2014/01/20 19:57:06 nros Exp $
$NetBSD: distinfo,v 1.2 2014/02/16 19:38:23 nros Exp $
SHA1 (qore-xml-module-1.2.tar.bz2) = 4fb5a8f7784f26014e79a6664ea48653b1169f63
RMD160 (qore-xml-module-1.2.tar.bz2) = 9f6eb789726f0ee2fa356529e548d1693e208f61
Size (qore-xml-module-1.2.tar.bz2) = 824832 bytes
SHA1 (patch-Makefile.in) = 6027d962ec362dd239e3a538295c81da4c203e3d
SHA1 (patch-src_Makefile.in) = 4c89a65aca9ded488b42aa0893bd5c4c4a79e052

View file

@ -0,0 +1,12 @@
# $NetBSD: options.mk,v 1.1 2014/02/16 19:38:23 nros Exp $
#
PKG_OPTIONS_VAR= PKG_OPTIONS.qore-xml-module
PKG_SUPPORTED_OPTIONS= debug
.include "../../mk/bsd.options.mk"
.if !empty(PKG_OPTIONS:Mdebug)
CONFIGURE_ARGS+= --enable-debug
.else
CONFIGURE_ARGS+= --disable-debug
.endif

View file

@ -0,0 +1,41 @@
$NetBSD: patch-Makefile.in,v 1.1 2014/02/16 19:38:23 nros Exp $
* Remove doxygen dependecy
* Install the docs under share/qore/docs/modules
--- Makefile.in.orig 2013-10-05 10:23:40.000000000 +0000
+++ Makefile.in
@@ -382,6 +382,7 @@ EXTRA_DIST = COPYING.LGPL COPYING.MIT Ch
qore-xml-module.spec $(am__append_1)
ACLOCAL_AMFLAGS = -I m4
dist_modver_DATA = $(USER_MODULES)
+PKG = xml SoapClient SoapHandler WSDL XmlRpcHandler
@COND_DOXYGEN_TRUE@DOX = xml SoapClient SoapHandler WSDL XmlRpcHandler
@COND_DOXYGEN_TRUE@DOXYGEN_OUTPUT = docs/xml/html docs/XmlRpcHandler/html docs/WSDL/html docs/SoapClient/html docs/SoapHandler/html
@COND_DOXYGEN_TRUE@DOXYFILES = docs/doxyfile docs/mainpage.doxygen
@@ -809,7 +810,7 @@ maintainer-clean-generic:
@echo "it deletes files that may require special tools to rebuild."
@COND_DOXYGEN_FALSE@uninstall-local:
@COND_DOXYGEN_FALSE@html-local:
-@COND_DOXYGEN_FALSE@install-html-local:
+
@COND_DOXYGEN_FALSE@clean-local:
clean: clean-recursive
@@ -963,12 +964,12 @@ uninstall-am: uninstall-dist_modverDATA
@COND_DOXYGEN_TRUE@html-local: $(DOXYGEN_OUTPUT)
-@COND_DOXYGEN_TRUE@install-html-local:
-@COND_DOXYGEN_TRUE@ for dox in $(DOX); do $(MKDIR_P) $(DESTDIR)$(datadir)/$(PACKAGE)/docs/$$dox/html/search; done
-@COND_DOXYGEN_TRUE@ for dir in $(DOXYGEN_OUTPUT); do \
-@COND_DOXYGEN_TRUE@ for f in $$dir/*; do if [ -f $$f ]; then $(INSTALL_DATA) $$f $(DESTDIR)$(datadir)/$(PACKAGE)/$$dir; fi; done; \
-@COND_DOXYGEN_TRUE@ for f in $$dir/search/*; do $(INSTALL_DATA) $$f $(DESTDIR)$(datadir)/$(PACKAGE)/$$dir/search; done; \
-@COND_DOXYGEN_TRUE@ done
+install-html-local:
+ for pkg in $(PKG) ; do $(MKDIR_P) $(DESTDIR)$(datadir)/qore/docs/modules/$$pkg/html/search; done
+ for pkg in $(PKG); do \
+ for f in docs/$$pkg/html/*; do if [ -f $$f ]; then $(INSTALL_DATA) $$f $(DESTDIR)$(datadir)/qore/docs/modules/$$pkg/html; fi; done; \
+ for f in docs/$$pkg/html/search/*; do $(INSTALL_DATA) $$f $(DESTDIR)$(datadir)/qore/docs/modules/$$pkg/html/search; done; \
+ done
@COND_DOXYGEN_TRUE@clean-local:
@COND_DOXYGEN_TRUE@ $(RM) -rf $(DOXYGEN_OUTPUT)

View file

@ -0,0 +1,12 @@
$NetBSD: patch-src_Makefile.in,v 1.1 2014/02/16 19:38:23 nros Exp $
* don't install .a file
--- src/Makefile.in.orig 2013-10-05 10:23:40.000000000 +0000
+++ src/Makefile.in
@@ -346,6 +346,7 @@ AM_CPPFLAGS = $(QORE_CPPFLAGS) ${LIBXML2
@COND_DEBUG_TRUE@@COND_PROFILE_FALSE@AM_CXXFLAGS = -g
@COND_PROFILE_TRUE@AM_CXXFLAGS = -g -pg
@COND_MINGW_TRUE@RM_OTHER = $(DESTDIR)$(libdir)/$(MNAME).dll.a
+@COND_MINGW_FALSE@RM_OTHER = $(DESTDIR)$(libdir)/$(MNAME).a
all: all-am
.SUFFIXES: