Add patch for configure so mcookie can have spaces in it.
(Already in upstream.) Set MCOOKIE same as already on NetBSD. Bump PKGREVISION. On NetBSD before, this startx was broken.
This commit is contained in:
parent
9994faa079
commit
0b118d7f94
3 changed files with 24 additions and 2 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2006/04/28 02:46:19 jeremy-c-reed Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2006/05/27 17:26:53 jeremy-c-reed Exp $
|
||||
#
|
||||
|
||||
DISTNAME= xinit-1.0.2
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://xorg.freedesktop.org/releases/individual/app/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -13,6 +14,11 @@ COMMENT= Utilities for starting the X Window System server
|
|||
GNU_CONFIGURE= yes
|
||||
USE_TOOLS+= pkg-config
|
||||
|
||||
# on Linux, it could use mcookie from util-linux
|
||||
# some openssl doesn't have that -hex
|
||||
#CONFIGURE_ENV+= MCOOKIE="/usr/bin/openssl rand -hex 16"
|
||||
CONFIGURE_ENV+= MCOOKIE="/bin/dd if=/dev/urandom bs=16 count=1 2>/dev/null | hexdump -e '\\\"%08x\\\"'"
|
||||
|
||||
.include "../../wip/libX11/buildlink3.mk"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2006/04/28 02:46:19 jeremy-c-reed Exp $
|
||||
$NetBSD: distinfo,v 1.2 2006/05/27 17:26:53 jeremy-c-reed Exp $
|
||||
|
||||
SHA1 (xinit-1.0.2.tar.bz2) = 78a2fefebbe75a65682373fa22721c8789f55580
|
||||
RMD160 (xinit-1.0.2.tar.bz2) = b3ced92e7ffb1afc3880799ed18f584e7f58d048
|
||||
Size (xinit-1.0.2.tar.bz2) = 96536 bytes
|
||||
SHA1 (patch-aa) = 9edd8019449265c33ce1a638ebf6d27490a8a2ca
|
||||
|
|
15
xinit/patches/patch-aa
Normal file
15
xinit/patches/patch-aa
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-aa,v 1.1 2006/05/27 17:26:52 jeremy-c-reed Exp $
|
||||
|
||||
--- configure.orig 2006-04-01 17:06:58.000000000 -0800
|
||||
+++ configure 2006-05-27 09:27:36.000000000 -0700
|
||||
@@ -4650,8 +4650,8 @@
|
||||
done
|
||||
test -n "$MCOOKIE" || MCOOKIE="$MCOOKIE"
|
||||
|
||||
-if test x$MCOOKIE != x ; then
|
||||
- STARTX_COOKIE_FLAGS='-DHAS_COOKIE_MAKER -DMK_COOKIE=$(MCOOKIE)'
|
||||
+if test "x$MCOOKIE" != x ; then
|
||||
+ STARTX_COOKIE_FLAGS='-DHAS_COOKIE_MAKER -DMK_COOKIE="$(MCOOKIE)"'
|
||||
fi
|
||||
|
||||
|
Loading…
Reference in a new issue