Initial import of smw-1.8beta2:

Super Mario War is a Super Mario multiplayer game.  The goal is to
stomp as many other Marios as possible to win the game.  It's a
tribute to Nintendo and the game Mario War by Samuele Poletto.

The game uses artwork and sounds from Nintendo games. We hope that
this noncommercial fangame qualifies as fair use work. We just
wanted to create this game to show how much we adore Nintendo's
characters and games.

Package is unfinished due to compilation errors:
_src/gamemodes.cpp: In member function 'virtual void CGM_ShyGuyTag::think()':
_src/gamemodes.cpp:1259: warning: unused variable 'playwarning'
_src/player.h:500: warning: 'MO_SuperFireball' is already a friend of 'CPlayer'
_src/ai.cpp: In member function 'virtual void CPlayerAI::Think(COutputControl*)':
_src/ai.cpp:348: error: no match for 'operator=' in 'itr = ((CPlayerAI*)this)->CPlayerAI::attentionObjects.std::map<_Key, _Tp, _Compare, _Alloc>::erase [with _Key = int, _Tp = AttentionObject*, _Compare = std::less<int>, _Alloc = std::allocator<std::pair<const int, AttentionObject*> >](itr)'
/usr/include/g++/bits/stl_tree.h:152: note: candidates are: std::_Rb_tree_iterator<std::pair<const int, AttentionObject*> >& std::_Rb_tree_iterator<std::pair<const int, AttentionObject*> >::operator=(const std::_Rb_tree_iterator<std::pair<const int, AttentionObject*> >&)
gmake: *** [build/ai.o] Error 1
This commit is contained in:
Thomas Klausner 2010-05-01 19:49:25 +00:00
parent 8e2f8ddffb
commit 0ba4509d35
6 changed files with 61 additions and 0 deletions

8
smw/DESCR Normal file
View file

@ -0,0 +1,8 @@
Super Mario War is a Super Mario multiplayer game. The goal is to
stomp as many other Marios as possible to win the game. It's a
tribute to Nintendo and the game Mario War by Samuele Poletto.
The game uses artwork and sounds from Nintendo games. We hope that
this noncommercial fangame qualifies as fair use work. We just
wanted to create this game to show how much we adore Nintendo's
characters and games.

25
smw/Makefile Normal file
View file

@ -0,0 +1,25 @@
# $NetBSD: Makefile,v 1.1.1.1 2010/05/01 19:49:25 thomasklausner Exp $
#
DISTNAME= smw-1.8-beta2-src
PKGNAME= smw-1.8beta2
PKGREVISION= 1
CATEGORIES= games
MASTER_SITES= http://smw.supersanctuary.net/18Beta2/
EXTRACT_SUFX= .zip
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://72dpiarmy.supersanctuary.net/viewforum.php?f=1
COMMENT= Super Mario War - stomp the Marios
#LICENSE= # TODO: (see mk/license.mk)
PKG_DESTDIR_SUPPORT= user-destdir
HAS_CONFIGURE= yes
USE_LANGUAGES= c c++
USE_TOOLS+= gmake
.include "../../audio/SDL_mixer/buildlink3.mk"
.include "../../devel/SDL/buildlink3.mk"
.include "../../graphics/SDL_image/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

1
smw/PLIST Normal file
View file

@ -0,0 +1 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2010/05/01 19:49:25 thomasklausner Exp $

8
smw/TODO Normal file
View file

@ -0,0 +1,8 @@
Fails to build on NetBSD-5.99.27/amd64 with:
_src/gamemodes.cpp: In member function 'virtual void CGM_ShyGuyTag::think()':
_src/gamemodes.cpp:1259: warning: unused variable 'playwarning'
_src/player.h:500: warning: 'MO_SuperFireball' is already a friend of 'CPlayer'
_src/ai.cpp: In member function 'virtual void CPlayerAI::Think(COutputControl*)':
_src/ai.cpp:348: error: no match for 'operator=' in 'itr = ((CPlayerAI*)this)->CPlayerAI::attentionObjects.std::map<_Key, _Tp, _Compare, _Alloc>::erase [with _Key = int, _Tp = AttentionObject*, _Compare = std::less<int>, _Alloc = std::allocator<std::pair<const int, AttentionObject*> >](itr)'
/usr/include/g++/bits/stl_tree.h:152: note: candidates are: std::_Rb_tree_iterator<std::pair<const int, AttentionObject*> >& std::_Rb_tree_iterator<std::pair<const int, AttentionObject*> >::operator=(const std::_Rb_tree_iterator<std::pair<const int, AttentionObject*> >&)
gmake: *** [build/ai.o] Error 1

6
smw/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2010/05/01 19:49:25 thomasklausner Exp $
SHA1 (smw-1.8-beta2-src.zip) = a0f836505c08c324c7184a0acc94fa43e8a7b0b0
RMD160 (smw-1.8-beta2-src.zip) = 4b50737b8c0b1b6bec6dbbb66cc1b0cbca34ce8c
Size (smw-1.8-beta2-src.zip) = 14973633 bytes
SHA1 (patch-aa) = d1f1376b333305bbb57bcec54ad01cac650a7bda

13
smw/patches/patch-aa Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2010/05/01 19:49:25 thomasklausner Exp $
--- configure.orig 2008-10-13 14:03:00.000000000 +0000
+++ configure
@@ -47,7 +47,7 @@ echo 'COMMON_OBJS:=$(COMMON_OBJS) build/
fi
# Linux configuration
-if [ "`uname`" = Linux ]
+if [ "`uname`" = Linux -o "`uname`" = NetBSD ]
then
echo 'CFLAGS:=$(CFLAGS) -DLINUXFUNC -DPREFIXPATH=\"/usr/share/games/smw\" '`sdl-config --cflags` $CFLAGS >> configuration
echo 'LDFLAGS:=$(LDFLAGS) '`sdl-config --libs` $LDFLAGS -lSDL_image -lSDL_mixer -lpng >> configuration