Initial import of xscribble-fs into the NetBSD Package Collection. It is almost

identical to x11/xscribble, with the exception that you can draw anywhere on
the screen.

Xscribble is an X application that allows a user of a touch screen
to input characters into X applications, using a uni-stroke (graffiti
like) alphabet. It uses the X test extension to allow synthesis of
characters as though they had been typed on a keyboard. It is the
X version of the scribble program.

As this program is "familiar" to Palm users, even if other, better
recognizers become available, it is important that we have a good
implementation of this recognition system..
This commit is contained in:
Quentin Garnier 2003-12-01 10:40:02 +00:00 committed by Thomas Klausner
parent 6932fbce4f
commit 0c3759b406
9 changed files with 114 additions and 0 deletions

9
xscribble-fs/DESCR Normal file
View file

@ -0,0 +1,9 @@
Xscribble is an X application that allows a user of a touch screen
to input characters into X applications, using a uni-stroke (graffiti
like) alphabet. It uses the X test extension to allow synthesis of
characters as though they had been typed on a keyboard. It is the
X version of the scribble program.
As this program is "familiar" to Palm users, even if other, better
recognizers become available, it is important that we have a good
implementation of this recognition system..

7
xscribble-fs/MESSAGE Normal file
View file

@ -0,0 +1,7 @@
===========================================================================
$NetBSD: MESSAGE,v 1.1.1.1 2003/12/01 10:40:03 cubidou Exp $
To actually use xscribble, you need to copy
${PREFIX}/share/examples/xscribble/*.cl into ~/.classifiers.
===========================================================================

22
xscribble-fs/Makefile Normal file
View file

@ -0,0 +1,22 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/12/01 10:40:03 cubidou Exp $
DISTNAME= xscribblefs
PKGNAME= xscribble-fs-20001213
CATEGORIES= x11
MASTER_SITES= http://linuxslate.com/files/
MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://linuxslate.com/software.html
COMMENT= Handwriting recognition (like graffiti)
USE_IMAKE= YES
NO_INSTALL_MANPAGES= YES
post-configure:
cd ${WRKSRC} && ${MAKE_PROGRAM} clean
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/xscribble
${INSTALL_DATA} ${WRKSRC}/classifiers/*.cl ${PREFIX}/share/examples/xscribble
.include "../../mk/bsd.pkg.mk"

6
xscribble-fs/PLIST Normal file
View file

@ -0,0 +1,6 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/12/01 10:40:02 cubidou Exp $
bin/xscribble
share/examples/xscribble/digits.cl
share/examples/xscribble/letters.cl
share/examples/xscribble/punc.cl
@dirrm share/examples/xscribble

8
xscribble-fs/distinfo Normal file
View file

@ -0,0 +1,8 @@
$NetBSD: distinfo,v 1.1.1.1 2003/12/01 10:40:02 cubidou Exp $
SHA1 (xscribblefs.tar.gz) = 00ddf2e3e0c476e17bc808f5955e9138d6eba103
Size (xscribblefs.tar.gz) = 279847 bytes
SHA1 (patch-aa) = a9624489e56f0196ed3ac3a6f82d41c7f5a586e3
SHA1 (patch-ab) = 4c234c385851db1237769b55c74ee2c462a6bad1
SHA1 (patch-ac) = 0a6352bf35e79db51b25e195a5bed88661672987
SHA1 (patch-ad) = 9fe0ce4f137975cd380280e13ccfa1543016b5b7

View file

@ -0,0 +1,18 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/12/01 10:40:03 cubidou Exp $
--- lirec/li_recognizer.c.orig Tue Jun 13 07:20:13 2000
+++ lirec/li_recognizer.c Mon Jan 1 22:41:28 2001
@@ -55,5 +55,5 @@
-#define bcopy(s1,s2,n) memcpy(s2,s1,n)
+/*#define bcopy(s1,s2,n) memcpy(s2,s1,n)*/
-#ifdef mips
+#if 0
char *strdup(char* from) {
@@ -925,3 +925,4 @@
/*#include <assert.h>*/
-#include <values.h>
+#include <sys/param.h>
+#define MAXINT INT_MAX
#include <sys/time.h>

View file

@ -0,0 +1,18 @@
$NetBSD: patch-ab,v 1.1.1.1 2003/12/01 10:40:03 cubidou Exp $
--- Imakefile.orig 2000-12-13 16:07:25.000000000 +0100
+++ Imakefile
@@ -12,7 +12,7 @@ LOCAL_LIBRARIES = XkbClientLibs XawClien
strokerecord.o
HEADERS = ScribbleP.h Scribble.h rec-interface.h scribble.h \
strokerecodd.h
- DEFINES = XkbClientDefines
+ DEFINES = XkbClientDefines -Dunix=1
INCLUDES = -Ilirec -Irecman
MakeSubdirs($(SUBDIRS))
@@ -20,3 +20,4 @@ DependSubdirs($(SUBDIRS))
ComplexProgramTarget(xscribble)
+xscribble.man::

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.1.1.1 2003/12/01 10:40:03 cubidou Exp $
*** lirec/util.h- Mon Jan 1 22:47:35 2001
--- lirec/util.h Mon Jan 1 22:48:37 2001
***************
*** 55,57 ****
! #ifndef unix
--- 55,57 ----
! #if 0

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1.1.1 2003/12/01 10:40:03 cubidou Exp $
--- lirec/Imakefile 2001/06/01 11:21:35 1.1
+++ lirec/Imakefile 2001/06/01 11:22:11
@@ -8,6 +8,8 @@
INCLUDES = -I../recman
+DEFINES = XkbClientDefines -Dunix=1
+
#include <Library.tmpl>
DependTarget()