Remove dancer-ircd, I don't want to maintain or update it.

This commit is contained in:
Juan Romero Pardines 2004-04-19 18:19:30 +00:00 committed by Thomas Klausner
parent 3ef9906e12
commit 0c6f6e6d73
9 changed files with 2 additions and 242 deletions

View file

@ -1,5 +1,5 @@
# $Id: Makefile,v 1.1220 2004/04/19 18:15:53 xtraeme Exp $
# $NetBSD: Makefile,v 1.1220 2004/04/19 18:15:53 xtraeme Exp $
# $Id: Makefile,v 1.1221 2004/04/19 18:19:30 xtraeme Exp $
# $NetBSD: Makefile,v 1.1221 2004/04/19 18:19:30 xtraeme Exp $
COMMENT= WIP pkgsrc packages
@ -92,7 +92,6 @@ SUBDIR+= cvsd
SUBDIR+= d2x
SUBDIR+= d4x
SUBDIR+= damageext
SUBDIR+= dancer-ircd
SUBDIR+= dansguardian
SUBDIR+= darcnes-svgalib
SUBDIR+= dasm

View file

@ -1,2 +0,0 @@
This is the ircd designed for use on freenode.net, based on the hybrid
ircd used by efnet.

View file

@ -1,91 +0,0 @@
# $NetBSD: Makefile,v 1.17 2004/01/25 02:11:57 grantbeattie Exp $
#
DISTNAME= dancer-ircd-1.0.31+maint8-fn6
PKGNAME= ${DISTNAME:S/+maint8-fn6/m8/}
CATEGORIES= chat
MASTER_SITES= http://freenode.net/
MAINTAINER= xtraeme@NetBSD.org
HOMEPAGE= http://freenode.net/dancer_ircd.shtml
COMMENT= Irc daemon based on hybrid ircd
USE_BUILDLINK2= YES
GNU_CONFIGURE= YES
USE_GNU_TOOLS+= make
USE_PKGINSTALL= YES
CONFIGURE_ARGS+= --with-config=dist
EGDIR= ${PREFIX}/share/examples/dancer-ircd
DOCDIR= ${PREFIX}/share/doc/dancer-ircd
DANCER_IRCD_USER= dancer_ircd
DANCER_IRCD_GROUP= dancer_ircd
PKG_GROUPS= ${DANCER_IRCD_GROUP}
PKG_USERS= ${DANCER_IRCD_USER}:${DANCER_IRCD_GROUP}::dancer_ircd\\ user
DIRS= /var/lib/dancer-ircd /var/log/dancer-ircd
.for f in ${DIRS}
OWN_DIRS_PERMS+= ${f} dancer_ircd dancer_ircd 750
.endfor
.undef f
RCD_SCRIPTS= dancer-ircd
PKG_SYSCONFSUBDIR= dancer-ircd
CONF_FILES= ${EGDIR}/ircd.conf.default ${PKG_SYSCONFDIR}/ircd.conf
.include "../../mk/bsd.prefs.mk"
BUILD_DEFS+= DANCER_IRCD_NETWORK_NAME DANCER_IRCD_NETWORK_DESCR \
DANCER_IRCD_REALNAME DANCER_IRCD_LOGDIR \
DANCER_IRCD_PIDDIR DANCER_IRCD_CONFDIR
# Default targets
DANCER_IRCD_NETWORK_NAME?= "My\ network"
DANCER_IRCD_NETWORK_DESCR?= "A\ happy\ and\ sweet\ network"
DANCER_IRCD_REALNAME?= "my_ircd.com"
DANCER_IRCD_LOGDIR?= /var/log/dancer-ircd
DANCER_IRCD_PIDDIR?= /var/run
DANCER_IRCD_CONFDIR?= ${PKG_SYSCONFDIR}
post-extract:
${MV} ${WRKSRC}/include/config.h.dist ${WRKSRC}/include/config.h.dist.in
pre-configure:
${SED} \
-e "s|@SPATH@|${PREFIX}/sbin/dancer-ircd|g" \
-e "s|@CPATH@|${DANCER_IRCD_CONFDIR}/dancer-ircd|g" \
-e "s|@KPATH@|${DANCER_IRCD_CONFDIR}/kline.conf|g" \
-e "s|@DLPATH@|${DANCER_IRCD_CONFDIR}/dline.conf|g" \
-e "s|@MPATH@|${DANCER_IRCD_CONFDIR}/motd|g" \
-e "s|@LPATH@|${DANCER_IRCD_LOGDIR}/ircd.log|g" \
-e "s|@PPATH@|${DANCER_IRCD_PIDDIR}/dancer-ircd.pid|g" \
-e "s|@HPATH@|${DANCER_IRCD_CONFDIR}/ohelp|g" \
-e "s|@OPATH@|${DANCER_IRCD_CONFDIR}/omotd|g" \
-e "s|@MXPATH@|${DANCER_IRCD_CONFDIR}/ircd.max|g" \
-e "s|@NET_NAME@|${DANCER_IRCD_NETWORK_NAME}|g" \
-e "s|@NET_DESCR@|${DANCER_IRCD_NETWORK_DESCR}|g" \
-e "s|@NET_RNAME@|${DANCER_IRCD_REALNAME}|g" \
< ${WRKSRC}/include/config.h.dist.in > \
${WRKSRC}/include/config.h.dist
do-install:
${INSTALL_DATA_DIR} ${EGDIR} ${DOCDIR} ${DOCDIR}/hybrid
( cd ${WRKSRC}/doc && \
for f in RE* *.txt; do ${INSTALL_DATA} $$f ${DOCDIR}; done )
( cd ${WRKSRC}/doc/hybrid/ && \
for f in *; do ${INSTALL_DATA} $$f ${DOCDIR}/hybrid; done )
${INSTALL_PROGRAM} ${WRKSRC}/src/dancer-ircd ${PREFIX}/sbin
${INSTALL_SCRIPT} ${WRKSRC}/tools/mkconf ${WRKSRC}/tools/install_ircd \
${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/tools/viconf ${WRKSRC}/tools/mkpasswd \
${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/doc/ircd.8 ${PREFIX}/man/man8
${INSTALL_DATA} ${WRKSRC}/doc/example.conf ${EGDIR}/ircd.conf.default
.include "../../mk/bsd.pkg.mk"

View file

@ -1,30 +0,0 @@
@comment $NetBSD: PLIST,v 1.2 2003/05/10 08:48:39 xtraeme Exp $
etc/rc.d/dancer-ircd
man/man8/ircd.8
sbin/dancer-ircd
sbin/install_ircd
sbin/mkconf
sbin/mkpasswd
sbin/viconf
share/doc/dancer-ircd/CIDR.txt
share/doc/dancer-ircd/README
share/doc/dancer-ircd/README.FIRST.hybrid-6
share/doc/dancer-ircd/README.TSora
share/doc/dancer-ircd/README.small_nets
share/doc/dancer-ircd/README.umodes
share/doc/dancer-ircd/RELNOTES.hybrid-6
share/doc/dancer-ircd/blalloc.txt
share/doc/dancer-ircd/hybrid/ChangeLog.hybrid-6.gz
share/doc/dancer-ircd/hybrid/README
share/doc/dancer-ircd/hybrid/example.conf
share/doc/dancer-ircd/hybrid/example.conf.trillian
share/doc/dancer-ircd/hybrid/mtrie.txt
share/doc/dancer-ircd/hybrid/opermyth.txt
share/doc/dancer-ircd/hybrid/opers.txt
share/doc/dancer-ircd/hybrid/server-version-info
share/doc/dancer-ircd/hybrid/simple.conf
share/doc/dancer-ircd/rfc1459.txt
share/examples/dancer-ircd/ircd.conf.default
@dirrm share/examples/dancer-ircd
@dirrm share/doc/dancer-ircd/hybrid
@dirrm share/doc/dancer-ircd

View file

@ -1,7 +0,0 @@
$Id: TODO,v 1.6 2003/06/03 18:16:16 xtraeme Exp $
* Improve DESCR ?
* Improve the do-install target ?
- There is no need for files/dancer-ircd.sh to have execute permissions. When
importing this package in pkgsrc, fix it.

View file

@ -1,6 +0,0 @@
$NetBSD: distinfo,v 1.6 2003/05/10 08:48:39 xtraeme Exp $
SHA1 (dancer-ircd-1.0.31+maint8-fn6.tar.gz) = 8d67992ff4da97c2b94d7de079eaeb734d2b8b69
Size (dancer-ircd-1.0.31+maint8-fn6.tar.gz) = 779694 bytes
SHA1 (patch-aa) = 393181160d1f4e66eee051816a8dc92f2e7c07c4
SHA1 (patch-ab) = 42dc4f293d5e6095db90baba33afb477bb7dadb7

View file

@ -1,20 +0,0 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: dancer-ircd.sh,v 1.2 2003/07/14 14:37:05 xtraeme Exp $
#
# PROVIDE: dancer-ircd
# REQUIRE: DAEMON
. /etc/rc.subr
name="dancer-ircd"
rcvar=$name
command="@PREFIX@/sbin/${name}"
pidfile="/var/run/${name}.pid"
required_files="@PKG_SYSCONFDIR@/ircd.conf"
dancer_ircd_user="dancer_ircd"
dancer_ircd_group="dancer_ircd"
load_rc_config $name
run_rc_command "$1"

View file

@ -1,15 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/04/20 15:14:26 xtraeme Exp $
--- src/res.c.orig 2003-04-20 14:52:58.000000000 +0200
+++ src/res.c 2003-04-20 14:53:21.000000000 +0200
@@ -265,8 +265,8 @@
* From bind 8.3, these aren't in earlier versions of bind
*
*/
-extern u_short _getshort(const u_char *);
-extern u_int _getlong(const u_char *);
+/*extern u_short _getshort(const u_char *);
+extern u_int _getlong(const u_char *);*/
/*
* int
* res_isourserver(ina)

View file

@ -1,68 +0,0 @@
$NetBSD: patch-ab,v 1.4 2003/05/10 08:48:39 xtraeme Exp $
--- include/config.h.dist.in.orig 2003-05-10 10:07:29.000000000 +0200
+++ include/config.h.dist.in 2003-05-10 10:12:33.000000000 +0200
@@ -125,15 +125,15 @@
*/
#define DPATH "/"
-#define SPATH "bin/dancer-ircd"
-#define CPATH "etc/dancer-ircd/ircd.conf"
-#define KPATH "var/lib/dancer-ircd/kline.conf"
-#define DLPATH "var/lib/dancer-ircd/dline.conf"
-#define MPATH "etc/dancer-ircd/motd"
-#define LPATH "var/log/dancer-ircd/ircd.log"
-#define PPATH "var/run/dancer-ircd.pid"
-#define HPATH "etc/dancer-ircd/ohelp"
-#define OPATH "etc/dancer-ircd/omotd"
+#define SPATH "@SPATH@"
+#define CPATH "@CPATH@"
+#define KPATH "@KPATH@"
+#define DLPATH "@DLPATH@"
+#define MPATH "@MPATH@"
+#define LPATH "@LPATH@"
+#define PPATH "@PPATH@"
+#define HPATH "@HPATH@"
+#define OPATH "@OPATH@"
/* HIDE_OPS
* Define this to prevent non chanops from seeing what ops a channel has
@@ -173,17 +173,17 @@
/* NETWORK_NAME
* Displayed in place of the servername when SERVERHIDE is enabled
*/
-#define NETWORK_NAME "irc.freenode.net"
+#define NETWORK_NAME "@NET_NAME@"
/* NETWORK_DESC
* Displayed in place of the server info when SERVERHIDE is enabled
*/
-#define NETWORK_DESC "http://freenode.net/"
+#define NETWORK_DESC "@NET_DESCR@"
/* NETWORK_REALNAME
* Displayed in welcome message
*/
-#define NETWORK_REALNAME "freenode IRC"
+#define NETWORK_REALNAME "@NET_RNAME@"
/* USE_SERVICES
* Defines whether or not you're using services on your network
@@ -251,7 +251,7 @@
*/
#define SAVE_MAXCLIENT
#ifdef SAVE_MAXCLIENT
-# define MXPATH "etc/dancer-ircd/ircd.max"
+# define MXPATH "@MXPATH@"
# define SAVE_TIME 3600
#endif
@@ -575,7 +575,7 @@
* this option is used unless you tell the system administrator beforehand
* and obtain their permission to send messages to the system log files.
*/
-#undef USE_SYSLOG
+#define USE_SYSLOG
#ifdef USE_SYSLOG
/* SYSLOG_KILL SYSLOG_SQUIT SYSLOG_CONNECT SYSLOG_USERS SYSLOG_OPER