Create broken package Jitsi
Jitsi (formerly SIP Communicator) is an audio/video and chat communicator that supports protocols such as SIP, XMPP/Jabber, AIM/ICQ, Windows Live, Yahoo! and many other useful features.
This commit is contained in:
parent
8f7c05d4f1
commit
1132763127
7 changed files with 109 additions and 0 deletions
3
jitsi/DESCR
Normal file
3
jitsi/DESCR
Normal file
|
@ -0,0 +1,3 @@
|
|||
Jitsi (formerly SIP Communicator) is an audio/video and chat communicator
|
||||
that supports protocols such as SIP, XMPP/Jabber, AIM/ICQ, Windows Live,
|
||||
Yahoo! and many other useful features.
|
27
jitsi/Makefile
Normal file
27
jitsi/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
# $NetBSD$
|
||||
|
||||
DISTNAME= jitsi-src-2.8.5426
|
||||
CATEGORIES= chat
|
||||
MASTER_SITES= https://download.jitsi.org/jitsi/src/
|
||||
EXTRACT_SUFX= .zip
|
||||
|
||||
MAINTAINER= coypu@sdf.org
|
||||
HOMEPAGE= https://jitsi.org
|
||||
COMMENT=
|
||||
LICENSE= gnu-lgpl-v2.1
|
||||
|
||||
WRKSRC= ${WRKDIR}/jitsi
|
||||
USE_LANGUAGES= c c++
|
||||
|
||||
do-build:
|
||||
$(RUN)$(_ULIMIT_CMD) cd $(WRKSRC) && \
|
||||
$(PKGSRC_SETENV) $(MAKE_ENV) \
|
||||
ant -nouserlib rebuild
|
||||
|
||||
do-install:
|
||||
cd ${WRKSRC} && ./resources/install/generic/run.sh
|
||||
|
||||
DEPENDS+= apache-ant-[0-9]*:../../devel/apache-ant
|
||||
|
||||
.include "../../mk/java-vm.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
1
jitsi/PLIST
Normal file
1
jitsi/PLIST
Normal file
|
@ -0,0 +1 @@
|
|||
@comment $NetBSD$
|
9
jitsi/distinfo
Normal file
9
jitsi/distinfo
Normal file
|
@ -0,0 +1,9 @@
|
|||
$NetBSD$
|
||||
|
||||
SHA1 (jitsi-src-2.8.5426.zip) = 97e2b6d964d2a6f7dc1ff87ea9335d106655f2bc
|
||||
RMD160 (jitsi-src-2.8.5426.zip) = 54a858128789bdd0c83205aa3e12fb3d99163054
|
||||
SHA512 (jitsi-src-2.8.5426.zip) = 9a44f3af10620e42a4de87967c74084f6d07eea433c69f9e2e0ddd529723777ac48bcd250d5717872f8cea926cdf237cbbaf44cbeaba1ab201f23a34d68d7841
|
||||
Size (jitsi-src-2.8.5426.zip) = 67515973 bytes
|
||||
SHA1 (patch-build.xml) = 12366e729c31cb98d35197de4f2de24ff6d5336c
|
||||
SHA1 (patch-resources_install_generic_run.sh) = 69d104f900df2e6c1a6ab7192d75754a0d65c164
|
||||
SHA1 (patch-src_native_hwaddressretriever_HardwareAddressRetriever__unix.c) = 21b8e86460954b9240e02b8dfd3f3612b73fb356
|
33
jitsi/patches/patch-build.xml
Normal file
33
jitsi/patches/patch-build.xml
Normal file
|
@ -0,0 +1,33 @@
|
|||
$NetBSD$
|
||||
|
||||
--- build.xml.orig 2015-02-10 17:12:09.000000000 +0000
|
||||
+++ build.xml
|
||||
@@ -12,6 +12,7 @@
|
||||
<property name="bundles.dest.win" value="${bundles.dest}/os-specific/windows"/>
|
||||
<property name="bundles.dest.lin" value="${bundles.dest}/os-specific/linux"/>
|
||||
<property name="bundles.dest.sol" value="${bundles.dest}/os-specific/solaris"/>
|
||||
+ <property name="bundles.dest.freebsd" value="${bundles.dest}/os-specific/freebsd"/>
|
||||
<property name="bundles.dest.freebsd" value="${bundles.dest}/os-specific/freebsd"/>
|
||||
<property name="bundles.dest.android" value="${bundles.dest}/os-specific/android"/>
|
||||
<property name="doc" value="doc"/>
|
||||
@@ -25,6 +26,8 @@
|
||||
<property name="lib.mac.noinst" value="${lib}/os-specific/mac/installer-exclude"/>
|
||||
<property name="lib.sol" value="${lib}/os-specific/solaris"/>
|
||||
<property name="lib.sol.noinst" value="${lib}/os-specific/solaris/installer-exclude"/>
|
||||
+ <property name="lib.netbsd" value="${lib}/os-specific/freebsd"/>
|
||||
+ <property name="lib.netbsd.noinst" value="${lib}/os-specific/freebsd/installer-exclude"/>
|
||||
<property name="lib.freebsd" value="${lib}/os-specific/freebsd"/>
|
||||
<property name="lib.freebsd.noinst" value="${lib}/os-specific/freebsd/installer-exclude"/>
|
||||
<property name="lib.noinst" value="${lib}/installer-exclude"/>
|
||||
@@ -168,6 +171,11 @@
|
||||
<isset property="is.running.macos"/>
|
||||
</condition>
|
||||
|
||||
+ <!-- NetBSD specific properties -->
|
||||
+ <condition property="is.running.netbsd" value="${os.name}">
|
||||
+ <equals arg1="${os.name}" arg2="freebsd" casesensitive="false" trim="true"/>
|
||||
+ </condition>
|
||||
+
|
||||
<!-- FreeBSD specific properties -->
|
||||
<condition property="is.running.freebsd" value="${os.name}">
|
||||
<equals arg1="${os.name}" arg2="freebsd" casesensitive="false" trim="true"/>
|
23
jitsi/patches/patch-resources_install_generic_run.sh
Normal file
23
jitsi/patches/patch-resources_install_generic_run.sh
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD$
|
||||
|
||||
Unnecessary and breaks NetBSD which doesnt have x86_64
|
||||
or 32 in uname.
|
||||
|
||||
--- resources/install/generic/run.sh.orig 2013-11-01 15:37:21.000000000 +0000
|
||||
+++ resources/install/generic/run.sh
|
||||
@@ -1,15 +1,4 @@
|
||||
mkdir -p $HOME/.sip-communicator/log
|
||||
|
||||
-# Get architecture
|
||||
-ARCH=`uname -m | sed -e s/x86_64/64/ -e s/i.86/32/`
|
||||
-
|
||||
-# Additionnal JVM arguments
|
||||
-CLIENTARGS=""
|
||||
-
|
||||
-if [ $ARCH -eq 32 ]
|
||||
-then
|
||||
- CLIENTARGS="-client -Xmx256m"
|
||||
-fi
|
||||
-
|
||||
export PATH=$PATH:native
|
||||
java $CLIENTARGS -classpath "lib/felix.jar:sc-bundles/sc-launcher.jar:sc-bundles/util.jar:lib/" -Djava.library.path=native -Dfelix.config.properties=file:./lib/felix.client.run.properties -Djava.util.logging.config.file=lib/logging.properties net.java.sip.communicator.launcher.SIPCommunicator
|
|
@ -0,0 +1,13 @@
|
|||
$NetBSD$
|
||||
|
||||
--- src/native/hwaddressretriever/HardwareAddressRetriever_unix.c.orig 2013-07-09 08:31:30.000000000 +0000
|
||||
+++ src/native/hwaddressretriever/HardwareAddressRetriever_unix.c
|
||||
@@ -26,7 +26,7 @@
|
||||
|
||||
#include <net/if.h>
|
||||
|
||||
-#if defined(__FreeBSD__) || defined(__APPLE__)
|
||||
+#if defined(__NetBSD__) || defined(__FreeBSD__) || defined(__APPLE__)
|
||||
#include <ifaddrs.h>
|
||||
#include <net/if_dl.h>
|
||||
#include <net/route.h>
|
Loading…
Reference in a new issue