Packaged DeforaOS Panel 0.3.1 (as already found in pkgsrc) for Gtk+ 3
This commit is contained in:
parent
b5db8f9886
commit
113c61f87a
12 changed files with 192 additions and 44 deletions
|
@ -1,10 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.28 2014/06/26 12:02:19 khorben Exp $
|
||||
# $NetBSD: Makefile,v 1.29 2014/10/25 00:00:42 khorben Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Panel-0.2.18
|
||||
PKGNAME= deforaos-panel-0.2.18
|
||||
DISTNAME= Panel-0.3.1
|
||||
PKGNAME= deforaos-panel-0.3.1
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://www.defora.org/os/download/download/4295/
|
||||
MASTER_SITES= http://www.defora.org/os/download/download/4338/
|
||||
|
||||
MAINTAINER= khorben@defora.org
|
||||
HOMEPAGE= http://www.defora.org/
|
||||
|
@ -22,20 +22,32 @@ MAKE_FLAGS+= DESTDIR=${DESTDIR}
|
|||
MAKE_FLAGS+= PREFIX=${PREFIX}
|
||||
AUTO_MKDIRS= yes
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${PKGMANDIR} != "share/man"
|
||||
post-install:
|
||||
${MV} ${DESTDIR}${PREFIX}/share/man/html1/panel-embed.html ${DESTDIR}${PREFIX}/${PKGMANDIR}/html1/panel-embed.html
|
||||
${MV} ${DESTDIR}${PREFIX}/share/man/html1/panel-message.html ${DESTDIR}${PREFIX}/${PKGMANDIR}/html1/panel-message.html
|
||||
${MV} ${DESTDIR}${PREFIX}/share/man/html1/panel-notify.html ${DESTDIR}${PREFIX}/${PKGMANDIR}/html1/panel-notify.html
|
||||
${MV} ${DESTDIR}${PREFIX}/share/man/html1/panel.html ${DESTDIR}${PREFIX}/${PKGMANDIR}/html1/panel.html
|
||||
${MV} ${DESTDIR}${PREFIX}/share/man/html1/panelctl.html ${DESTDIR}${PREFIX}/${PKGMANDIR}/html1/panelctl.html
|
||||
${MV} ${DESTDIR}${PREFIX}/share/man/html1/wifibrowser.html ${DESTDIR}${PREFIX}/${PKGMANDIR}/html1/wifibrowser.html
|
||||
${MV} ${DESTDIR}${PREFIX}/share/man/man1/panel-embed.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/panel-embed.1
|
||||
${MV} ${DESTDIR}${PREFIX}/share/man/man1/panel-message.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/panel-message.1
|
||||
${MV} ${DESTDIR}${PREFIX}/share/man/man1/panel-notify.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/panel-notify.1
|
||||
${MV} ${DESTDIR}${PREFIX}/share/man/man1/panel.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/panel.1
|
||||
${MV} ${DESTDIR}${PREFIX}/share/man/man1/panelctl.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/panelctl.1
|
||||
${MV} ${DESTDIR}${PREFIX}/share/man/man1/wifibrowser.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/wifibrowser.1
|
||||
${RMDIR} ${DESTDIR}${PREFIX}/share/man/html1
|
||||
${RMDIR} ${DESTDIR}${PREFIX}/share/man/man1
|
||||
${RMDIR} ${DESTDIR}${PREFIX}/share/man
|
||||
.endif
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
|
||||
.include "../../wip/deforaos-libdesktop/buildlink3.mk"
|
||||
.include "../../wip/deforaos-browser/buildlink3.mk"
|
||||
.include "../../wip/deforaos-keyboard/buildlink3.mk"
|
||||
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
|
||||
#.include "../../multimedia/deforaos-player/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,10 +1,11 @@
|
|||
@comment $NetBSD: PLIST,v 1.14 2014/06/26 12:02:20 khorben Exp $
|
||||
@comment $NetBSD: PLIST,v 1.15 2014/10/25 00:00:42 khorben Exp $
|
||||
bin/panel
|
||||
bin/panel-embed
|
||||
bin/panel-message
|
||||
bin/panel-notify
|
||||
bin/panelctl
|
||||
bin/run
|
||||
bin/wifibrowser
|
||||
include/Desktop/Panel.h
|
||||
lib/Panel/applets/battery.so
|
||||
lib/Panel/applets/bluetooth.so
|
||||
|
@ -16,12 +17,12 @@ lib/Panel/applets/desktop.so
|
|||
lib/Panel/applets/embed.so
|
||||
lib/Panel/applets/gps.so
|
||||
lib/Panel/applets/gsm.so
|
||||
lib/Panel/applets/keyboard.so
|
||||
lib/Panel/applets/lock.so
|
||||
lib/Panel/applets/logout.so
|
||||
lib/Panel/applets/main.so
|
||||
lib/Panel/applets/memory.so
|
||||
lib/Panel/applets/mixer.so
|
||||
lib/Panel/applets/network.so
|
||||
lib/Panel/applets/pager.so
|
||||
lib/Panel/applets/phone.so
|
||||
lib/Panel/applets/player.so
|
||||
|
@ -33,20 +34,28 @@ lib/Panel/applets/systray.so
|
|||
lib/Panel/applets/tasks.so
|
||||
lib/Panel/applets/title.so
|
||||
lib/Panel/applets/usb.so
|
||||
lib/Panel/applets/user.so
|
||||
lib/Panel/applets/volume.so
|
||||
lib/Panel/applets/wpa_supplicant.so
|
||||
lib/libPanel.a
|
||||
lib/libPanel.so
|
||||
lib/libPanel.so.0
|
||||
lib/libPanel.so.0.0
|
||||
lib/pkgconfig/Panel.pc
|
||||
man/html1/panel-embed.html
|
||||
man/html1/panel-message.html
|
||||
man/html1/panel-notify.html
|
||||
man/html1/panel.html
|
||||
man/html1/panelctl.html
|
||||
man/html1/wifibrowser.html
|
||||
man/man1/panel-embed.1
|
||||
man/man1/panel-message.1
|
||||
man/man1/panel-notify.1
|
||||
man/man1/panel.1
|
||||
man/man1/panelctl.1
|
||||
share/applications/panel-settings.desktop
|
||||
share/doc/html/Panel/panel-embed.html
|
||||
share/doc/html/Panel/panel-message.html
|
||||
share/doc/html/Panel/panel-notify.html
|
||||
share/doc/html/Panel/panel.html
|
||||
share/doc/html/Panel/panelctl.html
|
||||
man/man1/wifibrowser.1
|
||||
share/applications/deforaos-panel-settings.desktop
|
||||
share/applications/deforaos-wifibrowser.desktop
|
||||
share/icons/hicolor/16x16/apps/panel-applet-bluetooth.png
|
||||
share/icons/hicolor/16x16/apps/panel-applet-desktop.png
|
||||
share/icons/hicolor/16x16/apps/panel-applet-usb.png
|
||||
|
|
|
@ -1,11 +1,15 @@
|
|||
$NetBSD: distinfo,v 1.20 2014/06/26 12:02:20 khorben Exp $
|
||||
$NetBSD: distinfo,v 1.21 2014/10/25 00:00:42 khorben Exp $
|
||||
|
||||
SHA1 (Panel-0.2.18.tar.gz) = 2920631f99b3c9f4d91de1765b2588dfbf0f6645
|
||||
RMD160 (Panel-0.2.18.tar.gz) = c8dae6a9cb028814a24b01a5fcf04b6b34f4c6c6
|
||||
Size (Panel-0.2.18.tar.gz) = 111036 bytes
|
||||
SHA1 (Panel-0.3.1.tar.gz) = 0a2d9d424b8b316d8a6db087c8cb2dddaaa47347
|
||||
RMD160 (Panel-0.3.1.tar.gz) = 3e2fe1e8f1cf2a4c27cdf355bf5c00685d5ada9a
|
||||
Size (Panel-0.3.1.tar.gz) = 133677 bytes
|
||||
SHA1 (patch-data_Panel.pc.in) = c650bb1875d73466e0a9fe86e82fcfa3c9ca1527
|
||||
SHA1 (patch-src_Makefile) = 401e81f345691dd5d7c2d50ee21ab6f13b1f26b1
|
||||
SHA1 (patch-src_applets_Makefile) = 77f6974352be6081be3b5db69d63665b7d15a8f0
|
||||
SHA1 (patch-src_applets_embed.c) = ad32c1f76134f2dd95db74f05e9ffdb434a538fd
|
||||
SHA1 (patch-tools_Makefile) = e3f492d944bb255b8cfa4e53282ab45add4761c6
|
||||
SHA1 (patch-tools_message.c) = 4b1652fb0844308bc11a28d90e786e03fb7d0834
|
||||
SHA1 (patch-data_pkgconfig.sh) = 7c40652087c604cff593a320e97259c453633c74
|
||||
SHA1 (patch-src_Makefile) = d5024940f966122276dbf24166893475cc39aaf2
|
||||
SHA1 (patch-src_applets_Makefile) = 74f382d08048d6deb51aa38e6fcd8d56cd4206f2
|
||||
SHA1 (patch-src_applets_main.c) = 07382b429402b750800bcec490a4e911d6c4ec49
|
||||
SHA1 (patch-src_applets_memory.c) = 858dc9f03fa32e01d3d02d49d13742cda7b0193e
|
||||
SHA1 (patch-src_applets_swap.c) = b23884942caea5416a1809321edd36a36ed2ec17
|
||||
SHA1 (patch-src_applets_volume.c) = cc921f78c1b99bd645c89b3228b36a38c23a8294
|
||||
SHA1 (patch-src_panel.c) = 9423e1a6c3535be8d90a40c9b2f70a5cbff2ac78
|
||||
SHA1 (patch-tools_Makefile) = 642887110b585cd6b78d0cf43acc4f826b1abcae
|
||||
|
|
20
deforaos-panel/patches/patch-data_pkgconfig.sh
Normal file
20
deforaos-panel/patches/patch-data_pkgconfig.sh
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-data_pkgconfig.sh,v 1.1 2014/10/25 00:00:42 khorben Exp $
|
||||
|
||||
Use correct rpath flag on SunOS.
|
||||
|
||||
--- data/pkgconfig.sh.orig 2014-04-23 15:37:45.000000000 +0000
|
||||
+++ data/pkgconfig.sh
|
||||
@@ -129,9 +129,12 @@ while [ $# -gt 0 ]; do
|
||||
if [ "$PREFIX" != "/usr" ]; then
|
||||
RPATH="-Wl,-rpath-link,\${libdir} -Wl,-rpath,\${libdir}"
|
||||
case $(uname -s) in
|
||||
- Darwin|SunOS)
|
||||
+ Darwin)
|
||||
RPATH="-Wl,-rpath,\${libdir}"
|
||||
;;
|
||||
+ SunOS)
|
||||
+ RPATH="-Wl,-R\${libdir}"
|
||||
+ ;;
|
||||
esac
|
||||
fi
|
||||
|
|
@ -1,17 +1,17 @@
|
|||
$NetBSD: patch-src_Makefile,v 1.1 2014/06/26 12:02:20 khorben Exp $
|
||||
$NetBSD: patch-src_Makefile,v 1.2 2014/10/25 00:00:42 khorben Exp $
|
||||
|
||||
Build run(1) with Gtk+ 3.0
|
||||
|
||||
--- src/Makefile.orig 2013-06-11 21:40:17.000000000 +0000
|
||||
--- src/Makefile.orig 2014-10-23 17:35:58.000000000 +0000
|
||||
+++ src/Makefile
|
||||
@@ -35,8 +35,8 @@ panelctl: $(panelctl_OBJS)
|
||||
@@ -52,8 +52,8 @@ panelctl: $(panelctl_OBJS)
|
||||
$(CC) -o panelctl $(panelctl_OBJS) $(panelctl_LDFLAGS)
|
||||
|
||||
run_OBJS = run.o
|
||||
-run_CFLAGS = $(CPPFLAGSF) $(CPPFLAGS) -D PREFIX=\"$(PREFIX)\" $(CFLAGSF) $(CFLAGS) `pkg-config --cflags libSystem gtk+-2.0`
|
||||
-run_LDFLAGS = $(LDFLAGSF) $(LDFLAGS) `pkg-config --libs libSystem gtk+-2.0`
|
||||
-run_LDFLAGS = $(LDFLAGSF) $(LDFLAGS) `pkg-config --libs libSystem gtk+-2.0` -lintl
|
||||
+run_CFLAGS = $(CPPFLAGSF) $(CPPFLAGS) -D PREFIX=\"$(PREFIX)\" $(CFLAGSF) $(CFLAGS) `pkg-config --cflags libSystem gtk+-3.0`
|
||||
+run_LDFLAGS = $(LDFLAGSF) $(LDFLAGS) `pkg-config --libs libSystem gtk+-3.0`
|
||||
+run_LDFLAGS = $(LDFLAGSF) $(LDFLAGS) `pkg-config --libs libSystem gtk+-3.0` -lintl
|
||||
|
||||
run: $(run_OBJS)
|
||||
$(CC) -o run $(run_OBJS) $(run_LDFLAGS)
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-src_applets_Makefile,v 1.1 2014/06/26 12:02:20 khorben Exp $
|
||||
$NetBSD: patch-src_applets_Makefile,v 1.2 2014/10/25 00:00:42 khorben Exp $
|
||||
|
||||
Build the panel applets with Gtk+ 3.0
|
||||
The "embed" panel applet requires an additional library with Gtk+ 3.0
|
||||
|
||||
--- src/applets/Makefile.orig 2013-06-11 21:40:17.000000000 +0000
|
||||
--- src/applets/Makefile.orig 2014-10-23 17:35:58.000000000 +0000
|
||||
+++ src/applets/Makefile
|
||||
@@ -5,9 +5,9 @@ LIBDIR = $(PREFIX)/lib
|
||||
CC = cc
|
||||
|
|
16
deforaos-panel/patches/patch-src_applets_main.c
Normal file
16
deforaos-panel/patches/patch-src_applets_main.c
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-src_applets_main.c,v 1.1 2014/10/25 00:00:42 khorben Exp $
|
||||
|
||||
Need sys/fcntl.h for O_RDONLY on SunOS.
|
||||
|
||||
--- src/applets/main.c.orig 2014-10-23 17:34:42.000000000 +0000
|
||||
+++ src/applets/main.c
|
||||
@@ -16,6 +16,9 @@
|
||||
|
||||
|
||||
#include <sys/stat.h>
|
||||
+#if defined(__sun)
|
||||
+# include <fcntl.h>
|
||||
+#endif
|
||||
#include <dirent.h>
|
||||
#include <unistd.h>
|
||||
#include <stdlib.h>
|
22
deforaos-panel/patches/patch-src_applets_memory.c
Normal file
22
deforaos-panel/patches/patch-src_applets_memory.c
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-src_applets_memory.c,v 1.1 2014/10/25 00:00:42 khorben Exp $
|
||||
|
||||
--- src/applets/memory.c.orig 2014-06-27 11:22:53.000000000 +0000
|
||||
+++ src/applets/memory.c
|
||||
@@ -21,12 +21,13 @@
|
||||
#include <errno.h>
|
||||
#if defined(__linux__)
|
||||
# include <sys/sysinfo.h>
|
||||
-#elif defined(__FreeBSD__) || defined(__NetBSD__)
|
||||
+#elif defined(__FreeBSD__)
|
||||
+# include <sys/sysctl.h>
|
||||
+# include <sys/vmmeter.h>
|
||||
+# include <vm/vm_param.h>
|
||||
+#elif defined(__NetBSD__)
|
||||
# include <sys/sysctl.h>
|
||||
# include <sys/vmmeter.h>
|
||||
-# if defined(__FreeBSD__)
|
||||
-# include <vm/vm_param.h>
|
||||
-# endif
|
||||
#endif
|
||||
#include <libintl.h>
|
||||
#include "Panel.h"
|
12
deforaos-panel/patches/patch-src_applets_swap.c
Normal file
12
deforaos-panel/patches/patch-src_applets_swap.c
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-src_applets_swap.c,v 1.1 2014/10/25 00:00:42 khorben Exp $
|
||||
|
||||
--- src/applets/swap.c.orig 2014-06-27 11:23:35.000000000 +0000
|
||||
+++ src/applets/swap.c
|
||||
@@ -23,6 +23,7 @@
|
||||
# include <sys/sysinfo.h>
|
||||
#elif defined(__NetBSD__)
|
||||
# include <sys/sysctl.h>
|
||||
+# include <uvm/uvm_extern.h>
|
||||
#endif
|
||||
#include <libintl.h>
|
||||
#include "Panel.h"
|
15
deforaos-panel/patches/patch-src_applets_volume.c
Normal file
15
deforaos-panel/patches/patch-src_applets_volume.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_applets_volume.c,v 1.1 2014/10/25 00:00:42 khorben Exp $
|
||||
|
||||
Fix SunOS includes.
|
||||
|
||||
--- src/applets/volume.c.orig 2014-05-16 19:42:45.000000000 +0000
|
||||
+++ src/applets/volume.c
|
||||
@@ -19,7 +19,7 @@
|
||||
|
||||
|
||||
#include <sys/ioctl.h>
|
||||
-#if defined(__NetBSD__) || defined(__sun__)
|
||||
+#if defined(__NetBSD__)
|
||||
# include <sys/audioio.h>
|
||||
#elif defined(__linux__)
|
||||
# include <alsa/asoundlib.h>
|
43
deforaos-panel/patches/patch-src_panel.c
Normal file
43
deforaos-panel/patches/patch-src_panel.c
Normal file
|
@ -0,0 +1,43 @@
|
|||
$NetBSD: patch-src_panel.c,v 1.1 2014/10/25 00:00:42 khorben Exp $
|
||||
|
||||
Fix for Gtk+ 2.24
|
||||
|
||||
--- src/panel.c.orig 2014-10-23 09:38:39.000000000 +0000
|
||||
+++ src/panel.c
|
||||
@@ -768,7 +768,7 @@ static GtkWidget * _preferences_window_p
|
||||
for(i = 0; i < sizeof(titles) / sizeof(*titles); i++)
|
||||
{
|
||||
#if GTK_CHECK_VERSION(2, 24, 0)
|
||||
- gtk_combo_box_append_text(GTK_COMBO_BOX(widget), _(titles[i]));
|
||||
+ gtk_combo_box_text_append_text(GTK_COMBO_BOX_TEXT(widget), _(titles[i]));
|
||||
#else
|
||||
gtk_combo_box_append_text(GTK_COMBO_BOX(widget), _(titles[i]));
|
||||
#endif
|
||||
@@ -782,11 +782,11 @@ static GtkWidget * _preferences_window_p
|
||||
FALSE, TRUE, 0);
|
||||
gtk_widget_set_no_show_all(panel->pr_panels[i].enabled, TRUE);
|
||||
/* size */
|
||||
-#if GTK_CHECK_VERSION(3, 0, 0)
|
||||
+#if GTK_CHECK_VERSION(2, 24, 0)
|
||||
panel->pr_panels[i].size = gtk_combo_box_text_new();
|
||||
- gtk_combo_box_text_append(
|
||||
+ gtk_combo_box_text_append_text(
|
||||
GTK_COMBO_BOX_TEXT(panel->pr_panels[i].size),
|
||||
- NULL, _("Default"));
|
||||
+ _("Default"));
|
||||
#else
|
||||
panel->pr_panels[i].size = gtk_combo_box_new_text();
|
||||
gtk_combo_box_append_text(
|
||||
@@ -796,9 +796,9 @@ static GtkWidget * _preferences_window_p
|
||||
for(j = 0; j < sizeof(_panel_sizes) / sizeof(*_panel_sizes);
|
||||
j++)
|
||||
{
|
||||
-#if GTK_CHECK_VERSION(3, 0, 0)
|
||||
- gtk_combo_box_text_append(GTK_COMBO_BOX_TEXT(
|
||||
- panel->pr_panels[i].size), NULL,
|
||||
+#if GTK_CHECK_VERSION(2, 24, 0)
|
||||
+ gtk_combo_box_text_append_text(GTK_COMBO_BOX_TEXT(
|
||||
+ panel->pr_panels[i].size),
|
||||
_(_panel_sizes[j].alias));
|
||||
#else
|
||||
gtk_combo_box_append_text(
|
|
@ -1,17 +1,12 @@
|
|||
$NetBSD: patch-tools_Makefile,v 1.3 2014/06/26 12:02:20 khorben Exp $
|
||||
$NetBSD: patch-tools_Makefile,v 1.4 2014/10/25 00:00:42 khorben Exp $
|
||||
|
||||
panel-message(1) needs an additional library with Gtk+ 3.0
|
||||
|
||||
--- tools/Makefile.orig 2013-06-11 21:40:17.000000000 +0000
|
||||
--- tools/Makefile.orig 2014-10-23 17:35:58.000000000 +0000
|
||||
+++ tools/Makefile
|
||||
@@ -25,8 +25,8 @@ panel-embed: $(panel-embed_OBJS)
|
||||
$(CC) -o panel-embed $(panel-embed_OBJS) $(panel-embed_LDFLAGS)
|
||||
|
||||
panel-message_OBJS = message.o
|
||||
-panel-message_CFLAGS = $(CPPFLAGSF) $(CPPFLAGS) $(CFLAGSF) $(CFLAGS)
|
||||
-panel-message_LDFLAGS = $(LDFLAGSF) $(LDFLAGS)
|
||||
+panel-message_CFLAGS = $(CPPFLAGSF) $(CPPFLAGS) $(CFLAGSF) $(CFLAGS) `pkg-config --cflags gtk+-x11-3.0`
|
||||
+panel-message_LDFLAGS = $(LDFLAGSF) $(LDFLAGS) `pkg-config --libs gtk+-x11-3.0`
|
||||
|
||||
panel-message: $(panel-message_OBJS)
|
||||
$(CC) -o panel-message $(panel-message_OBJS) $(panel-message_LDFLAGS)
|
||||
@@ -2,6 +2,7 @@ TARGETS = panel-embed panel-message pane
|
||||
PREFIX = /usr/local
|
||||
DESTDIR =
|
||||
BINDIR = $(PREFIX)/bin
|
||||
+LIBDIR = $(PREFIX)/lib
|
||||
SBINDIR = $(PREFIX)/sbin
|
||||
CC = cc
|
||||
CPPFLAGSF=
|
||||
|
|
Loading…
Reference in a new issue