Upgrade DrWeb daemon client to version 4.30 (20031020, beta). At
this moment it works more stable than 4.30 release. Major changes: - Complete support of DrWeb 4.30 features. - Support of POSIX REs in filter rules. - Several new options was added. - Many bug fixes scince 4.29. Fore more detailed list please refer to http://lists.drweb.ru/pipermail/drweb-unix-announce/2003-October/000005.html This package changes: - More intelligent support of DISTFILES definitions. - Few cleanups.
This commit is contained in:
parent
d3ed099b96
commit
115b50feb7
10 changed files with 311 additions and 265 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.common,v 1.2 2003/10/17 19:51:41 bubuchka Exp $
|
||||
# $NetBSD: Makefile.common,v 1.3 2003/10/28 16:06:59 bubuchka Exp $
|
||||
#
|
||||
# This is installation framework to various clients to DrWeb daemon
|
||||
# antivirus shiped by Dialogue Science
|
||||
|
@ -16,31 +16,34 @@
|
|||
# .include "../../mk/bsd.pkg.mk"
|
||||
# Note: the bsd.pkg.install.mk is already included by this file.
|
||||
|
||||
DRW_CLMVER= 4.29.12
|
||||
DRW_CLSUBVER= F
|
||||
DRW_CLSUBVERN= 6
|
||||
DRW_CLVER= ${DRW_CLMVER}.${DRW_CLSUBVERN}
|
||||
DRW_CLMVER= 4.30.0
|
||||
DRW_CLSUBVER= beta
|
||||
DRW_CLSUBVERN= 20031020
|
||||
DRW_CLVER= ${DRW_CLMVER}${DRW_CLSUBVER:D-${DRW_CLSUBVER}}
|
||||
DRW_CLVERN= ${DRW_CLMVER}${DRW_CLSUBVERN:D.${DRW_CLSUBVERN}}
|
||||
|
||||
.if !defined(DRW_CLIENT_NAME)
|
||||
DRW_CLIENT_NAME= UNKNOWN
|
||||
PKG_FAIL_REASON= \
|
||||
"The package (${PKGNAME}) in the following directory is" \
|
||||
"improperly configured or damaged:" \
|
||||
"improperly configured or damaged:" \
|
||||
" ${.CURDIR}" \
|
||||
"Please define DRW_CLIENT_NAME variable before and see the" \
|
||||
"drweb-clients-shared/Makefile.common and drweb/Makefile.common files."
|
||||
.endif
|
||||
|
||||
DISTNAME= drweb-clients-${DRW_CLMVER}-${DRW_CLSUBVER}-sources
|
||||
PKGNAME= drweb-${DRW_CLIENT_NAME}-${DRW_CLVER}
|
||||
CATEGORIES= security
|
||||
# The DISTNAME must be changed when 4.30 will be released (again)
|
||||
#DISTNAME= drweb-clients-${DRW_CLVER}-sources
|
||||
DISTNAME= drweb-clients-beta-${DRW_CLSUBVERN}-sources
|
||||
PKGNAME= drweb-${DRW_CLIENT_NAME}-${DRW_CLVERN}
|
||||
CATEGORIES= wip security
|
||||
MASTER_SITES= ftp://ftp.drweb.ru/pub/unix/ \
|
||||
ftp://ftp.drweb.ru/pub/unix/betas/
|
||||
|
||||
HOMEPAGE= http://www.drweb.ru/
|
||||
|
||||
.if ${DRW_CLIENT_NAME} != "clients-shared"
|
||||
DEPENDS+= drweb-clients-shared-${DRW_CLVER}:../../wip/drweb-clients-shared
|
||||
DEPENDS+= drweb-clients-shared-${DRW_CLVERN}:../../wip/drweb-clients-shared
|
||||
|
||||
CFLAGS+= -DPKG_SYSCONFDIR='\"${PKG_SYSCONFDIR}\"'
|
||||
|
||||
|
@ -55,7 +58,7 @@ PATCHDIR= ${.CURDIR}/../../wip/drweb-clients-shared/patches
|
|||
FILESDIR= ${.CURDIR}/../../wip/drweb-clients-shared/files
|
||||
DISTINFO_FILE= ${.CURDIR}/../../wip/drweb-clients-shared/distinfo
|
||||
|
||||
FILES_SUBST+= DRW_CLVER=${DRW_CLVER} DRW_CLSUBVER=${DRW_CLSUBVER}
|
||||
FILES_SUBST+= DRW_CLVER=${DRW_CLVER} DRW_CLVERN=${DRW_CLVERN}
|
||||
|
||||
pre-configure:
|
||||
@${SED} ${FILES_SUBST_SED} \
|
||||
|
|
|
@ -1,9 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/09/13 12:58:40 bubuchka Exp $
|
||||
$NetBSD: distinfo,v 1.2 2003/10/28 16:06:59 bubuchka Exp $
|
||||
|
||||
SHA1 (drweb-clients-4.29.12-F-sources.tar.gz) = 3a3c23e64046a44708e6464654548c48a730b718
|
||||
Size (drweb-clients-4.29.12-F-sources.tar.gz) = 338133 bytes
|
||||
SHA1 (patch-aa) = 58209f96eeff2d9c09ae4fd0ec8782d06024552d
|
||||
SHA1 (patch-ab) = 25db0dc607cbec2b1a494035ef8f567fb7c8959b
|
||||
SHA1 (patch-ac) = 0c231d3c02e5411856efdab5814152f13ef2ebe0
|
||||
SHA1 (patch-ad) = 76b9a31cc636b0678ac8a827c38e573de796acef
|
||||
SHA1 (patch-ae) = f98791bc785e2c77748b101412b71e70584a20b1
|
||||
SHA1 (drweb-clients-beta-20031020-sources.tar.gz) = 4dab75d9fa97c38e5e1123dd4b9b9f1c4690e091
|
||||
Size (drweb-clients-beta-20031020-sources.tar.gz) = 390646 bytes
|
||||
SHA1 (patch-aa) = c0ce331a84c6b81cb9c3a2d19d09253cf52cb751
|
||||
SHA1 (patch-ab) = f051cb717ecd40ca3972f125d11490783997e9ae
|
||||
SHA1 (patch-ac) = 2ed4123966bfe4f98b166055eda3eb1c514c915b
|
||||
SHA1 (patch-ad) = f3c234f79d5af828d84fb67e39ef21c671bb7908
|
||||
SHA1 (patch-ae) = 56a4641c161b2770aa6e750d0f3c9592a5725b20
|
||||
SHA1 (patch-af) = 656c1a29ec3f759533b9b01823bf82cfa472f81d
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2003/09/13 12:58:43 bubuchka Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2003/10/28 16:07:00 bubuchka Exp $
|
||||
|
||||
--- Makefile.nix.tmpl.orig 2003-07-30 17:35:23.000000000 +0300
|
||||
--- Makefile.nix.tmpl.orig 2003-10-20 20:02:09.000000000 +0300
|
||||
+++ Makefile.nix.tmpl
|
||||
@@ -47,6 +47,7 @@ OPTFLAGS = ___OPT_FLAGS___
|
||||
DEFFLAGS = ___POLL_DEF___ -D__UNIX_DW -D$(OS)_DW -DDW_VERSION="\"___VER___\""
|
||||
|
@ -22,12 +22,12 @@ $NetBSD: patch-aa,v 1.1.1.1 2003/09/13 12:58:43 bubuchka Exp $
|
|||
|
||||
# Milter Library
|
||||
# Hack - add threads for drweb-smf under Linux
|
||||
@@ -215,7 +219,7 @@ dw_addresses.o: dw_addresses.c
|
||||
@@ -225,7 +229,7 @@ dw_addresses.o: dw_addresses.c
|
||||
|
||||
# DrWebd command line client rules
|
||||
drwebdc : drwebdc.o $(DWLIB)
|
||||
- $(CC) drwebdc.o -static -o $@ $(LINKLIB)
|
||||
+ $(CC) drwebdc.o -o $@ $(LINKLIB)
|
||||
drwebdc : drwebdc.o dc_files.o $(DWLIB)
|
||||
- $(CC) drwebdc.o dc_files.o -static -o $@ $(LINKLIB)
|
||||
+ $(CC) drwebdc.o dc_files.o -o $@ $(LINKLIB)
|
||||
|
||||
drwebdc.o: drwebdc.c
|
||||
$(CC) -c $(ADD_CFLAGS) $(DCOPT) ___SOURCE___ -o $@ $(CCOUTPUT)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2003/09/13 12:58:44 bubuchka Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2003/10/28 16:07:00 bubuchka Exp $
|
||||
|
||||
--- configure.orig 2003-07-30 17:35:23.000000000 +0300
|
||||
--- configure.orig 2003-10-20 20:02:09.000000000 +0300
|
||||
+++ configure
|
||||
@@ -42,6 +42,10 @@ case "`(uname -sr)2>/dev/null`" in
|
||||
OS="FreeBSD"
|
||||
|
@ -13,30 +13,19 @@ $NetBSD: patch-ab,v 1.1.1.1 2003/09/13 12:58:44 bubuchka Exp $
|
|||
"SunOS 5"*)
|
||||
OS="Solaris"
|
||||
echo
|
||||
@@ -117,53 +121,6 @@ if [ "$NEED_SM" = "y" ] ; then
|
||||
MILTER_VER="FIXED"
|
||||
fi
|
||||
fi
|
||||
- if [ $MILTER_VER = "STD" ] ; then
|
||||
- SM_HDR="include/libmilter/mfdef.h"
|
||||
- SM_LIB="lib/libsm.a"
|
||||
- SM_LIB_CMD="-lsm"
|
||||
- elif [ $MILTER_VER = "FIXED" ] ; then
|
||||
- SM_HDR="include/libmilter/mfdef.h"
|
||||
- SM_LIB=""
|
||||
- SM_LIB_CMD=""
|
||||
- elif [ $OS = "Linux" ] ; then
|
||||
- SM_HDR=""
|
||||
- SM_LIB="lib/libsmutil.a"
|
||||
- SM_LIB_CMD="-lsmutil"
|
||||
- else
|
||||
- SM_HDR=""
|
||||
- SM_LIB=""
|
||||
- SM_LIB_CMD=""
|
||||
- fi
|
||||
@@ -139,42 +143,6 @@ if [ "$NEED_SM" = "y" ] ; then
|
||||
SM_LIB=""
|
||||
SM_LIB_CMD=""
|
||||
fi
|
||||
- NO_ADD="no"
|
||||
- if [ ! -f include/libmilter/mfapi.h ] ; then
|
||||
- echo "no include/libmilter/mfapi.h"
|
||||
- fi
|
||||
- if grep smfi_setbacklog include/libmilter/mfapi.h > /dev/null 2>&1 ; then
|
||||
- SM_BACKLOG="-DDW_HAVE_BACKLOG"
|
||||
- fi
|
||||
- if grep SMFI_DRWEB_PATCHED include/libmilter/mfapi.h > /dev/null 2>&1 ; then
|
||||
- SM_PATCH="yes"
|
||||
- fi
|
||||
- if [ "x$SM_HDR" != "x" -a ! -f "$SM_HDR" ] ; then
|
||||
- echo "no $SM_HDR"
|
||||
|
|
|
@ -1,76 +1,42 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2003/09/13 12:58:45 bubuchka Exp $
|
||||
$NetBSD: patch-ac,v 1.2 2003/10/28 16:07:00 bubuchka Exp $
|
||||
|
||||
--- dw_options.c.orig 2003-07-30 17:35:23.000000000 +0300
|
||||
+++ dw_options.c
|
||||
@@ -66,62 +66,54 @@ static const char rcsid[] = "$Id: dw_opt
|
||||
#define PROG_NAME "drweb-smf"
|
||||
#define PROG_FULLNAME "DrWeb Sendmail Filter"
|
||||
#define PROG_NOTE ""
|
||||
-#define CONF_FNAME "drweb_smf.conf"
|
||||
+#define CONF_FNAME "drweb-smf.conf"
|
||||
#endif /* SENDMAIL */
|
||||
|
||||
#if defined(DW_CGP)
|
||||
#define PROG_NAME "drweb-cgp"
|
||||
#define PROG_FULLNAME "DrWeb Plug-in for CommuniGate Pro"
|
||||
#define PROG_NOTE "Note: plug-in will be started by CommuniGate Pro automatically"
|
||||
-#define CONF_FNAME "drweb_cgp.conf"
|
||||
+#define CONF_FNAME "drweb-cgp.conf"
|
||||
#endif /* CGP */
|
||||
|
||||
#if defined(DW_MIO)
|
||||
#define PROG_NAME "drweb-mio"
|
||||
#define PROG_FULLNAME "DrWeb Plug-in for Mobico MIO Server"
|
||||
#define PROG_NOTE "Note: plug-in will be started by MIO automatically"
|
||||
-#define CONF_FNAME "drweb_mio.conf"
|
||||
+#define CONF_FNAME "drweb-mio.conf"
|
||||
#endif /* MIO */
|
||||
|
||||
#if defined(DW_ZMAILER)
|
||||
#define PROG_NAME "drweb-zmailer"
|
||||
#define PROG_FULLNAME "DrWeb Filter for ZMailer"
|
||||
#define PROG_NOTE "Note: filter will be started by ZMailer automatically"
|
||||
-#define CONF_FNAME "drweb_zmailer.conf"
|
||||
+#define CONF_FNAME "drweb-zmailer.conf"
|
||||
#endif /* ZMAILER */
|
||||
|
||||
#if defined(DW_QMAIL)
|
||||
#define PROG_NAME "qmail-queue"
|
||||
#define PROG_FULLNAME "DrWeb Filter for QMail"
|
||||
#define PROG_NOTE "Note: filter will be started by QMail system automatically after install"
|
||||
-#define CONF_FNAME "drweb_qmail.conf"
|
||||
+#define CONF_FNAME "drweb-qmail.conf"
|
||||
#endif /* QMAIL */
|
||||
|
||||
#if defined(DW_POSTFIX)
|
||||
#define PROG_NAME "drweb-postfix"
|
||||
#define PROG_FULLNAME "DrWeb Filter for Postfix"
|
||||
#define PROG_NOTE "Note: filter will be started by Postfix system automatically after install"
|
||||
-#define CONF_FNAME "drweb_postfix.conf"
|
||||
+#define CONF_FNAME "drweb-postfix.conf"
|
||||
#endif /* POSTFIX */
|
||||
|
||||
#if defined(DW_EXIM)
|
||||
#define PROG_NAME "drweb-exim"
|
||||
#define PROG_FULLNAME "DrWeb Filter for Exim"
|
||||
#define PROG_NOTE "Note: filter will be started by Exim system automatically after install"
|
||||
-#define CONF_FNAME "drweb_exim.conf"
|
||||
+#define CONF_FNAME "drweb-exim.conf"
|
||||
#endif /* EXIM */
|
||||
|
||||
#if defined(__UNIX_DW)
|
||||
-#if !defined(EMX_DW)
|
||||
-#if defined(FreeBSD_DW)
|
||||
-#define OS_SPEC_CONFNAME "/usr/local/drweb/"CONF_FNAME
|
||||
-#else /* FreeBSD */
|
||||
-#define OS_SPEC_CONFNAME "/opt/drweb/"CONF_FNAME
|
||||
-#endif /* FreeBSD */
|
||||
-#else /* EMX */
|
||||
-#define OS_SPEC_CONFNAME "./"CONF_FNAME
|
||||
-#endif /* EMX */
|
||||
-#define FHS_SPEC_CONFNAME "/etc/drweb/"CONF_FNAME
|
||||
+#define OS_SPEC_CONFNAME PKG_SYSCONFDIR"/"CONF_FNAME
|
||||
+#define FHS_SPEC_CONFNAME "./"CONF_FNAME
|
||||
#endif /* UNIX */
|
||||
#if defined(__WIN32_DW)
|
||||
#define OS_SPEC_CONFNAME ".\\"CONF_FNAME
|
||||
--- dw_files.c.orig 2003-10-20 20:02:09.000000000 +0300
|
||||
+++ dw_files.c
|
||||
@@ -369,22 +369,22 @@ static dwc_bool_t dw_test_spoolfile( con
|
||||
dwc_scan_result_t scan = NULL;
|
||||
dwc_path_t scan_path = NULL;
|
||||
char test_buf1[] = \
|
||||
-"Subject: Standard antivirus test file
|
||||
-Mime-Version: 1.0
|
||||
-Content-Type: multipart/mixed; boundary=\"test\"
|
||||
-Content-Disposition: inline
|
||||
-
|
||||
---test
|
||||
-Content-Type: text/plain; charset=us-ascii
|
||||
-Content-Disposition: inline
|
||||
-
|
||||
-Attachment to this message contains standard antivirus test file.
|
||||
---test
|
||||
-Content-Type: application/x-msdos-program
|
||||
-Content-Disposition: attachment; filename=\"eicar.com\"
|
||||
-
|
||||
+"Subject: Standard antivirus test file \r\n\
|
||||
+Mime-Version: 1.0\r\n\
|
||||
+Content-Type: multipart/mixed; boundary=\"test\"\r\n\
|
||||
+Content-Disposition: inline\r\n\
|
||||
+\r\n\
|
||||
+--test\r\n\
|
||||
+Content-Type: text/plain; charset=us-ascii\r\n\
|
||||
+Content-Disposition: inline\r\n\
|
||||
+\r\n\
|
||||
+Attachment to this message contains standard antivirus test file. \r\n\
|
||||
+--test\r\n\
|
||||
+Content-Type: application/x-msdos-program\r\n\
|
||||
+Content-Disposition: attachment; filename=\"eicar.com\"\r\n\
|
||||
+\r\n\
|
||||
X5O!P%@";
|
||||
- char test_buf2[] = "AP[4\\PZX54(P^)7CC)7}$EICAR-STANDARD-ANTIVIRUS-TEST-FILE!$H+H*
\r\n--test--
\r\n";
|
||||
+ char test_buf2[] = "AP[4\\PZX54(P^)7CC)7}$EICAR-STANDARD-ANTIVIRUS-TEST-FILE!$H+H*\r\n--test--\r\n";
|
||||
|
||||
fd = dw_open_tmpfile( tmpl, name );
|
||||
if( fd < 0 )
|
||||
|
|
|
@ -1,134 +1,84 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2003/09/13 12:58:47 bubuchka Exp $
|
||||
$NetBSD: patch-ad,v 1.2 2003/10/28 16:07:00 bubuchka Exp $
|
||||
|
||||
--- etc/drweb_smf.conf.orig 2003-07-30 17:35:23.000000000 +0300
|
||||
+++ etc/drweb_smf.conf
|
||||
@@ -14,10 +14,10 @@
|
||||
# pid - get daemon address from pidfile, then {ADDRESS} is {PIDFILE}
|
||||
# Examples:
|
||||
# Address = inet:3000@localhost
|
||||
-# Address = local:/usr/local/drweb/run/drwebd.skt
|
||||
-# Address = pid:/usr/local/drweb/run/drwebd.pid
|
||||
-# Address = pid:/var/drweb/run/drwebd.pid, inet:3000@backup_server.example.com
|
||||
-Address = inet:3000@localhost
|
||||
+# Address = local:@DRW_SOCKFILE@
|
||||
+# Address = pid:@DRW_PIDFILE@
|
||||
+# Address = pid:@DRW_PIDFILE@, inet:3000@backup_server.example.com
|
||||
+Address = local:@DRW_SOCKFILE@
|
||||
--- dw_options.c.orig 2003-10-20 20:02:09.000000000 +0300
|
||||
+++ dw_options.c
|
||||
@@ -62,69 +62,61 @@ static const char rcsid[] = "$Id: dw_opt
|
||||
#define PROG_NAME "drweb-courier"
|
||||
#define PROG_FULLNAME "DrWeb Courier-MTA filter"
|
||||
#define PROG_NOTE "Note: filter will be started by Courier-MTA automatically after install"
|
||||
-#define CONF_FNAME "drweb_courier.conf"
|
||||
+#define CONF_FNAME "drweb-courier.conf"
|
||||
#endif /* COURIER */
|
||||
|
||||
# Enable/disable caching resolved daemon host
|
||||
# (useful only if daemon uses TCP/IP communications)
|
||||
@@ -58,7 +58,7 @@ ReportMaxSize = 8192
|
||||
# LocalScan has affect only on connection with first daemon in Address list
|
||||
# If enabled then spool directory must be readable (writeable for EVAL key)
|
||||
# for drwebd process (see drweb32.ini option User)
|
||||
-LocalScan = yes
|
||||
+LocalScan = no
|
||||
#if defined(DW_SENDMAIL)
|
||||
#define PROG_NAME "drweb-smf"
|
||||
#define PROG_FULLNAME "DrWeb Sendmail Filter"
|
||||
#define PROG_NOTE ""
|
||||
-#define CONF_FNAME "drweb_smf.conf"
|
||||
+#define CONF_FNAME "drweb-smf.conf"
|
||||
#endif /* SENDMAIL */
|
||||
|
||||
# Enable or disable daemon rule filter (on/off)
|
||||
RuleFilter = on
|
||||
@@ -72,10 +72,10 @@ FilterAccount = drweb
|
||||
DenyOnOne = yes
|
||||
#if defined(DW_CGP)
|
||||
#define PROG_NAME "drweb-cgp"
|
||||
#define PROG_FULLNAME "DrWeb Plug-in for CommuniGate Pro"
|
||||
#define PROG_NOTE "Note: plug-in will be started by CommuniGate Pro automatically"
|
||||
-#define CONF_FNAME "drweb_cgp.conf"
|
||||
+#define CONF_FNAME "drweb-cgp.conf"
|
||||
#endif /* CGP */
|
||||
|
||||
# List with rules for users or domains to block scanning
|
||||
-DenyList = /etc/drweb/users.conf
|
||||
+DenyList = @PKG_SYSCONFDIR@/users.conf
|
||||
#if defined(DW_MIO)
|
||||
#define PROG_NAME "drweb-mio"
|
||||
#define PROG_FULLNAME "DrWeb Plug-in for Mobico MIO Server"
|
||||
#define PROG_NOTE "Note: plug-in will be started by MIO automatically"
|
||||
-#define CONF_FNAME "drweb_mio.conf"
|
||||
+#define CONF_FNAME "drweb-mio.conf"
|
||||
#endif /* MIO */
|
||||
|
||||
# Directory used for story temporary files
|
||||
-Spool = /var/drweb/spool
|
||||
+Spool = /tmp
|
||||
#if defined(DW_ZMAILER)
|
||||
#define PROG_NAME "drweb-zmailer"
|
||||
#define PROG_FULLNAME "DrWeb Filter for ZMailer"
|
||||
#define PROG_NOTE "Note: filter will be started by ZMailer automatically"
|
||||
-#define CONF_FNAME "drweb_zmailer.conf"
|
||||
+#define CONF_FNAME "drweb-zmailer.conf"
|
||||
#endif /* ZMAILER */
|
||||
|
||||
# Permissions for created spool files
|
||||
SpoolFilesMode = 0600
|
||||
@@ -198,25 +198,25 @@ ScanningErrors = quarantine
|
||||
ProcessingErrors = quarantine
|
||||
#if defined(DW_QMAIL)
|
||||
#define PROG_NAME "qmail-queue"
|
||||
#define PROG_FULLNAME "DrWeb Filter for QMail"
|
||||
#define PROG_NOTE "Note: filter will be started by QMail system automatically after install"
|
||||
-#define CONF_FNAME "drweb_qmail.conf"
|
||||
+#define CONF_FNAME "drweb-qmail.conf"
|
||||
#endif /* QMAIL */
|
||||
|
||||
# Admin mail address (may be unix-local address)
|
||||
-AdminMail = av-master@example.com
|
||||
+AdminMail = postmaster@example.com
|
||||
#if defined(DW_POSTFIX)
|
||||
#define PROG_NAME "drweb-postfix"
|
||||
#define PROG_FULLNAME "DrWeb Filter for Postfix"
|
||||
#define PROG_NOTE "Note: filter will be started by Postfix system automatically after install"
|
||||
-#define CONF_FNAME "drweb_postfix.conf"
|
||||
+#define CONF_FNAME "drweb-postfix.conf"
|
||||
#endif /* POSTFIX */
|
||||
|
||||
# Mail address for redirect action (may be unix-local address)
|
||||
-RedirectMail = quarantine@example.com
|
||||
+RedirectMail = postmaster@example.com
|
||||
#if defined(DW_EXIM)
|
||||
#define PROG_NAME "drweb-exim"
|
||||
#define PROG_FULLNAME "DrWeb Filter for Exim"
|
||||
#define PROG_NOTE "Note: filter will be started by Exim system automatically after install"
|
||||
-#define CONF_FNAME "drweb_exim.conf"
|
||||
+#define CONF_FNAME "drweb-exim.conf"
|
||||
#endif /* EXIM */
|
||||
|
||||
# Filter address, that be used in From: (should be qualified)
|
||||
-FilterMail = DrWEB-DAEMON@example.com
|
||||
+FilterMail = DrWeb-DAEMON@example.com
|
||||
|
||||
# List of unnotificable viruses
|
||||
-UnnotificableVirusesList = /etc/drweb/viruses.conf
|
||||
+UnnotificableVirusesList = @PKG_SYSCONFDIR@/viruses.conf
|
||||
|
||||
# List of unnotificable addresses
|
||||
-UnnotificableAddressesList = /etc/drweb/addresses.conf
|
||||
+UnnotificableAddressesList = @PKG_SYSCONFDIR@/addresses.conf
|
||||
|
||||
# Quarantine directory.
|
||||
# The infected files could be moved in that dir
|
||||
# if you stay this field empty or commented then
|
||||
# infected messages would not been storied
|
||||
-Quarantine = /var/drweb/infected
|
||||
+Quarantine = @DRW_INFECTDIR@
|
||||
|
||||
# Permissions for quarantined files
|
||||
QuarantineFilesMode = 0660
|
||||
@@ -254,15 +254,15 @@ AdminNotify = yes
|
||||
RcptsNotify = yes
|
||||
|
||||
# Files with notification templates
|
||||
-SenderTemplate = /etc/drweb/templates/en-ru/sendmail/virus-sender.msg
|
||||
-AdminTemplate = /etc/drweb/templates/en-ru/sendmail/virus-admin.msg
|
||||
-RcptsTemplate = /etc/drweb/templates/en-ru/sendmail/virus-rcpts.msg
|
||||
+SenderTemplate = @PKG_SYSCONFDIR@/sender-virus.msg
|
||||
+AdminTemplate = @PKG_SYSCONFDIR@/admin-virus.msg
|
||||
+RcptsTemplate = @PKG_SYSCONFDIR@/rcpts-virus.msg
|
||||
|
||||
[SkipNotifications]
|
||||
SenderNotify = yes
|
||||
AdminNotify = no
|
||||
RcptsNotify = no
|
||||
-SenderTemplate = /etc/drweb/templates/en-ru/sendmail/skip-sender.msg
|
||||
+SenderTemplate = @PKG_SYSCONFDIR@/sender-skip.msg
|
||||
AdminTemplate =
|
||||
RcptsTemplate =
|
||||
|
||||
@@ -270,16 +270,16 @@ RcptsTemplate =
|
||||
SenderNotify = yes
|
||||
AdminNotify = yes
|
||||
RcptsNotify = no
|
||||
-SenderTemplate = /etc/drweb/templates/en-ru/sendmail/archive-sender.msg
|
||||
-AdminTemplate = /etc/drweb/templates/en-ru/sendmail/archive-admin.msg
|
||||
+SenderTemplate = @PKG_SYSCONFDIR@/sender-archive.msg
|
||||
+AdminTemplate = @PKG_SYSCONFDIR@/admin-archive.msg
|
||||
RcptsTemplate =
|
||||
|
||||
[ErrorNotifications]
|
||||
SenderNotify = yes
|
||||
AdminNotify = yes
|
||||
RcptsNotify = no
|
||||
-SenderTemplate = /etc/drweb/templates/en-ru/sendmail/error-sender.msg
|
||||
-AdminTemplate = /etc/drweb/templates/en-ru/sendmail/error-admin.msg
|
||||
+SenderTemplate = @PKG_SYSCONFDIR@/sender-error.msg
|
||||
+AdminTemplate = @PKG_SYSCONFDIR@/admin-error.msg
|
||||
RcptsTemplate =
|
||||
|
||||
[RuleFilterNotifications]
|
||||
@@ -287,7 +287,7 @@ SenderNotify = no
|
||||
AdminNotify = yes
|
||||
RcptsNotify = no
|
||||
SenderTemplate =
|
||||
-AdminTemplate = /etc/drweb/templates/en-ru/sendmail/rule-admin.msg
|
||||
+AdminTemplate = @PKG_SYSCONFDIR@/admin-rule.msg
|
||||
RcptsTemplate =
|
||||
|
||||
###################
|
||||
@@ -315,8 +315,8 @@ Sendmail = /usr/sbin/sendmail
|
||||
|
||||
# Definition of Sendmail Milter Address according to sendmail.cf
|
||||
# Note: FAMILY pid is not valid
|
||||
-# MilterAddress = local:/usr/local/drweb/run/drweb-smf.skt
|
||||
-MilterAddress = inet:3001@localhost
|
||||
+# MilterAddress = inet:3001@localhost
|
||||
+MilterAddress = local:@DRW_SMF_SOCKFILE@
|
||||
|
||||
# Timeout for drweb-smf to sendmail connection
|
||||
# (Must be greater that any Timeout. parameter in sendmail.cf)
|
||||
#if defined(__UNIX_DW)
|
||||
-#if !defined(EMX_DW)
|
||||
-#if defined(FreeBSD_DW)
|
||||
-#define OS_SPEC_CONFNAME "/usr/local/etc/drweb/"CONF_FNAME
|
||||
-#else /* FreeBSD */
|
||||
-#define OS_SPEC_CONFNAME "/opt/drweb/"CONF_FNAME
|
||||
-#endif /* FreeBSD */
|
||||
-#else /* EMX */
|
||||
-#define OS_SPEC_CONFNAME "./"CONF_FNAME
|
||||
-#endif /* EMX */
|
||||
-#define FHS_SPEC_CONFNAME "/etc/drweb/"CONF_FNAME
|
||||
+#define OS_SPEC_CONFNAME PKG_SYSCONFDIR"/"CONF_FNAME
|
||||
+#define FHS_SPEC_CONFNAME "./"CONF_FNAME
|
||||
#endif /* UNIX */
|
||||
#if defined(__WIN32_DW)
|
||||
#define OS_SPEC_CONFNAME ".\\"CONF_FNAME
|
||||
|
|
|
@ -1,12 +1,141 @@
|
|||
$NetBSD: patch-ae,v 1.1.1.1 2003/09/13 12:58:47 bubuchka Exp $
|
||||
$NetBSD: patch-ae,v 1.2 2003/10/28 16:07:00 bubuchka Exp $
|
||||
|
||||
--- src/Makefile.nix.tmpl.orig 2003-07-30 17:35:24.000000000 +0300
|
||||
+++ src/Makefile.nix.tmpl
|
||||
@@ -33,6 +33,7 @@ OPTFLAGS = ___OPT_FLAGS___
|
||||
DEFFLAGS = ___POLL_DEF___ -D__UNIX_DW -D$(OS)_DW
|
||||
INCFLAGS =
|
||||
ADD_CFLAGS = $(OPTFLAGS) $(DEFFLAGS) $(INCFLAGS) $(ADDFLAGS)
|
||||
+ADD_CFLAGS += ${CFLAGS} ${PTHREAD_CFLAGS}
|
||||
--- etc/drweb_smf.conf.orig 2003-10-20 20:02:09.000000000 +0300
|
||||
+++ etc/drweb_smf.conf
|
||||
@@ -15,10 +15,10 @@
|
||||
# pid - get daemon address from pidfile, then {ADDRESS} is {PIDFILE}
|
||||
# Examples:
|
||||
# Address = inet:3000@localhost
|
||||
-# Address = local:/usr/local/drweb/run/drwebd.skt
|
||||
-# Address = pid:/usr/local/drweb/run/drwebd.pid
|
||||
-# Address = pid:/var/drweb/run/drwebd.pid, inet:3000@backup_server.example.com
|
||||
-Address = inet:3000@localhost
|
||||
+# Address = local:@DRW_SOCKFILE@
|
||||
+# Address = pid:@DRW_PIDFILE@
|
||||
+# Address = pid:@DRW_PIDFILE@, inet:3000@backup_server.example.com
|
||||
+Address = local:@DRW_SOCKFILE@
|
||||
|
||||
SRCS = \
|
||||
dwc_strings.c\
|
||||
# Enable/disable caching resolved daemon host
|
||||
# (useful only if daemon uses TCP/IP communications)
|
||||
@@ -59,13 +59,13 @@ ReportMaxSize = 8192
|
||||
# LocalScan has affect only on connection with first daemon in Address list
|
||||
# If enabled then spool directory must be readable (writeable for EVAL key)
|
||||
# for drwebd process (see drweb32.ini option User)
|
||||
-LocalScan = yes
|
||||
+LocalScan = no
|
||||
|
||||
# Enable or disable daemon rule filter (on/off)
|
||||
RuleFilter = on
|
||||
|
||||
# User account used by filter
|
||||
-FilterAccount = drweb
|
||||
+FilterAccount = @DRW_USER@
|
||||
|
||||
# If set this parameter to "yes" filter will not become a daemon
|
||||
# (fork and in background), it use full for monitoring filter state with
|
||||
@@ -91,10 +91,10 @@ DenyMode = byAllRecipients
|
||||
DenyByDefault = no
|
||||
|
||||
# List with rules for users or domains to block scanning
|
||||
-DenyList = /etc/drweb/users.conf
|
||||
+DenyList = @PKG_SYSCONFDIR@/users.conf
|
||||
|
||||
# Directory used for story temporary files
|
||||
-Spool = /var/drweb/spool
|
||||
+Spool = /tmp
|
||||
|
||||
# Permissions for created spool files
|
||||
SpoolFilesMode = 0600
|
||||
@@ -255,25 +255,25 @@ ReplyArchiveRestriction = "DrWEB Antivir
|
||||
ReplyError = "DrWEB Antivirus: Message is rejected due to software error."
|
||||
|
||||
# Admin mail address (may be unix-local address)
|
||||
-AdminMail = av-master@example.com
|
||||
+AdminMail = postmaster
|
||||
|
||||
# Mail address for redirect action (may be unix-local address)
|
||||
-RedirectMail = quarantine@example.com
|
||||
+RedirectMail = postmaster
|
||||
|
||||
# Filter address, that be used in From: (should be qualified)
|
||||
-FilterMail = DrWEB-DAEMON@example.com
|
||||
+FilterMail = postmaster
|
||||
|
||||
# List of unnotificable viruses
|
||||
-UnnotificableVirusesList = /etc/drweb/viruses.conf
|
||||
+UnnotificableVirusesList = @PKG_SYSCONFDIR@/viruses.conf
|
||||
|
||||
# List of unnotificable addresses
|
||||
-UnnotificableAddressesList = /etc/drweb/addresses.conf
|
||||
+UnnotificableAddressesList = @PKG_SYSCONFDIR@/addresses.conf
|
||||
|
||||
# Quarantine directory.
|
||||
# The infected files could be moved in that dir
|
||||
# if you stay this field empty or commented then
|
||||
# infected messages would not been storied
|
||||
-Quarantine = /var/drweb/infected
|
||||
+Quarantine = @DRW_INFECTDIR@
|
||||
|
||||
# Permissions for quarantined files
|
||||
QuarantineFilesMode = 0660
|
||||
@@ -311,15 +311,15 @@ AdminNotify = yes
|
||||
RcptsNotify = yes
|
||||
|
||||
# Files with notification templates
|
||||
-SenderTemplate = /etc/drweb/templates/en-ru/sendmail/virus-sender.msg
|
||||
-AdminTemplate = /etc/drweb/templates/en-ru/sendmail/virus-admin.msg
|
||||
-RcptsTemplate = /etc/drweb/templates/en-ru/sendmail/virus-rcpts.msg
|
||||
+SenderTemplate = @PKG_SYSCONFDIR@/sender-virus.msg
|
||||
+AdminTemplate = @PKG_SYSCONFDIR@/admin-virus.msg
|
||||
+RcptsTemplate = @PKG_SYSCONFDIR@/rcpts-virus.msg
|
||||
|
||||
[SkipNotifications]
|
||||
SenderNotify = yes
|
||||
AdminNotify = no
|
||||
RcptsNotify = no
|
||||
-SenderTemplate = /etc/drweb/templates/en-ru/sendmail/skip-sender.msg
|
||||
+SenderTemplate = @PKG_SYSCONFDIR@/sender-skip.msg
|
||||
AdminTemplate =
|
||||
RcptsTemplate =
|
||||
|
||||
@@ -327,16 +327,16 @@ RcptsTemplate =
|
||||
SenderNotify = yes
|
||||
AdminNotify = yes
|
||||
RcptsNotify = no
|
||||
-SenderTemplate = /etc/drweb/templates/en-ru/sendmail/archive-sender.msg
|
||||
-AdminTemplate = /etc/drweb/templates/en-ru/sendmail/archive-admin.msg
|
||||
+SenderTemplate = @PKG_SYSCONFDIR@/sender-archive.msg
|
||||
+AdminTemplate = @PKG_SYSCONFDIR@/admin-archive.msg
|
||||
RcptsTemplate =
|
||||
|
||||
[ErrorNotifications]
|
||||
SenderNotify = yes
|
||||
AdminNotify = yes
|
||||
RcptsNotify = no
|
||||
-SenderTemplate = /etc/drweb/templates/en-ru/sendmail/error-sender.msg
|
||||
-AdminTemplate = /etc/drweb/templates/en-ru/sendmail/error-admin.msg
|
||||
+SenderTemplate = @PKG_SYSCONFDIR@/sender-error.msg
|
||||
+AdminTemplate = @PKG_SYSCONFDIR@/admin-error.msg
|
||||
RcptsTemplate =
|
||||
|
||||
[RuleFilterNotifications]
|
||||
@@ -344,7 +344,7 @@ SenderNotify = no
|
||||
AdminNotify = yes
|
||||
RcptsNotify = no
|
||||
SenderTemplate =
|
||||
-AdminTemplate = /etc/drweb/templates/en-ru/sendmail/rule-admin.msg
|
||||
+AdminTemplate = @PKG_SYSCONFDIR@/admin-rule.msg
|
||||
RcptsTemplate =
|
||||
|
||||
###################
|
||||
@@ -385,8 +385,8 @@ Sendmail = /usr/sbin/sendmail
|
||||
|
||||
# Definition of Sendmail Milter Address according to sendmail.cf
|
||||
# Note: FAMILY pid is not valid
|
||||
-# MilterAddress = local:/usr/local/drweb/run/drweb-smf.skt
|
||||
-MilterAddress = inet:3001@localhost
|
||||
+# MilterAddress = inet:3001@localhost
|
||||
+MilterAddress = local:@DRW_SMF_SOCKFILE@
|
||||
|
||||
# Timeout for drweb-smf to sendmail connection
|
||||
# (Must be greater that any Timeout. parameter in sendmail.cf)
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
===========================================================================
|
||||
$NetBSD: MESSAGE,v 1.1.1.1 2003/09/13 13:01:35 bubuchka Exp $
|
||||
$NetBSD: MESSAGE,v 1.2 2003/10/28 16:07:01 bubuchka Exp $
|
||||
|
||||
To enable this mail filter on your sendmail server, please add the
|
||||
contents of the following file to /etc/mail/sendmail.mc, and then
|
||||
|
@ -7,4 +7,13 @@ rebuild last one:
|
|||
|
||||
${EGDIR}/sendmail.mc.addon
|
||||
|
||||
If you are doing upgrade from drweb-smf version prior to 4.30, it is
|
||||
HIGHLY RECOMMENDED to use the new configuration file. Sample file is
|
||||
located on:
|
||||
|
||||
${EGDIR}/drweb-smf.conf
|
||||
|
||||
Please note also, the ${PKGNAME} is NOT compatible with
|
||||
DrWeb Daemon version prior to 4.30. Please upgrade it as well.
|
||||
|
||||
===========================================================================
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2003/09/13 13:01:35 bubuchka Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2003/10/28 16:07:01 bubuchka Exp $
|
||||
|
||||
DRW_CLIENT_NAME= smf
|
||||
|
||||
|
@ -6,7 +6,6 @@ MAINTAINER= mishka@terabyte.com.ua
|
|||
COMMENT= Sendmail MTA filter for DrWeb Daemon antivirus
|
||||
|
||||
RCD_SCRIPTS= drweb-smf
|
||||
#RCD_SCRIPT_SRC.drweb-smf= ${FILESDIR}/drweb-smf-rcd.src
|
||||
|
||||
PKG_GROUPS= ${DRW_GROUP}
|
||||
PKG_USERS= ${DRW_USER}:${PKG_GROUPS}::DrWeb\\ AntiVirus
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
- It works within troubles on NetBSD-current and just halts on
|
||||
NetBSD-stable (using devel/pth). Within devel/{unproven|mit}-pthreads
|
||||
it works like on NetBSD-current. The problem is covered by broken
|
||||
POSIX threads support.
|
||||
- It works within troubles on NetBSD version prior to 1.6ZD and
|
||||
just halts on NetBSD-stable (using devel/pth). Within
|
||||
devel/{unproven|mit}-pthreads it works like on NetBSD-current.
|
||||
The problem is covered by broken POSIX threads support.
|
||||
|
|
Loading…
Reference in a new issue