This is the return of the infamous double-';' patches, that allow gimp-current to be built on gcc 2.9x.x. Obviously the previous commiter overlooked this fact, thus removed it - so I added some comments in the patch to avoid such situation in the future. I have been told (#gimp/irc.gtk.org), that this has already been fixed in gimp-cvs, so 2.0 won't need it when it will be available.
This commit is contained in:
parent
1c43ede613
commit
11700320e2
4 changed files with 78 additions and 1 deletions
|
@ -1,4 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.15 2004/02/09 14:55:56 moubctez Exp $
|
||||
$NetBSD: distinfo,v 1.16 2004/03/01 17:08:11 mpasternak Exp $
|
||||
|
||||
SHA1 (gimp-2.0pre3.tar.bz2) = 2d832766891d676fdb327b5e70eed1cc3a782c2d
|
||||
Size (gimp-2.0pre3.tar.bz2) = 12102800 bytes
|
||||
SHA1 (patch-aa) = 2045d6025f054d1a8264d57b90b963e6325c4b44
|
||||
SHA1 (patch-ab) = 8ceb0d3320950381f4323faca80d67f975d143b8
|
||||
SHA1 (patch-ac) = b79fa601db849d255f25ba898209a56fcd72b22c
|
||||
|
|
21
gimp-current/patches/patch-aa
Normal file
21
gimp-current/patches/patch-aa
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-aa,v 1.3 2004/03/01 17:08:11 mpasternak Exp $
|
||||
|
||||
Please do NOT touch this patch. It allows gimp-current to be built
|
||||
on gcc earlier than 3.x . If you don't know, what it does, why is it
|
||||
really needed, go and read a bit about differences between standards
|
||||
supported by gcc 3.x and gcc 2.x, but first - do NOT touch it until it's
|
||||
not needed (this has been fixed in gimp-cvs).
|
||||
|
||||
-- dotz@irc.pl
|
||||
|
||||
--- app/core/gimpchannel.c.orig Mon Mar 1 17:34:27 2004
|
||||
+++ app/core/gimpchannel.c
|
||||
@@ -640,7 +640,7 @@ gimp_channel_stroke (GimpItem *item,
|
||||
else if (GIMP_IS_PAINT_INFO (stroke_desc))
|
||||
{
|
||||
GimpImage *gimage = gimp_item_get_image (item);
|
||||
- GimpPaintInfo *paint_info = GIMP_PAINT_INFO (stroke_desc);;
|
||||
+ GimpPaintInfo *paint_info = GIMP_PAINT_INFO (stroke_desc);
|
||||
GimpPaintOptions *paint_options;
|
||||
GimpPaintCore *core;
|
||||
|
27
gimp-current/patches/patch-ab
Normal file
27
gimp-current/patches/patch-ab
Normal file
|
@ -0,0 +1,27 @@
|
|||
$NetBSD: patch-ab,v 1.1 2004/03/01 17:08:11 mpasternak Exp $
|
||||
|
||||
Please see comments in patches/patch-aa before removing this file.
|
||||
Thank you!
|
||||
|
||||
-- dotz@irc.pl
|
||||
|
||||
--- app/vectors/gimpvectors.c.orig Mon Mar 1 17:48:54 2004
|
||||
+++ app/vectors/gimpvectors.c
|
||||
@@ -545,7 +545,7 @@ gimp_vectors_stroke (GimpItem *item,
|
||||
GimpObject *stroke_desc,
|
||||
gboolean use_default_values)
|
||||
{
|
||||
- GimpVectors *vectors = GIMP_VECTORS (item);;
|
||||
+ GimpVectors *vectors = GIMP_VECTORS (item);
|
||||
gboolean retval = FALSE;
|
||||
|
||||
if (! vectors->strokes)
|
||||
@@ -564,7 +564,7 @@ gimp_vectors_stroke (GimpItem *item,
|
||||
else if (GIMP_IS_PAINT_INFO (stroke_desc))
|
||||
{
|
||||
GimpImage *gimage = gimp_item_get_image (item);
|
||||
- GimpPaintInfo *paint_info = GIMP_PAINT_INFO (stroke_desc);;
|
||||
+ GimpPaintInfo *paint_info = GIMP_PAINT_INFO (stroke_desc);
|
||||
GimpPaintOptions *paint_options;
|
||||
GimpPaintCore *core;
|
||||
|
26
gimp-current/patches/patch-ac
Normal file
26
gimp-current/patches/patch-ac
Normal file
|
@ -0,0 +1,26 @@
|
|||
$NetBSD: patch-ac,v 1.1 2004/03/01 17:08:11 mpasternak Exp $
|
||||
|
||||
See comments in patches/patch-aa before removing this file. Thank you!
|
||||
|
||||
-- dotz@irc.pl
|
||||
|
||||
--- app/tools/gimptexttool.c.orig Mon Mar 1 17:50:58 2004
|
||||
+++ app/tools/gimptexttool.c
|
||||
@@ -187,7 +187,7 @@ gimp_text_tool_control (GimpTool *
|
||||
GimpToolAction action,
|
||||
GimpDisplay *gdisp)
|
||||
{
|
||||
- GimpTextTool *text_tool = GIMP_TEXT_TOOL (tool);;
|
||||
+ GimpTextTool *text_tool = GIMP_TEXT_TOOL (tool);
|
||||
|
||||
switch (action)
|
||||
{
|
||||
@@ -218,7 +218,7 @@ gimp_text_tool_button_press (GimpTool
|
||||
GdkModifierType state,
|
||||
GimpDisplay *gdisp)
|
||||
{
|
||||
- GimpTextTool *text_tool = GIMP_TEXT_TOOL (tool);;
|
||||
+ GimpTextTool *text_tool = GIMP_TEXT_TOOL (tool);
|
||||
GimpDrawable *drawable;
|
||||
GimpText *text = NULL;
|
||||
gint off_x = 0;
|
Loading…
Reference in a new issue