Add a MAIN__ to keep f2c happy.

This commit is contained in:
Mark Davies 2008-07-26 22:00:11 +00:00 committed by Thomas Klausner
parent d00755de98
commit 12dcd2cb3f
2 changed files with 15 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2008/06/25 10:56:01 mwdavies Exp $
$NetBSD: distinfo,v 1.2 2008/07/26 22:00:11 mwdavies Exp $
SHA1 (numpy-1.1.0.tar.gz) = c36451e05251599294abfefa386835300e2066d5
RMD160 (numpy-1.1.0.tar.gz) = 046d15df1d4c1733886a61677d6f7e9a836f8ea3
Size (numpy-1.1.0.tar.gz) = 1733403 bytes
SHA1 (patch-aa) = 5dc5d8c1ffb2bbbb6c89656aaa6404ac01e977ed
SHA1 (patch-ab) = 18ef5b7ad8386a4e991bde9f7112ec7b13d2a39c

13
py-numpy/patches/patch-ab Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2008/07/26 22:00:11 mwdavies Exp $
--- numpy/linalg/lapack_litemodule.c.orig 2008-05-26 19:39:50.000000000 +1200
+++ numpy/linalg/lapack_litemodule.c
@@ -16,6 +16,8 @@ typedef struct { float r, i; } f2c_compl
typedef struct { double r, i; } f2c_doublecomplex;
/* typedef long int (*L_fp)(); */
+int FNAME(MAIN_)() { return 0; }
+
extern int FNAME(dgeev)(char *jobvl, char *jobvr, int *n,
double a[], int *lda, double wr[], double wi[],
double vl[], int *ldvl, double vr[], int *ldvr,