diff --git a/SDL-doc-html/Makefile b/SDL-doc-html/Makefile
index b92f258daa..9a8c95f868 100644
--- a/SDL-doc-html/Makefile
+++ b/SDL-doc-html/Makefile
@@ -1,4 +1,4 @@
-# $NetBSD: Makefile,v 1.1 2005/05/31 12:20:02 ianzag Exp $
+# $NetBSD: Makefile,v 1.2 2012/09/24 16:43:02 asau Exp $
#
DISTNAME= sdldoc-html
@@ -11,7 +11,7 @@ HOMEPAGE= http://www.libsdl.org/docs.php
COMMENT= Simple DirectMedia Layer documentation
WRKSRC= ${WRKDIR}/html
-DEST= ${PREFIX}/share/doc/SDL-doc/html
+DEST= ${DESTDIR}${PREFIX}/share/doc/SDL-doc/html
NO_CONFIGURE= YES
NO_BUILD= YES
diff --git a/SDL-doc-ps/Makefile b/SDL-doc-ps/Makefile
index beda6489d7..65d98b8790 100644
--- a/SDL-doc-ps/Makefile
+++ b/SDL-doc-ps/Makefile
@@ -1,4 +1,4 @@
-# $NetBSD: Makefile,v 1.1 2005/05/31 12:20:02 ianzag Exp $
+# $NetBSD: Makefile,v 1.2 2012/09/24 16:43:02 asau Exp $
#
DISTNAME= sdldoc-ps
@@ -11,7 +11,7 @@ HOMEPAGE= http://www.libsdl.org/docs.php
COMMENT= Simple DirectMedia Layer documentation
WRKSRC= ${WRKDIR}
-DEST= ${PREFIX}/share/doc/SDL-doc/ps
+DEST= ${DESTDIR}${PREFIX}/share/doc/SDL-doc/ps
NO_CONFIGURE= YES
NO_BUILD= YES
diff --git a/WEPCrack/Makefile b/WEPCrack/Makefile
index 0edff8bf4c..84672fb8d8 100644
--- a/WEPCrack/Makefile
+++ b/WEPCrack/Makefile
@@ -1,4 +1,4 @@
-# $NetBSD: Makefile,v 1.8 2006/01/13 01:45:31 rillig Exp $
+# $NetBSD: Makefile,v 1.9 2012/09/24 16:43:56 asau Exp $
DISTNAME= WEPCrack-0.1.0
CATEGORIES= security
@@ -17,7 +17,7 @@ REPLACE_PERL+= *.pl
do-install:
set -e; \
cd ${WRKSRC:Q} && for f in *.pl; do \
- ${INSTALL_SCRIPT} "./$$f" ${PREFIX:Q}/bin/; \
+ ${INSTALL_SCRIPT} "./$$f" ${DESTDIR}${PREFIX:Q}/bin/; \
done
.include "../../mk/bsd.pkg.mk"
diff --git a/ap-choke/Makefile b/ap-choke/Makefile
index a0a22d03ae..8bc9f3d869 100644
--- a/ap-choke/Makefile
+++ b/ap-choke/Makefile
@@ -1,4 +1,4 @@
-# $NetBSD: Makefile,v 1.2 2005/06/13 00:09:07 kristerw Exp $
+# $NetBSD: Makefile,v 1.3 2012/09/24 16:47:36 asau Exp $
#
DISTNAME= mod_choke-0.06
@@ -15,7 +15,7 @@ APACHE_MODULE_NAME= mod_choke.so
.include "../../www/apache/module.mk"
post-install:
- ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/mod_choke && \
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/mod_choke
+ ${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/doc/mod_choke && \
+ ${INSTALL_DATA} ${WRKSRC}/README ${DESTDIR}${PREFIX}/share/doc/mod_choke
.include "../../mk/bsd.pkg.mk"
diff --git a/apachebench2/Makefile b/apachebench2/Makefile
index f2382b4348..d80e0bc154 100644
--- a/apachebench2/Makefile
+++ b/apachebench2/Makefile
@@ -1,4 +1,4 @@
-# $NetBSD: Makefile,v 1.14 2010/01/17 12:03:23 thomasklausner Exp $
+# $NetBSD: Makefile,v 1.15 2012/09/24 16:50:03 asau Exp $
# XXX This uses the version of apache2 distfile instead of
# XXX the AP_AB_BASEREVISION from the support/ab.c source.
@@ -18,6 +18,8 @@ BUILD_TARGET= ab
CONFIGURE_ARGS+= --with-ssl=${BUILDLINK_PREFIX.openssl}
CONFIGURE_ARGS+= --enable-static-ab
+INSTALLATION_DIRS= sbin ${PKGMANDIR}/man8
+
do-build:
cd ${WRKSRC}/srclib/pcre && ${SETENV} ${MAKE_ENV} ${MAKE}
cd ${WRKSRC}/srclib/apr-util && ${SETENV} ${MAKE_ENV} ${MAKE}
@@ -25,8 +27,8 @@ do-build:
cd ${WRKSRC}/support && ${SETENV} ${MAKE_ENV} ${MAKE} ab
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/support/ab ${PREFIX}/sbin/apachebench2
- ${INSTALL_MAN} ${WRKSRC}/docs/man/ab.8 ${PREFIX}/${PKGMANDIR}/man8/apachebench2.8
+ ${INSTALL_PROGRAM} ${WRKSRC}/support/ab ${DESTDIR}${PREFIX}/sbin/apachebench2
+ ${INSTALL_MAN} ${WRKSRC}/docs/man/ab.8 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man8/apachebench2.8
.include "../../www/apache2/Makefile.common"
.include "../../security/openssl/buildlink3.mk"
diff --git a/apstget/Makefile b/apstget/Makefile
index 47045d227e..4c13625899 100644
--- a/apstget/Makefile
+++ b/apstget/Makefile
@@ -1,4 +1,4 @@
-# $NetBSD: Makefile,v 1.33 2009/04/09 01:26:24 jsonn Exp $
+# $NetBSD: Makefile,v 1.34 2012/09/24 16:51:01 asau Exp $
DISTNAME= apstget-20060410
CATEGORIES= pkgtools
@@ -24,8 +24,8 @@ do-extract:
cp -R ${FILESDIR} ${WRKSRC}
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/apst-get ${PREFIX}/bin/apstget
- ${INSTALL_SCRIPT} ${WRKSRC}/apstget-wrapper ${PREFIX}/libexec/
+ ${INSTALL_SCRIPT} ${WRKSRC}/apst-get ${DESTDIR}${PREFIX}/bin/apstget
+ ${INSTALL_SCRIPT} ${WRKSRC}/apstget-wrapper ${DESTDIR}${PREFIX}/libexec/
.include "../../mk/bsd.prefs.mk"